summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Laß2021-05-08 21:58:18 +0200
committerMichael Laß2021-05-08 22:12:59 +0200
commit509ba7fdffb85773e43ec60ebf737899c4321570 (patch)
treef1dce4f5f2f9c9b24ebe5543df212a1c2a883631
downloadaur-509ba7fdffb85773e43ec60ebf737899c4321570.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD49
2 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..291ad12f214c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = qt-dab
+ pkgdesc = Software DAB decoder for use with various SDR devices
+ pkgver = 3.71
+ pkgrel = 1
+ url = https://www.sdr-j.tk/
+ arch = x86_64
+ license = GPL2
+ makedepends = libiio
+ depends = faad2
+ depends = fftw
+ depends = hicolor-icon-theme
+ depends = libsamplerate
+ depends = libsndfile
+ depends = portaudio
+ depends = qwt
+ source = https://github.com/JvanKatwijk/qt-dab/archive/refs/tags/Qt-DAB3.71.tar.gz
+ sha256sums = 8a5ec68a7b920ee3b397fa8d9bd2e773f5e95ca5bb5a939dc907f4509d3df84f
+
+pkgname = qt-dab
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c79961b3575d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Michael Lass <bevan@bi-co.net>
+
+# This PKGBUILD is maintained on github:
+# https://github.com/michaellass/AUR
+
+pkgname=qt-dab
+_pkgname=Qt-DAB
+pkgver=3.71
+pkgrel=1
+pkgdesc="Software DAB decoder for use with various SDR devices"
+arch=(x86_64)
+url="https://www.sdr-j.tk/"
+license=('GPL2')
+depends=(faad2 fftw hicolor-icon-theme libsamplerate libsndfile portaudio qwt)
+makedepends=(libiio)
+source=("https://github.com/JvanKatwijk/${pkgname}/archive/refs/tags/${_pkgname}${pkgver}.tar.gz")
+sha256sums=('8a5ec68a7b920ee3b397fa8d9bd2e773f5e95ca5bb5a939dc907f4509d3df84f')
+
+prepare() {
+ sed -i 's/Qt_DAB/Qt-DAB/g' ${pkgname}-${_pkgname}${pkgver}/dab-maxi/${pkgname}.desktop
+}
+
+build() {
+ mkdir -p build-maxi; cd build-maxi
+
+ # cmake flags taken from .travis.yml to match the AppImage build
+ cmake \
+ -Wno-dev \
+ -DTRY_EPG=ON \
+ -DRTLSDR=ON \
+ -DRTL_TCP=ON \
+ -DAIRSPY=ON \
+ -DSDRPLAY=ON \
+ -DSDRPLAY_V3=ON \
+ -DLIMESDR=ON \
+ -DHACKRF=ON \
+ -DPLUTO=ON \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ ../$pkgname-$_pkgname$pkgver/dab-maxi
+
+ make
+}
+
+package() {
+ install -Dm 755 build-maxi/${pkgname}-${pkgver} "${pkgdir}"/usr/bin/${pkgname}
+ install -Dm 644 ${pkgname}-${_pkgname}${pkgver}/dab-maxi/${pkgname}.desktop "${pkgdir}"/usr/share/applications/${pkgname}.desktop
+ install -Dm 644 ${pkgname}-${_pkgname}${pkgver}/dab-maxi/${pkgname}.png "${pkgdir}"/usr/share/icons/hicolor/256x256/apps/${pkgname}.png
+ install -Dm 644 ${pkgname}-${_pkgname}${pkgver}/docs/${pkgname}.pdf "${pkgdir}"/usr/share/doc/${pkgname}/${pkgname}.pdf
+}