summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Laß2023-07-08 08:34:07 +0200
committerMichael Laß2023-07-08 08:34:07 +0200
commita12b28931991e23f15f1c030fe6b9df63db576be (patch)
treeb33b76e6a4b808e4a8bfd64dd64337658a1d39b8
parentf704d03a93b62f098cf09a1a1aa939ed30e1f3d0 (diff)
downloadaur-a12b28931991e23f15f1c030fe6b9df63db576be.tar.gz
Update to 4.7
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD16
2 files changed, 17 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f446f85b3667..1782b46e44ee 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = qt-dab
pkgdesc = Software DAB decoder for use with various SDR devices (version 4, formerly dab-maxi)
- pkgver = 4.6
- pkgrel = 2
+ pkgver = 4.7
+ pkgrel = 1
url = https://www.sdr-j.tk/
arch = x86_64
license = GPL2
@@ -18,7 +18,9 @@ pkgbase = qt-dab
optdepends = libad9361: Support for Pluto
optdepends = rtl-sdr: Support for RTL-SDR
optdepends = libsdrplay: Support for SDRplay
- source = https://github.com/JvanKatwijk/qt-dab/archive/refs/tags/qt-dab-4.6-5.3.tar.gz
- sha256sums = c4b52260bb8b6f6fe8af57e808b95d88cf35e1f297f0fdfdb7dcdbe701beaa0b
+ source = https://github.com/JvanKatwijk/qt-dab/archive/refs/tags/qt-dab-4.7/5.4.tar.gz
+ source = https://github.com/JvanKatwijk/qt-dab/commit/a9d1817f0a940a7b8caf65e29016f94dec3d0c93.patch
+ sha256sums = 1da2813dd03a5d0ca2965e8dfa0152b3aaaeec7e749ce1788ae085af3676cbe5
+ sha256sums = 6c30604dd396fb947bd3865249c17c8271b7487225479ea2e1837e6858a0ccde
pkgname = qt-dab
diff --git a/PKGBUILD b/PKGBUILD
index 63ced0200d0d..0bcf368dbd61 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,13 +4,14 @@
# https://github.com/michaellass/AUR
pkgname=qt-dab
-pkgver=4.6
+pkgver=4.7
_prefix=qt-dab- # name of tarball and contents change from release to release
-_pkgver=4.6-5.3 # tag names may combine v4 and v5
+_tagname=4.7/5.4 # tag names may combine v4 and v5
+_pkgver=${_tagname//\//-}
_fullname=${pkgname}-4
_fullname_s=${pkgname}-s4
_binary=${pkgname}-${pkgver}
-pkgrel=2
+pkgrel=1
pkgdesc="Software DAB decoder for use with various SDR devices (version 4, formerly dab-maxi)"
arch=(x86_64)
url="https://www.sdr-j.tk/"
@@ -22,14 +23,19 @@ optdepends=('airspy: Support for Airspy'
'libad9361: Support for Pluto'
'rtl-sdr: Support for RTL-SDR'
'libsdrplay: Support for SDRplay')
-source=("https://github.com/JvanKatwijk/${pkgname}/archive/refs/tags/${_prefix}${_pkgver}.tar.gz")
-sha256sums=('c4b52260bb8b6f6fe8af57e808b95d88cf35e1f297f0fdfdb7dcdbe701beaa0b')
+source=("https://github.com/JvanKatwijk/${pkgname}/archive/refs/tags/${_prefix}${_tagname}.tar.gz"
+ "https://github.com/JvanKatwijk/qt-dab/commit/a9d1817f0a940a7b8caf65e29016f94dec3d0c93.patch")
+sha256sums=('1da2813dd03a5d0ca2965e8dfa0152b3aaaeec7e749ce1788ae085af3676cbe5'
+ '6c30604dd396fb947bd3865249c17c8271b7487225479ea2e1837e6858a0ccde')
prepare() {
cd "${_prefix}${pkgname}-${_pkgver}"
# The program is officially called Qt-DAB.
sed -i 's/Qt_DAB/Qt-DAB/g' ${_fullname_s}/${_fullname}.desktop
+
+ # https://github.com/JvanKatwijk/qt-dab/pull/294
+ patch -p1 < "${srcdir}"/a9d1817f0a940a7b8caf65e29016f94dec3d0c93.patch
}
build() {