summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Laß2023-04-26 20:24:50 +0200
committerMichael Laß2023-04-26 20:53:10 +0200
commitb14994e0799cdb93ee8f13b07722cd18a56bb4ed (patch)
tree055670c4df90721bfd0a8889ccb9e23e8aece6b4
parentaaa73b68ff537405de810e4e03109d147b73a384 (diff)
downloadaur-b14994e0799cdb93ee8f13b07722cd18a56bb4ed.tar.gz
Update to 4.6
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD31
2 files changed, 19 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 95a633edd787..651b70609014 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = qt-dab
- pkgdesc = Software DAB decoder for use with various SDR devices
- pkgver = 4.4.2
+ pkgdesc = Software DAB decoder for use with various SDR devices (version 4, formerly dab-maxi)
+ pkgver = 4.6
pkgrel = 1
url = https://www.sdr-j.tk/
arch = x86_64
@@ -18,7 +18,7 @@ pkgbase = qt-dab
optdepends = libad9361: Support for Pluto
optdepends = rtl-sdr: Support for RTL-SDR
optdepends = libsdrplay: Support for SDRplay
- source = https://github.com/JvanKatwijk/qt-dab/archive/refs/tags/4.4.2.tar.gz
- sha256sums = a19413f4d2d1adb30169462744c6b2f4eec357ac26c563688f147a73396d552b
+ source = https://github.com/JvanKatwijk/qt-dab/archive/refs/tags/qt-dab-4.6-5.3.tar.gz
+ sha256sums = c4b52260bb8b6f6fe8af57e808b95d88cf35e1f297f0fdfdb7dcdbe701beaa0b
pkgname = qt-dab
diff --git a/PKGBUILD b/PKGBUILD
index 8566b63b93e1..0b2df3d92c95 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,12 +4,14 @@
# https://github.com/michaellass/AUR
pkgname=qt-dab
-pkgver=4.4.2
-_prefix= # name of tarball and contents change from release to release
-_pkgver=4.4.2 # official versioning not necessarily compatible with pacman
-_binary=${pkgname}-${_pkgver}
+pkgver=4.6
+_prefix=qt-dab- # name of tarball and contents change from release to release
+_pkgver=4.6-5.3 # tag names may combine v4 and v5
+_fullname=${pkgname}-4
+_fullname_s=${pkgname}-s4
+_binary=${pkgname}-${pkgver}
pkgrel=1
-pkgdesc="Software DAB decoder for use with various SDR devices"
+pkgdesc="Software DAB decoder for use with various SDR devices (version 4, formerly dab-maxi)"
arch=(x86_64)
url="https://www.sdr-j.tk/"
license=('GPL2')
@@ -21,37 +23,34 @@ optdepends=('airspy: Support for Airspy'
'rtl-sdr: Support for RTL-SDR'
'libsdrplay: Support for SDRplay')
source=("https://github.com/JvanKatwijk/${pkgname}/archive/refs/tags/${_prefix}${_pkgver}.tar.gz")
-sha256sums=('a19413f4d2d1adb30169462744c6b2f4eec357ac26c563688f147a73396d552b')
+sha256sums=('c4b52260bb8b6f6fe8af57e808b95d88cf35e1f297f0fdfdb7dcdbe701beaa0b')
prepare() {
cd "${_prefix}${pkgname}-${_pkgver}"
# The program is officially called Qt-DAB.
- sed -i 's/Qt_DAB/Qt-DAB/g' dab-maxi/${pkgname}.desktop
+ sed -i 's/Qt_DAB/Qt-DAB/g' ${_fullname_s}/${_fullname}.desktop
}
build() {
- mkdir -p build-maxi; cd build-maxi
+ mkdir -p build; cd build
cmake \
-Wno-dev \
- -DTRY_EPG=ON \
- -DRTLSDR=ON \
-DRTL_TCP=ON \
-DAIRSPY=ON \
- -DSDRPLAY_V3=ON \
-DLIMESDR=ON \
-DHACKRF=ON \
-DPLUTO=ON \
-DCMAKE_INSTALL_PREFIX=/usr \
- ../${_prefix}${pkgname}-${_pkgver}/dab-maxi
+ ../${_prefix}${pkgname}-${_pkgver}/${_fullname_s}
make
}
package() {
- install -Dm 755 build-maxi/${_binary} "${pkgdir}"/usr/bin/${pkgname}
- install -Dm 644 ${_prefix}${pkgname}-${_pkgver}/dab-maxi/${pkgname}.desktop "${pkgdir}"/usr/share/applications/${pkgname}.desktop
- install -Dm 644 ${_prefix}${pkgname}-${_pkgver}/dab-maxi/${pkgname}.png "${pkgdir}"/usr/share/icons/hicolor/256x256/apps/${pkgname}.png
- install -Dm 644 ${_prefix}${pkgname}-${_pkgver}/docs/manual.pdf "${pkgdir}"/usr/share/doc/${pkgname}/manual.pdf
+ install -Dm 755 build/${_binary} "${pkgdir}"/usr/bin/${_fullname}
+ install -Dm 644 ${_prefix}${pkgname}-${_pkgver}/${_fullname_s}/${_fullname}.desktop "${pkgdir}"/usr/share/applications/${_fullname}.desktop
+ install -Dm 644 ${_prefix}${pkgname}-${_pkgver}/${_fullname_s}/${_fullname}.png "${pkgdir}"/usr/share/icons/hicolor/256x256/apps/${_fullname}.png
+ install -Dm 644 ${_prefix}${pkgname}-${_pkgver}/qt-dab.pdf "${pkgdir}"/usr/share/doc/${pkgname}/manual.pdf
}