summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Laß2022-02-15 22:58:37 +0100
committerMichael Laß2022-02-15 23:08:41 +0100
commitd2c1ff6909bf5f7861e2fb425e1c8990aa9f0426 (patch)
tree8bb31a26823ccb58f7722ab0ef6f238c06fea6b2
parentec176f29ac48e169da5881f0c8c5ccd9d61bb347 (diff)
downloadaur-d2c1ff6909bf5f7861e2fb425e1c8990aa9f0426.tar.gz
Update to 4.3a
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD19
2 files changed, 18 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3490c9bac13e..10bdb5f06ba5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = qt-dab
pkgdesc = Software DAB decoder for use with various SDR devices
- pkgver = 4.1.1
+ pkgver = 4.3a
pkgrel = 1
url = https://www.sdr-j.tk/
arch = x86_64
@@ -18,7 +18,9 @@ pkgbase = qt-dab
optdepends = libad9361: Support for Pluto
optdepends = rtl-sdr: Support for RTL-SDR
optdepends = libsdrplay: Support for SDRplay
- source = https://github.com/JvanKatwijk/qt-dab/archive/refs/tags/qt-dab-4.11.tar.gz
- sha256sums = 8f664ae37d40d5cf1f36d2dbb48e285bbb0d62257d257622f34d617c7c009594
+ source = https://github.com/JvanKatwijk/qt-dab/archive/refs/tags/qt-dab-4.3a.tar.gz
+ source = https://github.com/JvanKatwijk/qt-dab/commit/59a3761e8a2f9aba8fd6e5b471f9c6508c29f274.patch
+ sha256sums = 3fbaa2f8ea05af99b364d2d47133cc0d79738dfd3a71d96761d3fdc6e4383d28
+ sha256sums = e9e01b0df5afaee4b8cf564334f87ebd91d80725c557f3dcecc7805a54924c8d
pkgname = qt-dab
diff --git a/PKGBUILD b/PKGBUILD
index df054f66b708..45d9107e8143 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,9 +4,11 @@
# https://github.com/michaellass/AUR
pkgname=qt-dab
-pkgver=4.1.1
+pkgver=4.3a
_prefix=qt-dab- # name of tarball and contents change from release to release
-_pkgver=4.11 # official versioning not compatible with pacman
+_pkgver=4.3a # official versioning not compatible with pacman
+#_binary=${pkgname}-${_pkgver}
+_binary=${pkgname}-4.3
pkgrel=1
pkgdesc="Software DAB decoder for use with various SDR devices"
arch=(x86_64)
@@ -19,14 +21,19 @@ optdepends=('airspy: Support for Airspy'
'libad9361: Support for Pluto'
'rtl-sdr: Support for RTL-SDR'
'libsdrplay: Support for SDRplay')
-source=("https://github.com/JvanKatwijk/${pkgname}/archive/refs/tags/${_prefix}${_pkgver}.tar.gz")
-sha256sums=('8f664ae37d40d5cf1f36d2dbb48e285bbb0d62257d257622f34d617c7c009594')
+source=("https://github.com/JvanKatwijk/${pkgname}/archive/refs/tags/${_prefix}${_pkgver}.tar.gz"
+ "https://github.com/JvanKatwijk/qt-dab/commit/59a3761e8a2f9aba8fd6e5b471f9c6508c29f274.patch")
+sha256sums=('3fbaa2f8ea05af99b364d2d47133cc0d79738dfd3a71d96761d3fdc6e4383d28'
+ 'e9e01b0df5afaee4b8cf564334f87ebd91d80725c557f3dcecc7805a54924c8d')
prepare() {
cd "${_prefix}${pkgname}-${_pkgver}"
# The program is officially called Qt-DAB.
sed -i 's/Qt_DAB/Qt-DAB/g' dab-maxi/${pkgname}.desktop
+
+ # Fix CMakeList.txt after introduction of tii-codes
+ patch -p1 < "${srcdir}/59a3761e8a2f9aba8fd6e5b471f9c6508c29f274.patch"
}
build() {
@@ -49,8 +56,8 @@ build() {
}
package() {
- install -Dm 755 build-maxi/${pkgname}-${_pkgver} "${pkgdir}"/usr/bin/${pkgname}
+ install -Dm 755 build-maxi/${_binary} "${pkgdir}"/usr/bin/${pkgname}
install -Dm 644 ${_prefix}${pkgname}-${_pkgver}/dab-maxi/${pkgname}.desktop "${pkgdir}"/usr/share/applications/${pkgname}.desktop
install -Dm 644 ${_prefix}${pkgname}-${_pkgver}/dab-maxi/${pkgname}.png "${pkgdir}"/usr/share/icons/hicolor/256x256/apps/${pkgname}.png
- install -Dm 644 ${_prefix}${pkgname}-${_pkgver}/docs/${pkgname}.pdf "${pkgdir}"/usr/share/doc/${pkgname}/${pkgname}.pdf
+ install -Dm 644 ${_prefix}${pkgname}-${_pkgver}/docs/manual.pdf "${pkgdir}"/usr/share/doc/${pkgname}/manual.pdf
}