summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Laß2023-10-16 21:05:49 +0200
committerMichael Laß2023-10-16 21:18:04 +0200
commitee236357c809252d906a60f90e893d31d178a232 (patch)
treefe60bd370081b6856abee99e6fa66510b7cbb547
parent13befc5bea6f6cde50172bb9d98488720347b7ae (diff)
downloadaur-ee236357c809252d906a60f90e893d31d178a232.tar.gz
Update to 6.2
-rw-r--r--.SRCINFO10
-rw-r--r--0001-Fix-compilation.patch104
-rw-r--r--PKGBUILD32
3 files changed, 19 insertions, 127 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0b52f2aee177..a04da9c15258 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = qt-dab
pkgdesc = Software DAB decoder for use with various SDR devices (formerly dab-maxi)
- pkgver = 6.1
- pkgrel = 2
+ pkgver = 6.2
+ pkgrel = 1
url = https://www.sdr-j.tk/
arch = x86_64
license = GPL2
@@ -18,9 +18,7 @@ pkgbase = qt-dab
optdepends = libad9361: Support for Pluto
optdepends = rtl-sdr: Support for RTL-SDR
optdepends = libsdrplay: Support for SDRplay
- source = https://github.com/JvanKatwijk/qt-dab/archive/refs/tags/qt-dab-6.1.tar.gz
- source = 0001-Fix-compilation.patch
- sha256sums = c29d7ef891364114c1ee47ab396e7e4ea75cd9e9077a27878ed51683cceb7793
- sha256sums = 88315e5e3bee137deb768e2cede03bb33987255ec30f7ea2ce3e567bda90c046
+ source = https://github.com/JvanKatwijk/qt-dab/archive/refs/tags/Qt-DAB-6.2.tar.gz
+ sha256sums = edc4b6f769534b311345d2f01cd5093324eac19b9d88b0098feecf41cc9e89c3
pkgname = qt-dab
diff --git a/0001-Fix-compilation.patch b/0001-Fix-compilation.patch
deleted file mode 100644
index b790057a16aa..000000000000
--- a/0001-Fix-compilation.patch
+++ /dev/null
@@ -1,104 +0,0 @@
-From 4a7eb91cb2ab2cc532998347f98ac9ce0fa63b2d Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Michael=20La=C3=9F?= <bevan@bi-co.net>
-Date: Mon, 2 Oct 2023 22:15:45 +0200
-Subject: [PATCH] Fix compilation
-
-This is a squashed combination of
-* typo (c04750429475fef7c66e39c66a2d48a3b3757873)
-* update for tii-codes (80e7988160a96ca94e429c5ddb255969cdfce2e1)
-* update for tii (e7b64d2632527de7aa995e01a390c9c422e48901)
-all authored by JvanKatwijk <J.vanKatwijk@gmail.com>
----
- qt-dab-s6/qt-dab-6.pro | 6 +++---
- src/support/tii-library/tii-codes.cpp | 16 ++++++++++++++++
- src/support/tii-library/tii-codes.h | 13 ++++---------
- 3 files changed, 23 insertions(+), 12 deletions(-)
-
-diff --git a/qt-dab-s6/qt-dab-6.pro b/qt-dab-s6/qt-dab-6.pro
-index 806e3d0..6252a4f 100755
---- a/qt-dab-s6/qt-dab-6.pro
-+++ b/qt-dab-s6/qt-dab-6.pro
-@@ -415,8 +415,8 @@ CONFIG += pluto-2
- #CONFIG += colibri
- CONFIG += faad
- #CONFIG += fdk-aac
--CONFIG += preCompiled
--#CONFIG += tiiLib
-+#CONFIG += preCompiled
-+CONFIG += tiiLib
- #very experimental, simple server for connecting to a tdc handler
- CONFIG += datastreamer
- #to handle output of embedded an IP data stream, uncomment
-@@ -470,7 +470,7 @@ isEmpty(GITHASHSTRING) {
- # DEFINES += __THREADED_BACKEND
- #
- #for win32, comment out the lines above
-- TARGET = qt-dab32-6.0
-+ TARGET = qt-dab32-6.1
- DESTDIR = /usr/shared/w32-programs/windows-dab32-qt
- INCLUDEPATH += /usr/i686-w64-mingw32/sys-root/mingw/include
- INCLUDEPATH += /usr/i686-w64-mingw32/sys-root/mingw/include/qt5/qwt
-diff --git a/src/support/tii-library/tii-codes.cpp b/src/support/tii-library/tii-codes.cpp
-index cbb0dde..6e025f2 100755
---- a/src/support/tii-library/tii-codes.cpp
-+++ b/src/support/tii-library/tii-codes.cpp
-@@ -169,6 +169,22 @@ double d = sqrt (x * x + y * y);
- return (int)(R * d + 0.5);
- }
-
-+
-+int tiiHandler::distance (position &target,
-+ position &home) {
-+bool dy_sign = target. latitude > home. latitude;
-+double dx;
-+double dy = distance_2 (target. latitude, home. longitude,
-+ home. latitude, home. longitude);
-+ if (dy_sign) // lat1 is "higher" than lat2
-+ dx = distance_2 (target. latitude, target. longitude,
-+ target. latitude, home. longitude);
-+ else
-+ dx = distance_2 (home. latitude, target. longitude,
-+ home. latitude, home. longitude);
-+ return sqrt (dx * dx + dy * dy);
-+}
-+
- int tiiHandler::distance (float latitude1, float longitude1,
- float latitude2, float longitude2) {
- bool dy_sign = latitude1 > latitude2;
-diff --git a/src/support/tii-library/tii-codes.h b/src/support/tii-library/tii-codes.h
-index 33a8c76..59c7f8a 100755
---- a/src/support/tii-library/tii-codes.h
-+++ b/src/support/tii-library/tii-codes.h
-@@ -27,15 +27,9 @@
- #include "dlfcn.h"
- typedef void *HINSTANCE;
-
--class position {
--public:
-- position (float lat, float lon) {
-- latitude = lat;
-- longitude = lon;
-- }
-- ~position () {}
-+typedef struct {
- float latitude;
-- float longiture;
-+ float longitude;
- } position;
-
- typedef struct {
-@@ -71,9 +65,10 @@ public:
- uint16_t, uint8_t, uint8_t);
- void get_coordinates (float *, float *, float *,
- const QString &, const QString &);
-- void get_coordinates (position & float &,
-+ void get_coordinates (position &, float &,
- const QString &, const QString &);
- int distance_2 (float, float, float, float);
-+ int distance (position &, position &);
- int distance (float, float, float, float);
- int corner (position, position);
- bool is_black (uint16_t, uint8_t, uint8_t);
---
-2.42.0
-
diff --git a/PKGBUILD b/PKGBUILD
index 349fccb8ca72..d9e9893e2bad 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,12 +4,11 @@
# https://github.com/michaellass/AUR
pkgname=qt-dab
-pkgver=6.1
-pkgrel=2
+pkgver=6.2
+pkgrel=1
_prefix=qt-dab- # name of tarball and contents change from release to release
-_tagname=$pkgver # tag names may differ from the application version
+_tagname=Qt-DAB- # tag names may differ from the application version
_major=${pkgver::1}
-_pkgver=${_tagname//\//-}
_fullname=${pkgname}-${_major}
_fullname_s=${pkgname}-s${_major}
_binary=${pkgname}-${pkgver}
@@ -24,19 +23,14 @@ optdepends=('airspy: Support for Airspy'
'libad9361: Support for Pluto'
'rtl-sdr: Support for RTL-SDR'
'libsdrplay: Support for SDRplay')
-source=("https://github.com/JvanKatwijk/${pkgname}/archive/refs/tags/${_prefix}${_tagname}.tar.gz"
- "0001-Fix-compilation.patch")
-sha256sums=('c29d7ef891364114c1ee47ab396e7e4ea75cd9e9077a27878ed51683cceb7793'
- '88315e5e3bee137deb768e2cede03bb33987255ec30f7ea2ce3e567bda90c046')
+source=("https://github.com/JvanKatwijk/${pkgname}/archive/refs/tags/${_tagname}${pkgver}.tar.gz")
+sha256sums=('edc4b6f769534b311345d2f01cd5093324eac19b9d88b0098feecf41cc9e89c3')
prepare() {
- cd "${_prefix}${pkgname}-${_pkgver}"
+ cd "${_prefix}${_tagname}${pkgver}"
# The program is officially called Qt-DAB.
sed -i 's/Qt_DAB/Qt-DAB/g' ${_fullname_s}/${_fullname}.desktop
-
- # Fix compilation
- patch -p1 < "${srcdir}"/0001-Fix-compilation.patch
}
build() {
@@ -51,19 +45,23 @@ build() {
-DPLUTO=ON \
-DRTLSDR_LINUX=ON \
-DCMAKE_INSTALL_PREFIX=/usr \
- ../${_prefix}${pkgname}-${_pkgver}/${_fullname_s}
+ ../${_prefix}${_tagname}${pkgver}/${_fullname_s}
make
}
package() {
install -Dm 755 build/${_binary} "${pkgdir}"/usr/bin/${_fullname}
- install -Dm 644 ${_prefix}${pkgname}-${_pkgver}/${_fullname_s}/${_fullname}.desktop "${pkgdir}"/usr/share/applications/${_fullname}.desktop
- install -Dm 644 ${_prefix}${pkgname}-${_pkgver}/${_fullname_s}/${_fullname}.png "${pkgdir}"/usr/share/icons/hicolor/256x256/apps/${_fullname}.png
+ install -Dm 644 ${_prefix}${_tagname}${pkgver}/${_fullname_s}/${_fullname}.desktop "${pkgdir}"/usr/share/applications/${_fullname}.desktop
+ if [ $_major -gt 5 ]; then
+ install -Dm 644 ${_prefix}${_tagname}${pkgver}/${_fullname}.png "${pkgdir}"/usr/share/icons/hicolor/256x256/apps/${_fullname}.png
+ else
+ install -Dm 644 ${_prefix}${_tagname}${pkgver}/${_fullname_s}/${_fullname}.png "${pkgdir}"/usr/share/icons/hicolor/256x256/apps/${_fullname}.png
+ fi
if [ $_major -gt 4 ]; then
- install -Dm 644 ${_prefix}${pkgname}-${_pkgver}/docs/manual-${_major}.pdf "${pkgdir}"/usr/share/doc/${pkgname}/manual.pdf
+ install -Dm 644 ${_prefix}${_tagname}${pkgver}/docs/manual-${_major}.pdf "${pkgdir}"/usr/share/doc/${pkgname}/manual.pdf
else
- install -Dm 644 ${_prefix}${pkgname}-${_pkgver}/qt-dab.pdf "${pkgdir}"/usr/share/doc/${pkgname}/manual.pdf
+ install -Dm 644 ${_prefix}${_tagname}${pkgver}/qt-dab.pdf "${pkgdir}"/usr/share/doc/${pkgname}/manual.pdf
fi
}