summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLiam Greenough2017-09-17 16:13:49 +1000
committerLiam Greenough2017-09-17 16:13:49 +1000
commit3a851dc6c1ae0355700fcfa38a35ca65c8fd893f (patch)
tree1f28e2fa200b90ebc3876e8732c359e9af20fbd1
downloadaur-3a851dc6c1ae0355700fcfa38a35ca65c8fd893f.tar.gz
Init.
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD32
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5d9af86dc3cc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = qt-dab-git
+ pkgdesc = software dab decoder for use with a dabstick, airspy or sdrplay for RPI and PC
+ pkgver = VERSION
+ pkgrel = 1
+ url = http://www.sdr-j.tk
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ depends = qt5-base
+ depends = libsndfile
+ depends = fftw
+ depends = portaudio
+ depends = faad2
+ depends = zlib
+ depends = rtl-sdr
+ depends = qwt
+ depends = libsamplerate
+ provides = qt-dab-git
+ conflicts = qt-dab
+ conflicts = sdr-j-dabreciever
+ source = git+https://github.com/JvanKatwijk/qt-dab.git
+ md5sums = SKIP
+
+pkgname = qt-dab-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..db548f3c1ba7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Liam Greenough <beacon515@gmail.com>
+pkgname=qt-dab-git
+pkgver=VERSION
+pkgrel=1
+pkgdesc="software dab decoder for use with a dabstick, airspy or sdrplay for RPI and PC"
+arch=('i686' 'x86_64')
+url="http://www.sdr-j.tk"
+license=('GPL2')
+depends=('qt5-base' 'libsndfile' 'fftw' 'portaudio' 'faad2' 'zlib' 'rtl-sdr' 'qwt' 'libsamplerate')
+makedepends=('git')
+provides=('qt-dab-git')
+conflicts=('qt-dab' 'sdr-j-dabreciever')
+source=('git+https://github.com/JvanKatwijk/qt-dab.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/qt-dab"
+
+# Git, no tags available
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+
+}
+
+build() {
+ cd "$srcdir/qt-dab"
+ qmake qt-dab.pro
+ make
+}
+
+package() {
+ cd "$srcdir/qt-dab"
+}