summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLiam Greenough2017-09-17 17:08:51 +1000
committerLiam Greenough2017-09-17 17:08:51 +1000
commit910bf5bc199611cb4322a5cc82af977cb480b999 (patch)
tree97896318b901385c9cb46ca5d6096487f1107457
parent3a30221bd7239c15e6a38c32f988ab41eb745a4c (diff)
downloadaur-910bf5bc199611cb4322a5cc82af977cb480b999.tar.gz
Final, hopefully.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
-rw-r--r--qwt.patch15
3 files changed, 27 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0fdd3e97d96c..fee77a3c8c0e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = qt-dab-git
pkgdesc = software dab decoder for use with a dabstick, airspy or sdrplay for RPI and PC
- pkgver = VERSION
+ pkgver = r306.0b6c309
pkgrel = 1
url = http://www.sdr-j.tk
arch = i686
@@ -20,7 +20,9 @@ pkgbase = qt-dab-git
conflicts = qt-dab
conflicts = sdr-j-dabreciever
source = git+https://github.com/JvanKatwijk/qt-dab.git
+ source = qwt.patch
md5sums = SKIP
+ md5sums = d5a96a8f58268c892f33e9ed56fc16e9
pkgname = qt-dab-git
diff --git a/PKGBUILD b/PKGBUILD
index 19f12625cfb6..13b74ba06000 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Liam Greenough <beacon515@gmail.com>
pkgname=qt-dab-git
-pkgver=VERSION
+pkgver=r306.0b6c309
pkgrel=1
pkgdesc="software dab decoder for use with a dabstick, airspy or sdrplay for RPI and PC"
arch=('i686' 'x86_64')
@@ -10,8 +10,9 @@ depends=('qt5-base' 'libsndfile' 'fftw' 'portaudio' 'faad2' 'zlib' 'rtl-sdr' 'qw
makedepends=('git')
provides=('qt-dab-git')
conflicts=('qt-dab' 'sdr-j-dabreciever')
-source=('git+https://github.com/JvanKatwijk/qt-dab.git')
-md5sums=('SKIP')
+source=('git+https://github.com/JvanKatwijk/qt-dab.git' 'qwt.patch')
+md5sums=('SKIP'
+ 'd5a96a8f58268c892f33e9ed56fc16e9')
pkgver() {
cd "$srcdir/qt-dab"
@@ -28,5 +29,9 @@ build() {
}
package() {
- cd "$srcdir/qt-dab"
+ mkdir $pkgdir/usr/
+ mkdir $pkgdir/usr/bin
+ mkdir $pkgdir/
+ cd "$srcdir/qt-dab/linux-bin"
+ mv * /$pkgdir/usr/bin/qt-dab
}
diff --git a/qwt.patch b/qwt.patch
new file mode 100644
index 000000000000..bfb04fc009b6
--- /dev/null
+++ b/qwt.patch
@@ -0,0 +1,15 @@
+diff --git a/qt-dab.pro b/qt-dab.pro
+index 29176ad..e760609 100644
+--- a/qt-dab.pro
++++ b/qt-dab.pro
+@@ -285,8 +285,8 @@ spectrum {
+ HEADERS += ./includes/scopes-qwt6
+ SOURCES += ./optional-scope/spectrum-handler.cpp
+ #correct this for the correct path to the qwt6 library on your system
+-# LIBS += -lqwt
+- LIBS += -lqwt-qt5
++ LIBS += -lqwt
++# LIBS += -lqwt-qt5
+ }
+
+ # devices