summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHarry Jeffery2015-08-05 22:09:01 +0100
committerHarry Jeffery2015-08-05 22:09:01 +0100
commitff4fd625b3bd81ab55c4fa29d64d8f0ce9747df9 (patch)
tree0fd08e6744821a85b6b59788fff006de340aaffb
downloadaur-ff4fd625b3bd81ab55c4fa29d64d8f0ce9747df9.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD30
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..24c946143b5e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = qt-inspector-git
+ pkgdesc = A tool to visualize tree of widgets in a Qt application
+ pkgver = r64.b16fb85
+ pkgrel = 1
+ url = https://github.com/robertknight/Qt-Inspector
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = cmake
+ depends = qt4>=4.5
+ depends = protobuf
+ source = git://github.com/robertknight/Qt-Inspector
+ sha1sums = SKIP
+
+pkgname = qt-inspector-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dc7de2b2eb16
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Harry Jeffery <harry|@|exec64|.|co|.|uk>
+# Contributor: Dan Vratil <vratil@progdansoft.com>
+
+pkgname=qt-inspector-git
+pkgver=r64.b16fb85
+pkgrel=1
+pkgdesc="A tool to visualize tree of widgets in a Qt application"
+url="https://github.com/robertknight/Qt-Inspector"
+arch=('i686' 'x86_64')
+license=('GPL3')
+depends=('qt4>=4.5' 'protobuf')
+makedepends=('git' 'cmake')
+source=("git://github.com/robertknight/Qt-Inspector")
+sha1sums=('SKIP')
+
+pkgver() {
+ cd Qt-Inspector
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd Qt-Inspector
+ cmake -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+package() {
+ cd Qt-Inspector
+ make DESTDIR="$pkgdir" install
+}