summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp A2015-08-05 22:09:01 +0100
committerPhilipp A2017-05-10 10:44:17 +0200
commit02e4a5308d68913eb22c1cecb7c6598d2612ba9b (patch)
tree5ec2e55c2996e89d68014f8a4a57f9edb9b9a522
downloadaur-02e4a5308d68913eb22c1cecb7c6598d2612ba9b.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD33
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..16449532ff0e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = qt-inspector-qt5-git
+ pkgdesc = A tool to visualize tree of widgets in a Qt application
+ pkgver = r68.cce98a1
+ pkgrel = 1
+ url = https://github.com/robertknight/Qt-Inspector
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = cmake
+ depends = qt5-base
+ depends = protobuf
+ source = git://github.com/robertknight/Qt-Inspector
+ sha1sums = SKIP
+
+pkgname = qt-inspector-qt5-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..8e8b6cc898f6
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/src/
+/pkg/
+/Qt-Inspector/
+/*.pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..28e6a72f718d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Philipp A. <flying-sheep@web.de>
+# Contributor: Harry Jeffery <harry|@|exec64|.|co|.|uk>
+# Contributor: Dan Vratil <vratil@progdansoft.com>
+
+pkgname=qt-inspector-qt5-git
+pkgver=r68.cce98a1
+pkgrel=1
+pkgdesc='A tool to visualize tree of widgets in a Qt application'
+url='https://github.com/robertknight/Qt-Inspector'
+arch=(i686 x86_64)
+license=(GPL3)
+depends=(qt5-base protobuf)
+makedepends=(git cmake)
+source=('git://github.com/robertknight/Qt-Inspector')
+sha1sums=(SKIP)
+
+pkgver() {
+ cd Qt-Inspector
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd Qt-Inspector
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DUSE_QT5=ON
+ make
+}
+
+package() {
+ cd Qt-Inspector
+ make DESTDIR="$pkgdir" install
+}