summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLinArcX2018-07-20 20:52:26 +0430
committerLinArcX2018-07-20 20:52:26 +0430
commita30eeecfeb41f6949155c8b0c8892dd77a2d9217 (patch)
treec9f2457e4edf8cba35e865143b12de1ca4bb5078
parenta1f624d8f9b0035146593c64653a41fd1d92895b (diff)
downloadaur-a30eeecfeb41f6949155c8b0c8892dd77a2d9217.tar.gz
add sha256sum
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD14
2 files changed, 18 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 20d37756fbff..42d89e0820f2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,16 @@
pkgbase = qt-online-installer
pkgdesc = Qt Online Installer for the optimal Qt installation experience.
- pkgver = 3.0
+ pkgver = r2.a1f624d
pkgrel = 1
url = https://www.qt.io/download
arch = x86_64
license = GPL-3.0
source = http://download.qt.io/official_releases/online_installers/qt-unified-linux-x64-online.run
- sha256sums = SKIP
+ source = qt-online-installer.desktop
+ source = qt-online-installer.svg
+ sha256sums = 3926eff634f7a798bd8f7f8a3625d8e9db8179e7efaf4c59eeff9f1eae7e95f5
+ sha256sums = b033313135bb37fc14d26c8e5df2b48082e1bdd5b98893edd004706bd60d037c
+ sha256sums = 77bfaf98cf7734451e794f5bffd152e8b51d21d0d4114c64328ad7cf27aec4dc
pkgname = qt-online-installer
diff --git a/PKGBUILD b/PKGBUILD
index 312621324fdd..0554bc480512 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname='qt-online-installer'
_pkgname='qt-online-installer'
-pkgver=3.0
+pkgver=r2.a1f624d
_pkgverminor=3.0.5
pkgrel=1
pkgdesc="Qt Online Installer for the optimal Qt installation experience."
@@ -14,9 +14,19 @@ source=("http://download.qt.io/official_releases/online_installers/qt-unified-li
"qt-online-installer.svg")
#"/mnt/D/Document/WorkSpace/Packages/AUR/qt-online-installer/sources.tar.gz" #"http://ftp.jaist.ac.jp/pub/qtproject/archive/online_installers/${pkgver}/qt-unified-linux-x64-$_pkgverminor-online.run")
# source_i686=("http://ftp.jaist.ac.jp/pub/qtproject/archive/online_installers/${pkgver}/qt-unified-linux-x32-$_pkgverminor-online.run")
-sha256sums=('SKIP')
+sha256sums=('3926eff634f7a798bd8f7f8a3625d8e9db8179e7efaf4c59eeff9f1eae7e95f5'
+ 'b033313135bb37fc14d26c8e5df2b48082e1bdd5b98893edd004706bd60d037c'
+ '77bfaf98cf7734451e794f5bffd152e8b51d21d0d4114c64328ad7cf27aec4dc')
# sha256sums_i686=('SKIP')
+pkgver() {
+ cd "$srcdir"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
package() {
cd $srcdir