summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLinArcX2018-07-20 20:39:18 +0430
committerLinArcX2018-07-20 20:39:18 +0430
commitf1a6de3940bd3588b653afe875f6b1c0167ace85 (patch)
treee589fae4a8834fc3eed02dae246c45cb24d22b1d
downloadaur-f1a6de3940bd3588b653afe875f6b1c0167ace85.tar.gz
Init AUR Repo
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD40
-rw-r--r--qt-online-installer.desktop9
-rw-r--r--qt-online-installer.svg6
4 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..20d37756fbff
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = qt-online-installer
+ pkgdesc = Qt Online Installer for the optimal Qt installation experience.
+ pkgver = 3.0
+ pkgrel = 1
+ url = https://www.qt.io/download
+ arch = x86_64
+ license = GPL-3.0
+ source = http://download.qt.io/official_releases/online_installers/qt-unified-linux-x64-online.run
+ sha256sums = SKIP
+
+pkgname = qt-online-installer
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..325d14ba66e5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: LinArcx <linarcx@gmail.com>
+
+pkgname='qt-online-installer'
+_pkgname='qt-online-installer'
+pkgver=3.0
+_pkgverminor=3.0.5
+pkgrel=1
+pkgdesc="Qt Online Installer for the optimal Qt installation experience."
+arch=('x86_64')
+url="https://www.qt.io/download"
+license=('GPL-3.0')
+source=("http://download.qt.io/official_releases/online_installers/qt-unified-linux-x64-online.run") #"/mnt/D/Document/WorkSpace/Packages/AUR/qt-online-installer/sources.tar.gz" #"http://ftp.jaist.ac.jp/pub/qtproject/archive/online_installers/${pkgver}/qt-unified-linux-x64-$_pkgverminor-online.run")
+# source_i686=("http://ftp.jaist.ac.jp/pub/qtproject/archive/online_installers/${pkgver}/qt-unified-linux-x32-$_pkgverminor-online.run")
+sha256sums=('SKIP')
+# sha256sums_i686=('SKIP')
+
+package() {
+ cd $srcdir
+
+ _pkg=linux-x64
+ if [ "${CARCH}" = "i686" ]; then
+ _pkg=linux-x32
+ fi
+
+ install -d "${pkgdir}/usr/bin"
+ install -d "${pkgdir}/usr/share/applications"
+ install -d "${pkgdir}/usr/share/icons"
+
+# cp -r "${srcdir}/${_pkg}/"* "${pkgdir}/opt/${_pkgname}" -R
+# cp $srcdir/QEELauncher.sh ${pkgdir}/opt/${_pkgname}
+# cp $srcdir/${pkgname}.svg ${pkgdir}/usr/share/icons/${pkgname}
+# cp $srcdir/${pkgname}.desktop ${pkgdir}/usr/share/applications/${pkgname}
+
+ # ln -s /opt/${pkgname}/MyQxEntityEditorLauncher.sh "${pkgdir}"/usr/bin/MyQxEntityEditorLauncher.sh
+ install -Dm644 ${srcdir}/qt-unified-linux-x64-online.run ${pkgdir}/usr/bin/qt-unified-linux-x64-online.run
+ install -Dm755 ${srcdir}/${pkgname}.svg ${pkgdir}/usr/share/icons/${pkgname}.svg
+ install -Dm755 ${srcdir}/${pkgname}.desktop ${pkgdir}/usr/share/applications/${pkgname}.desktop
+
+ chmod +x ${pkgdir}/usr/bin/qt-unified-linux-x64-online.run
+} \ No newline at end of file
diff --git a/qt-online-installer.desktop b/qt-online-installer.desktop
new file mode 100644
index 000000000000..d63d7c1b2124
--- /dev/null
+++ b/qt-online-installer.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+
+Type=Application
+Name=qt-online-installer
+Icon=/usr/share/icons/qt-online-installer.svg
+Exec=/usr/bin/qt-unified-linux-x64-online.run
+Comment=Qt Online Installer for the optimal Qt installation experience
+Categories=Development;IDE;
+Terminal=false \ No newline at end of file
diff --git a/qt-online-installer.svg b/qt-online-installer.svg
new file mode 100644
index 000000000000..c5e52b9a435c
--- /dev/null
+++ b/qt-online-installer.svg
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<svg xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" viewBox="0 0 50 50" version="1.1" width="500px" height="500px">
+<g id="surface1">
+<path style=" " d="M 9.433594 8 C 8.976563 8 8.417969 8.234375 8.101563 8.554688 C 6.265625 10.375 4.425781 12.191406 2.578125 14.003906 C 2.257813 14.316406 2 14.878906 2 15.363281 L 2 15.367188 C 2.007813 23.761719 2.007813 40.808594 2.007813 40.996094 L 2.007813 41.996094 L 3.007813 41.996094 C 3.195313 41.996094 28.183594 41.992188 40.550781 42 C 41.050781 42 41.617188 41.742188 41.941406 41.421875 L 41.945313 41.417969 C 43.761719 39.609375 45.585938 37.808594 47.417969 36.015625 C 47.761719 35.675781 48 35.09375 48 34.617188 C 47.992188 26.246094 48 9 48 9 L 48 8 Z M 9.480469 10 L 46 10 C 46 11.253906 45.992188 26.550781 46 34.605469 C 44.171875 36.394531 42.347656 38.195313 40.535156 40 C 28.492188 39.992188 5.441406 39.992188 4.007813 39.996094 C 4.007813 38.597656 4.007813 23.496094 4 15.410156 C 5.832031 13.613281 7.660156 11.8125 9.480469 10 Z M 19.09375 14 C 18.777344 14 18.464844 14.007813 18.148438 14.019531 C 17.382813 14.050781 16.628906 14.179688 15.890625 14.394531 C 14.21875 14.890625 12.964844 15.882813 12.234375 17.464844 C 11.980469 18.015625 11.765625 18.589844 11.59375 19.171875 C 11.121094 20.765625 11.023438 22.40625 11.003906 24.050781 C 10.992188 25.160156 11.058594 26.265625 11.21875 27.363281 C 11.375 28.390625 11.617188 29.394531 12.027344 30.359375 C 12.769531 32.09375 14.074219 33.183594 15.910156 33.660156 C 17.507813 34.078125 19.121094 34.132813 20.785156 33.902344 C 21.621094 35.25 22.464844 36.617188 23.320313 38 C 24.332031 37.53125 25.292969 37.089844 26.28125 36.632813 C 25.464844 35.335938 24.679688 34.082031 23.902344 32.84375 C 24.242188 32.539063 24.578125 32.269531 24.875 31.964844 C 25.644531 31.15625 26.109375 30.183594 26.414063 29.125 C 26.847656 27.613281 26.957031 26.058594 26.996094 24.5 C 27.023438 23.292969 26.945313 22.089844 26.78125 20.894531 C 26.625 19.78125 26.355469 18.695313 25.894531 17.660156 C 25.109375 15.902344 23.773438 14.800781 21.894531 14.316406 C 20.96875 14.082031 20.035156 14.003906 19.09375 14 Z M 31 16 L 31 20 L 29 20 L 29 23 L 31 23 L 31 30 C 31 30.769531 31.160156 31.613281 31.46875 32.332031 C 31.726563 32.9375 32.160156 33.363281 32.765625 33.625 C 33.226563 33.820313 33.707031 33.921875 34.203125 33.96875 C 35.152344 34.054688 36.253906 33.902344 37.1875 33.738281 C 37.453125 33.691406 37.714844 33.636719 38 33.582031 C 37.972656 32.765625 37.929688 31.671875 37.863281 30.886719 C 37.757813 30.878906 37.703125 30.863281 37.644531 30.867188 C 37.019531 30.890625 36.230469 30.988281 35.605469 31 C 35.335938 31.003906 35.0625 30.976563 34.796875 30.921875 C 34.460938 30.851563 34.238281 30.628906 34.144531 30.292969 C 34.109375 30.152344 34.070313 30.015625 34.0625 29.875 C 34.019531 29.347656 34.003906 28.53125 34 28 C 33.988281 26.109375 34 23 34 23 L 38 23 L 38 20 L 34 20 L 34 16 Z M 18.996094 17.019531 C 19.589844 17.019531 20.179688 17.089844 20.769531 17.234375 C 21.789063 17.484375 22.550781 18.03125 23.019531 18.886719 C 23.429688 19.621094 23.65625 20.40625 23.761719 21.214844 C 23.886719 22.191406 23.945313 23.175781 24 23.785156 C 23.949219 25.476563 23.910156 26.789063 23.535156 28.074219 C 23.457031 28.347656 23.359375 28.617188 23.25 28.878906 C 22.828125 29.910156 21.996094 30.539063 20.816406 30.8125 C 19.625 31.085938 18.417969 31.089844 17.21875 30.820313 C 15.960938 30.539063 15.113281 29.855469 14.667969 28.765625 C 14.308594 27.882813 14.117188 26.972656 14.066406 26.042969 C 14.007813 25 13.984375 23.953125 14.015625 22.910156 C 14.042969 21.78125 14.210938 20.664063 14.621094 19.589844 C 14.707031 19.367188 14.8125 19.148438 14.921875 18.9375 C 15.390625 18.050781 16.171875 17.496094 17.21875 17.234375 C 17.808594 17.089844 18.402344 17.019531 18.996094 17.019531 Z "/>
+</g>
+</svg>