aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDonald Carr2023-03-21 14:32:06 -0700
committerDonald Carr2023-03-21 14:33:22 -0700
commit10b0ec3763c7782bbdd6bfd1b1fda106cbb40de0 (patch)
tree65a9cb9f213bf675012c1d339344a82c43abd9cc
parent01b4de520b4c1ca585aca0fc765cc4b856e42746 (diff)
downloadaur-10b0ec3763c7782bbdd6bfd1b1fda106cbb40de0.tar.gz
Enable mold lto which requires the use of onetbb-git at present
Change-Id: Ie2d8d8be95facd8356c1d87d2350581ceedb29c7
-rw-r--r--PKGBUILD6
1 files changed, 6 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 005df2bcbb71..a9afc890c7be 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,6 @@
# Maintainer: Donald Carr <d at chaos-reins dot com>
+# warning, you will need to install onetbb-git due to a bug which has yet to be included in a tagged release
# Cross compilation is currently broken due to Qt 6 changes
#set -x
@@ -225,11 +226,16 @@ build() {
#export CXX=clang++
#-DCMAKE_BUILD_TYPE=RelWithDebInfo \
#-DFEATURE_separate_debug_info=ON \
+
+ # pch are massive running out of space on 22GB drive vs 6GB build
local _configure_line_fn=configure_line
local _configure_line="cmake \
-GNinja \
-DCMAKE_BUILD_TYPE=Rel \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DFEATURE_separate_debug_info=ON \
-DBUILD_WITH_PCH=OFF \
+ -DCMAKE_INTERPROCEDURAL_OPTIMIZATION=ON \
-DFEATURE_reduce_exports=ON \
-DFEATURE_reduce_relocations=ON \
-DQT_BUILD_TESTS=OFF \