aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDonald Carr2019-04-03 01:13:01 -0700
committerDonald Carr2019-04-03 01:13:01 -0700
commit111f82a1e9df97fdb6721b8293f967bf33df2ee5 (patch)
treeba822acc75ad01ac424df2d99fa57028eeb7412d
parentb3f0aee5c7f1933d3316a75294111162809d8b0a (diff)
downloadaur-111f82a1e9df97fdb6721b8293f967bf33df2ee5.tar.gz
Integrate float patch
-rw-r--r--0005-Fix-qtdeclarative-build-configured-with-qreal-float.patch35
-rw-r--r--PKGBUILD2
2 files changed, 37 insertions, 0 deletions
diff --git a/0005-Fix-qtdeclarative-build-configured-with-qreal-float.patch b/0005-Fix-qtdeclarative-build-configured-with-qreal-float.patch
new file mode 100644
index 000000000000..22a46290f7e1
--- /dev/null
+++ b/0005-Fix-qtdeclarative-build-configured-with-qreal-float.patch
@@ -0,0 +1,35 @@
+From d9aad59d4144f5bf725893b5a008fe5c52ff5634 Mon Sep 17 00:00:00 2001
+From: Donald Carr <d@chaos-reins.com>
+Date: Thu, 28 Mar 2019 22:23:54 -0700
+Subject: [PATCH 5/7] Fix qtdeclarative build configured with -qreal=float
+
+There is a sole point of failure in Qt 5.13 beta1
+
+Change-Id: I58a41e310604a8bccbf14f463f734877d6a65a73
+Reviewed-by: Laszlo Agocs <laszlo.agocs@qt.io>
+---
+ src/plugins/scenegraph/openvg/qsgopenvghelpers.cpp | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/src/plugins/scenegraph/openvg/qsgopenvghelpers.cpp b/src/plugins/scenegraph/openvg/qsgopenvghelpers.cpp
+index 6bc99d32a..ab5cfb48b 100644
+--- a/src/plugins/scenegraph/openvg/qsgopenvghelpers.cpp
++++ b/src/plugins/scenegraph/openvg/qsgopenvghelpers.cpp
+@@ -220,10 +220,10 @@ void qDrawTiled(VGImage image, const QSize imageSize, const QRectF &targetRect,
+ void qDrawBorderImage(VGImage image, const QSizeF &textureSize, const QRectF &targetRect, const QRectF &innerTargetRect, const QRectF &subSourceRect)
+ {
+ // Create normalized margins
+- QMarginsF margins(qMax(innerTargetRect.left() - targetRect.left(), 0.0),
+- qMax(innerTargetRect.top() - targetRect.top(), 0.0),
+- qMax(targetRect.right() - innerTargetRect.right(), 0.0),
+- qMax(targetRect.bottom() - innerTargetRect.bottom(), 0.0));
++ QMarginsF margins(qMax(innerTargetRect.left() - targetRect.left(), qreal(0.0)),
++ qMax(innerTargetRect.top() - targetRect.top(), qreal(0.0)),
++ qMax(targetRect.right() - innerTargetRect.right(), qreal(0.0)),
++ qMax(targetRect.bottom() - innerTargetRect.bottom(), qreal(0.0)));
+
+ QRectF sourceRect(0, 0, textureSize.width(), textureSize.height());
+
+--
+2.21.0
+
diff --git a/PKGBUILD b/PKGBUILD
index b59e576cefef..598e88278082 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -396,6 +396,8 @@ fi
if $_patching; then
echo "Patching source"
+ cd ${_srcdir}/qtdeclarative
+ patch -p1 < ${startdir}/0005-Fix-qtdeclarative-build-configured-with-qreal-float.patch
fi
rm -Rf ${_bindir}