aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDonald Carr2016-06-03 18:25:37 -0700
committerDonald Carr2016-06-03 18:25:37 -0700
commit22159b028538b09dde6fd5ab9a073640a2a1e7a6 (patch)
tree8ddecaf783eba8afc77c27be8e0c106b13ef03d3
parent88f71609cf79c11fcbce99ac0a3c585a2409881d (diff)
parentb603e59d12e3c07647a5d64f7b642adbe8a638c3 (diff)
downloadaur-22159b028538b09dde6fd5ab9a073640a2a1e7a6.tar.gz
Merge remote-tracking branch 'pi2/master'
Change-Id: Ie8597806e1d212e9462b10d8dec16627c834e5cf
-rw-r--r--.SRCINFO10
-rw-r--r--0001-Always-define-arm_thumb.patch25
-rw-r--r--0001-Include-neon-support-for-any-fpu-.-neon.patch26
-rw-r--r--0001-Make-CFLAGS-CXXFLAGS-behave-consistently-in-config.t.patch66
-rw-r--r--0001-Search-for-libsystemd-first-fall-back-to-libsystemd-.patch56
-rw-r--r--0001-journald-test-will-fail-with-certain-toolchains.patch26
-rw-r--r--0002-Adjust-egl-config.test-to-pass-sysrooted-libs.patch30
-rw-r--r--PKGBUILD104
-rw-r--r--PKGBUILD.libs8
-rw-r--r--qpi.install6
10 files changed, 296 insertions, 61 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9b3159f34415..34e348e499fd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Fri Mar 4 02:48:17 UTC 2016
+# Sat Jun 4 01:24:59 UTC 2016
pkgbase = qt-sdk-raspberry-pi1
pkgdesc = Qt SDK for the Raspberry Pi1
- pkgver = 5.6.0
- pkgrel = 10
+ pkgver = 5.7.0
+ pkgrel = 1
url = http://www.qt.io
install = qpi.install
arch = x86_64
@@ -18,9 +18,9 @@ pkgbase = qt-sdk-raspberry-pi1
conflicts = qt-sdk-raspberry-pi1
options = !strip
source = git://github.com/sirspudd/mkspecs.git
- source = https://download.qt.io/development_releases/qt/5.6/5.6.0-rc/single/qt-everywhere-opensource-src-5.6.0-rc.7z
+ source = https://download.qt.io/development_releases/qt/5.7/5.7.0-beta/single/qt-everywhere-opensource-src-5.7.0-beta.7z
sha256sums = SKIP
- sha256sums = 82ed4bc1bf7735747e1612f322f8723dfd84f05fa4dca9398863e6527a0c1971
+ sha256sums = d3df816772492d3d4e9bd542d5dfb45071821ab973ab8c426ae96fda4a47a8b9
pkgname = qt-sdk-raspberry-pi1
diff --git a/0001-Always-define-arm_thumb.patch b/0001-Always-define-arm_thumb.patch
new file mode 100644
index 000000000000..c0a7874d07d3
--- /dev/null
+++ b/0001-Always-define-arm_thumb.patch
@@ -0,0 +1,25 @@
+From 0311a69dcec83d90fc29c37527e4d59e9b3d57a8 Mon Sep 17 00:00:00 2001
+From: Donald Carr <sirspudd@gmail.com>
+Date: Tue, 15 Mar 2016 19:20:28 -0700
+Subject: [PATCH] Always define arm_thumb
+
+Change-Id: Ia453970c597e4c634df91fd1279c67e76e08f34e
+---
+ src/core/gyp_run.pro | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/core/gyp_run.pro b/src/core/gyp_run.pro
+index 8aa4ad2..57745ab 100644
+--- a/src/core/gyp_run.pro
++++ b/src/core/gyp_run.pro
+@@ -81,6 +81,7 @@ contains(QT_ARCH, "arm") {
+ }
+
+ contains(QMAKE_CFLAGS, "-mthumb"): GYP_CONFIG += arm_thumb=1
++ else: GYP_CONFIG += arm_thumb=0
+ }
+
+ contains(QT_ARCH, "x86_64"): GYP_CONFIG += target_arch=x64
+--
+2.7.3
+
diff --git a/0001-Include-neon-support-for-any-fpu-.-neon.patch b/0001-Include-neon-support-for-any-fpu-.-neon.patch
new file mode 100644
index 000000000000..777b47ea8c32
--- /dev/null
+++ b/0001-Include-neon-support-for-any-fpu-.-neon.patch
@@ -0,0 +1,26 @@
+From 133d09c9c65cea0addec7963abd32992b2144a0d Mon Sep 17 00:00:00 2001
+From: Donald Carr <sirspudd@gmail.com>
+Date: Tue, 15 Mar 2016 18:48:24 -0700
+Subject: [PATCH] Include neon support for any -fpu=.*neon.*
+
+Change-Id: I9c571c823b6fa2411e003799f7ff8627ef6e1d5e
+---
+ src/core/gyp_run.pro | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/core/gyp_run.pro b/src/core/gyp_run.pro
+index dea1a22..8aa4ad2 100644
+--- a/src/core/gyp_run.pro
++++ b/src/core/gyp_run.pro
+@@ -75,7 +75,7 @@ contains(QT_ARCH, "arm") {
+ # If the toolchain does not explicitly specify to use NEON instructions
+ # we use arm_neon_optional for ARMv7 and newer and let chromium decide
+ # about the mfpu option.
+- contains(MFPU, "neon")|contains(MFPU, "neon-vfpv4"): GYP_CONFIG += arm_fpu=\"$$MFPU\" arm_neon=1
++ contains(MFPU, ".*neon.*"): GYP_CONFIG += arm_fpu=\"$$MFPU\" arm_neon=1
+ else:!lessThan(MARMV, 7): GYP_CONFIG += arm_neon=0 arm_neon_optional=1
+ else: GYP_CONFIG += arm_fpu=\"$$MFPU\" arm_neon=0 arm_neon_optional=0
+ }
+--
+2.7.3
+
diff --git a/0001-Make-CFLAGS-CXXFLAGS-behave-consistently-in-config.t.patch b/0001-Make-CFLAGS-CXXFLAGS-behave-consistently-in-config.t.patch
new file mode 100644
index 000000000000..fa4513b1e296
--- /dev/null
+++ b/0001-Make-CFLAGS-CXXFLAGS-behave-consistently-in-config.t.patch
@@ -0,0 +1,66 @@
+From 5a20bfa307598828a89dd12ec66d4963230cb8aa Mon Sep 17 00:00:00 2001
+From: Donald Carr <sirspudd@gmail.com>
+Date: Thu, 24 Mar 2016 18:37:57 -0700
+Subject: [PATCH 1/2] Make CFLAGS/CXXFLAGS behave consistently in config.tests
+
+The journald test was failing as sysroot was not being passed to the
+compiler in the compile test. This is due to the fact we were explicitly
+defining sysroot in the CXXFLAGS and not in CFLAGS.
+
+Change-Id: I4b4bda71f9aabc8e420e0e89ff3cc8fa3bbca201
+---
+ config.tests/unix/compile.test | 7 ++++++-
+ 1 file changed, 6 insertions(+), 1 deletion(-)
+
+diff --git a/config.tests/unix/compile.test b/config.tests/unix/compile.test
+index c8929a3..a80e81a 100755
+--- a/config.tests/unix/compile.test
++++ b/config.tests/unix/compile.test
+@@ -15,6 +15,7 @@ QTCONF=$9
+ shift 9
+ LFLAGS="$SYSROOT_FLAG"
+ INCLUDEPATH=""
++CFLAGS="$SYSROOT_FLAG"
+ CXXFLAGS="$SYSROOT_FLAG"
+ MAC_ARCH_CXXFLAGS=""
+ MAC_ARCH_LFLAGS=""
+@@ -31,12 +32,14 @@ while [ "$#" -gt 0 ]; do
+ shift
+ ;;
+ -arch)
++ MAC_ARCH_CFLAGS="$MAC_ARCH_CFLAGS -arch $2"
+ MAC_ARCH_CXXFLAGS="$MAC_ARCH_CXXFLAGS -arch $2"
+ MAC_ARCH_LFLAGS="$MAC_ARCH_LFLAGS -arch $2"
+ shift
+ ;;
+ -F*|-m*|-x*)
+ LFLAGS="$LFLAGS \"$PARAM\""
++ CFLAGS="$CFLAGS \"$PARAM\""
+ CXXFLAGS="$CXXFLAGS \"$PARAM\""
+ ;;
+ -L*|-l*|-pthread)
+@@ -47,10 +50,12 @@ while [ "$#" -gt 0 ]; do
+ INCLUDEPATH="$INCLUDEPATH \"$INC\""
+ ;;
+ -f*|-D*)
++ CFLAGS="$CFLAGS \"$PARAM\""
+ CXXFLAGS="$CXXFLAGS \"$PARAM\""
+ ;;
+ -Qoption)
+ # Two-argument form for the Sun Compiler
++ CFLAGS="$CFLAGS $PARAM \"$2\""
+ CXXFLAGS="$CXXFLAGS $PARAM \"$2\""
+ shift
+ ;;
+@@ -72,7 +77,7 @@ test -r Makefile && $MAKE distclean >/dev/null 2>&1
+ # Make sure output from possible previous tests is gone
+ rm -f "$EXE" "${EXE}.exe"
+
+-set -- "$QMAKE" -qtconf "$QTCONF" -nocache -spec "$QMKSPEC" "CONFIG+=$QMAKE_CONFIG" "CONFIG+=android_app" "CONFIG-=debug_and_release app_bundle lib_bundle" "LIBS+=$LFLAGS" "LIBS+=$MAC_ARCH_LFLAGS" "INCLUDEPATH*=$INCLUDEPATH" "QMAKE_CXXFLAGS*=$CXXFLAGS" "QMAKE_CXXFLAGS+=$MAC_ARCH_CXXFLAGS" $QMAKE_ARGS "$SRCDIR/$TEST/$EXE.pro" -o "$OUTDIR/$TEST/Makefile"
++set -- "$QMAKE" -qtconf "$QTCONF" -nocache -spec "$QMKSPEC" "CONFIG+=$QMAKE_CONFIG" "CONFIG+=android_app" "CONFIG-=debug_and_release app_bundle lib_bundle" "LIBS+=$LFLAGS" "LIBS+=$MAC_ARCH_LFLAGS" "INCLUDEPATH*=$INCLUDEPATH" "QMAKE_CXXFLAGS*=$CXXFLAGS" "QMAKE_CXXFLAGS+=$MAC_ARCH_CXXFLAGS" "QMAKE_CFLAGS*=$CFLAGS" "QMAKE_CFLAGS+=$MAC_ARCH_CFLAGS" $QMAKE_ARGS "$SRCDIR/$TEST/$EXE.pro" -o "$OUTDIR/$TEST/Makefile"
+ if [ "$VERBOSE" = "yes" ]; then
+ OUTDIR=$OUTDIR "$@" && $MAKE && SUCCESS=yes
+ else
+--
+2.7.4
+
diff --git a/0001-Search-for-libsystemd-first-fall-back-to-libsystemd-.patch b/0001-Search-for-libsystemd-first-fall-back-to-libsystemd-.patch
new file mode 100644
index 000000000000..f9ab096dbc19
--- /dev/null
+++ b/0001-Search-for-libsystemd-first-fall-back-to-libsystemd-.patch
@@ -0,0 +1,56 @@
+From c689bcafd3196aad22372e8056fe0ccb13c15f35 Mon Sep 17 00:00:00 2001
+From: Heiko Becker <heirecka@exherbo.org>
+Date: Fri, 12 Feb 2016 12:37:15 +0100
+Subject: [PATCH] Search for libsystemd first, fall back to libsystemd-journal
+
+systemd >= 209 merged the individual libraries libsystemd-journal,
+libsystemd-login, libsystemd-id128 and libsystemd-daemon into
+a single library, libsystemd. To ease the transition one could pass
+an option to its build to generate stub libraries and matching
+pkg-config files. With systemd >= 229 this option has now been
+removed, causing the build to fail when the journald option is
+enabled.
+
+Change-Id: I26670f207f1a9e79c16be5ce8c8a49353143c5ba
+Reviewed-by: Oswald Buddenhagen <oswald.buddenhagen@theqtcompany.com>
+Reviewed-by: Robin Burchell <robin.burchell@viroteck.net>
+---
+ config.tests/unix/journald/journald.pro | 6 +++++-
+ src/corelib/global/global.pri | 5 ++++-
+ 2 files changed, 9 insertions(+), 2 deletions(-)
+
+diff --git a/config.tests/unix/journald/journald.pro b/config.tests/unix/journald/journald.pro
+index 2bb50ce..ea76564 100644
+--- a/config.tests/unix/journald/journald.pro
++++ b/config.tests/unix/journald/journald.pro
+@@ -1,6 +1,10 @@
+ SOURCES = journald.c
+
+ CONFIG += link_pkgconfig
+-PKGCONFIG_PRIVATE += libsystemd-journal
++
++packagesExist(libsystemd): \
++ PKGCONFIG_PRIVATE += libsystemd
++else: \
++ PKGCONFIG_PRIVATE += libsystemd-journal
+
+ CONFIG -= qt
+diff --git a/src/corelib/global/global.pri b/src/corelib/global/global.pri
+index aa4945f..dd84695 100644
+--- a/src/corelib/global/global.pri
++++ b/src/corelib/global/global.pri
+@@ -53,7 +53,10 @@ slog2 {
+
+ journald {
+ CONFIG += link_pkgconfig
+- PKGCONFIG_PRIVATE += libsystemd-journal
++ packagesExist(libsystemd): \
++ PKGCONFIG_PRIVATE += libsystemd
++ else: \
++ PKGCONFIG_PRIVATE += libsystemd-journal
+ DEFINES += QT_USE_JOURNALD
+ }
+
+--
+2.7.2
+
diff --git a/0001-journald-test-will-fail-with-certain-toolchains.patch b/0001-journald-test-will-fail-with-certain-toolchains.patch
new file mode 100644
index 000000000000..1849de80937d
--- /dev/null
+++ b/0001-journald-test-will-fail-with-certain-toolchains.patch
@@ -0,0 +1,26 @@
+From fa629e87eea5ac43abe5bedbfb46af6546b9083c Mon Sep 17 00:00:00 2001
+From: Donald Carr <sirspudd@gmail.com>
+Date: Mon, 7 Mar 2016 18:49:57 -0800
+Subject: [PATCH] journald test will fail with certain toolchains
+
+which don't include default system paths
+
+Change-Id: I58043a9c9569e091fac18934cb1a2484cb9f61e2
+---
+ config.tests/unix/journald/journald.pro | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/config.tests/unix/journald/journald.pro b/config.tests/unix/journald/journald.pro
+index ea76564..59f920b 100644
+--- a/config.tests/unix/journald/journald.pro
++++ b/config.tests/unix/journald/journald.pro
+@@ -7,4 +7,6 @@ packagesExist(libsystemd): \
+ else: \
+ PKGCONFIG_PRIVATE += libsystemd-journal
+
++# toolchain does not include usr include by default
++INCLUDEPATH *= /usr/include
+ CONFIG -= qt
+--
+2.7.2
+
diff --git a/0002-Adjust-egl-config.test-to-pass-sysrooted-libs.patch b/0002-Adjust-egl-config.test-to-pass-sysrooted-libs.patch
new file mode 100644
index 000000000000..36df62b5e6d3
--- /dev/null
+++ b/0002-Adjust-egl-config.test-to-pass-sysrooted-libs.patch
@@ -0,0 +1,30 @@
+From ff84397f2dd8492386e025c73e595f004c3f69cd Mon Sep 17 00:00:00 2001
+From: Donald Carr <sirspudd@gmail.com>
+Date: Thu, 24 Mar 2016 20:11:53 -0700
+Subject: [PATCH 2/2] Adjust egl config.test to pass sysrooted libs
+
+We should really start using -L=/foo and -I=/foo inside of sysroots, and
+this test was preventing us from doing so (while arguably buying us
+nothing).
+
+Change-Id: If6e67631c585493871231e5d8a9354fa72e07343
+---
+ config.tests/qpa/eglfs-brcm/eglfs-brcm.pro | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/config.tests/qpa/eglfs-brcm/eglfs-brcm.pro b/config.tests/qpa/eglfs-brcm/eglfs-brcm.pro
+index ce16a3a..d8b1c3e 100644
+--- a/config.tests/qpa/eglfs-brcm/eglfs-brcm.pro
++++ b/config.tests/qpa/eglfs-brcm/eglfs-brcm.pro
+@@ -5,7 +5,7 @@ CONFIG -= qt
+ INCLUDEPATH += $$QMAKE_INCDIR_EGL
+
+ for(p, QMAKE_LIBDIR_EGL) {
+- exists($$p):LIBS += -L$$p
++ LIBS += -L$$p
+ }
+
+ LIBS += -lEGL -lGLESv2 -lbcm_host
+--
+2.7.4
+
diff --git a/PKGBUILD b/PKGBUILD
index f0ae3c4a2ffe..afee8895af64 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -22,13 +22,13 @@ _skip_web_engine=false
_static_build=false
_build_from_head=false
_local_qt5_repo="/opt/dev/src/qtproject/qt5"
-_wayland_compositor=true
-pkgver=5.6.0
-pkgrel=10
-
-# PKGBUILD
+pkgrel=1
_piver=1
+
+_pkgvermajmin="5.7"
+pkgver="${_pkgvermajmin}.0"
+
pkgname="qt-sdk-raspberry-pi${_piver}"
if $_static_build; then
@@ -36,7 +36,7 @@ if $_static_build; then
fi
if $_build_from_head; then
- _pkgver=6.6.6
+ pkgver=6.6.6
fi
provides=("${pkgname}")
@@ -44,18 +44,24 @@ conflicts=("${pkgname}")
_packaginguser=$(whoami)
_libspkgname="${pkgname}-target-libs"
_mkspec="linux-rpi${_piver}-g++"
-_pkgver=${pkgver}-rc
+
+_pkgver=${pkgver}-beta
+
_baseprefix=/opt
_installprefix=${_baseprefix}/${pkgname}
-_source_package_name=qt-everywhere-opensource-src-${_pkgver}
+_qt_package_name_prefix="qt-everywhere-opensource-src"
+_source_package_name=${_qt_package_name_prefix}-${_pkgver}
+
pkgdesc="Qt SDK for the Raspberry Pi${_piver}"
arch=("x86_64")
url="http://www.qt.io"
license=("LGPL3" "GPL3")
depends=("qpi-toolchain" "qtcreator")
makedepends=("git" "pkgconfig" "gcc")
-source=("git://github.com/sirspudd/mkspecs.git" "https://download.qt.io/development_releases/qt/5.6/${_pkgver}/single/${_source_package_name}.7z")
-sha256sums=("SKIP" "82ed4bc1bf7735747e1612f322f8723dfd84f05fa4dca9398863e6527a0c1971")
+source=("git://github.com/sirspudd/mkspecs.git" "https://download.qt.io/development_releases/qt/${_pkgvermajmin}/${_pkgver}/single/${_source_package_name}.7z")
+
+sha256sums=("SKIP" "d3df816772492d3d4e9bd542d5dfb45071821ab973ab8c426ae96fda4a47a8b9")
+
options=('!strip')
install=qpi.install
_fully_qualified_install_script="${startdir}/${install}"
@@ -78,7 +84,16 @@ fi
#end sanity check
-if $_static_build || $_skip_web_engine || [[ ${_piver} = "1" ]]; then
+# callbacks
+finish() {
+ if [[ -n ${startdir} ]]; then
+ cd ${startdir}
+ git checkout qpi.install
+ fi
+}
+trap finish EXIT
+
+if $_static_build || $_skip_web_engine || [[ ${_piver} = "1" ]] || [[ ${_piver} = "3" ]]; then
_device_configure_flags="$_device_configure_flags -skip qtwebengine"
fi
@@ -90,14 +105,14 @@ if $_build_from_head; then
_device_configure_flags="$_device_configure_flags -skip qt3d -skip qtsystems -skip qttools -skip qtwebkit"
fi
-if $_wayland_compositor; then
- _device_configure_flags="$_device_configure_flags -skip qtwayland"
-fi
-
build() {
local _srcdir="${srcdir}/${_source_package_name}"
- local _bindir="${_srcdir}-build"
- local _mkspec_dir="${_srcdir}/qtbase/mkspecs/devices/${_mkspec}"
+ local _basedir="${_srcdir}/qtbase"
+ local _waylanddir="${_srcdir}/qtwayland"
+ local _webenginedir="${_srcdir}/qtwebengine"
+ local _locationdir="${_srcdir}/qtlocation"
+ local _bindir="${_srcdir}"
+ local _mkspec_dir="${_basedir}/mkspecs/devices/${_mkspec}"
# Qt tries to do the right thing and stores these, breaking cross compilation
unset LDFLAGS
@@ -108,17 +123,13 @@ if $_build_from_head; then
_srcdir="${_local_qt5_repo}"
fi
+ cd ${_srcdir}
+
# Get our mkspec
rm -Rf $_mkspec_dir
cp -r "${srcdir}/mkspecs/${_mkspec}" $_mkspec_dir
- mkdir -p ${_bindir}
- cd ${_bindir}
-
- # skipping due to build issues: qtquickcontrols2
# skipping on principle: qtscript xcb
- # skipping because of the target in question: widgets qtwebchannel
- # TODO: qtwebengine, a little bulky but useful
# Too bleeding big
# -developer-build \
@@ -127,22 +138,37 @@ fi
# Chromium requires python2 to be the system python on your build host
# I literally symlink /usr/bin/python to /usr/bin/python2 on arch
- # patch
+ # build qtwebengine with our mkspec
local _webenginefileoverride="${_srcdir}/qtwebengine/tools/qmake/mkspecs/features/functions.prf"
sed -i "s/linux-clang/linux*/" ${_webenginefileoverride} || exit 1
- local _reducerelocations="${_srcdir}/qtbase/config.tests/unix/bsymbolic_functions.test"
+
+ # hard coded off, so we have to hard code it on
+ local _reducerelocations="${_basedir}/config.tests/unix/bsymbolic_functions.test"
sed -i "s/error/warning/" ${_reducerelocations} || exit 1
- # No longer required as we explicitly set CFLAGS = foo in the mkspec
# Work around our embarresing propensity to stomp on your own tailored build configuration
- sed -i "s/O[23]/Os/" ${_srcdir}/qtbase/mkspecs/common/gcc-base.conf || exit 1
+ sed -i "s/O[23]/Os/" ${_basedir}/mkspecs/common/gcc-base.conf || exit 1
+
+ # incorporate journald fix
+ local _patch_dir=${startdir}
+ cd ${_basedir}
+ patch -p1 < ${_patch_dir}/0001-Make-CFLAGS-CXXFLAGS-behave-consistently-in-config.t.patch
+ patch -p1 < ${_patch_dir}/0002-Adjust-egl-config.test-to-pass-sysrooted-libs.patch
+ cd ${_webenginedir}
+ patch -p1 < ${_patch_dir}/0001-Include-neon-support-for-any-fpu-.-neon.patch
+ patch -p1 < ${_patch_dir}/0001-Always-define-arm_thumb.patch
# end patch
+ mkdir -p ${_bindir}
+ cd ${_bindir}
+
# Breaks in qtwayland
# -qtnamespace Pi \
${_srcdir}/configure \
+ -no-icu \
+ -v \
-qreal float \
-release \
-silent \
@@ -158,14 +184,12 @@ fi
-prefix ${_installprefix} \
-opengl es2 \
-egl \
- -no-icu \
+ -journald \
\
- -no-widgets \
-make libs \
-no-xcb \
\
-skip qtscript \
- -skip qtenginio \
\
-sysroot ${_sysroot} \
-device ${_mkspec} \
@@ -173,16 +197,6 @@ fi
${_device_configure_flags} || exit 1
make || exit 1
-
-if $_wayland_compositor; then
- # regrettably required, as qtwayland barfs on shadow builds
- # as private header paths not included: no clue how to fix, bypassing
-
- cp -r "${_srcdir}/qtwayland" "${_bindir}" || exit 1
- cd "${_bindir}/qtwayland"
- ${_bindir}/qtbase/bin/qmake CONFIG+=wayland-compositor || exit 1
- make || exit 1
-fi
}
create_install_script()
@@ -196,7 +210,7 @@ create_install_script()
package() {
local _srcdir="${srcdir}/${_source_package_name}"
- local _bindir="${_srcdir}-build"
+ local _bindir="${_srcdir}"
create_install_script
@@ -207,12 +221,6 @@ package() {
cd "${_bindir}"
INSTALL_ROOT="$pkgdir" make install || exit 1
-if $_wayland_compositor; then
- # regrettably required
- cd "${_bindir}/qtwayland"
- INSTALL_ROOT="$pkgdir" make install || exit 1
-fi
-
# Qt is now installed to $pkgdir/$sysroot/$prefix
# manually generate/decompose host/target
local _libsdir="${startdir}/${_libspkgname}"
@@ -239,7 +247,5 @@ fi
cd ${_libsdir}
runuser -l ${_packaginguser} -c 'makepkg -d -f' || exit 1
- echo "the libs package for the Raspberry Pi${_piver} is in the ${_packaginguser} home directory awaiting deployment"
-
mv ${_libsdir}/${_libspkgname}-${pkgver}-${pkgrel}-any.pkg.tar.xz ${startdir}
}
diff --git a/PKGBUILD.libs b/PKGBUILD.libs
index 5cbf068a82db..b22fcd5bcad8 100644
--- a/PKGBUILD.libs
+++ b/PKGBUILD.libs
@@ -1,12 +1,12 @@
# Maintainer: Donald Carr <sirspudd@gmail.com>
pkgname=libspkgname
-provides=("${pkgname}")
-conflicts=("${pkgname}")
-replaces=("${pkgname}")
+_provides_pkgname="qt-sdk-raspberry-pi-target-libs"
+provides=("${_provides_pkgname}")
+conflicts=("${_provides_pkgname}")
pkgver=libspkgver
pkgrel=libspkgrel
-pkgdesc="Qt ${pkgver} libs cross compiled for the Raspberry Pi libspiversion"
+pkgdesc="Qt ${pkgver} libs cross compiled for the Raspberry Pi libspiver"
# I don't know how to set this correct for cross architecture builds
arch=("any")
url="http://www.qt.io"
diff --git a/qpi.install b/qpi.install
index cc174752cc28..e8ac0b26c91c 100644
--- a/qpi.install
+++ b/qpi.install
@@ -1,6 +1,6 @@
-_piver="libspiver"
-_qmakepath="libsqmakepath"
-_sysroot="libssysroot"
+_piver="1"
+_qmakepath="/opt/qt-sdk-raspberry-pi1/bin/qmake"
+_sysroot="/mnt/pi"
_sdktool="/usr/libexec/qtcreator/sdktool"
_devicefamily="raspberrypi"