aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDonald Carr2017-04-28 19:03:32 -0700
committerDonald Carr2017-04-28 19:14:17 -0700
commit4daa9c0f67e7b5b33309ee622444135cb5456045 (patch)
treeb26a5e1b9616c4c03bd883ace40fecbb7a924a44
parentfe35cd615d39d7d3013af575cf8863df5a405d6f (diff)
downloadaur-4daa9c0f67e7b5b33309ee622444135cb5456045.tar.gz
Update the srcinfo
Minimal build becomes the default (again)
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD19
2 files changed, 13 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a7e8e3e9fcd1..349f044b8c9f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Thu Apr 27 08:18:02 UTC 2017
+# Sat Apr 29 02:13:45 UTC 2017
pkgbase = qt-sdk-raspberry-pi
pkgdesc = Qt SDK for the Raspberry Pi 1/2/3
pkgver = 5.9.0
- pkgrel = 3
+ pkgrel = 4
url = http://chaos-reins.com/qpi/
install = qpi.install
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index e826cae33cdb..5c435a1d66c3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -36,26 +36,25 @@ _skip_web_engine=false
_static_build=false
_build_from_head=false
_patching=true
+_minimal=true
if [[ -z ${startdir} ]]; then
_building=false;
fi
-if [[ -f minimal ]]; then
+if [[ -f full-build ]]; then
+ _minimal = false
+fi
+
+if $_building && $_minimal; then
_skip_qtscript=true;
_skip_web_engine=true;
_skip_qt_widgets=true;
pkgname="${pkgname}-minimal"
fi
-if [[ -f target_host ]]; then
- _target_host=true;
-fi
-
# Sanity check options
-if $_target_host; then
- _piver=""
-elif $_building; then
+if $_building; then
if [[ -z $_piver ]] && [[ -n $LOCAL_PI_VER ]]; then _piver=$LOCAL_PI_VER; fi
_sysroot=/mnt/pi${_piver}
if [[ -z "${_piver}" ]]; then
@@ -69,6 +68,10 @@ elif $_building; then
fi
fi
+if [[ $_piver = "" ]]; then
+ _target_host=true
+fi
+
# vars
_local_qt5_repo="/opt/dev/src/qtproject/qt5"
_pkgvermajmin="5.9"