aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDonald Carr2019-02-10 19:32:50 -0800
committerDonald Carr2019-02-10 19:32:50 -0800
commit4de10f600e26779cf4edb3e184f3b787406c5f68 (patch)
tree023dba2b4547e1fdb6c46a2377c28bc8d3d16956
parent2af75719805659fc7ac15e64f7f41d5f2694fd58 (diff)
downloadaur-4de10f600e26779cf4edb3e184f3b787406c5f68.tar.gz
Facilitate building both Qt 5.12.1 and Qt 5.12.0
-rw-r--r--PKGBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6f028e317c4f..f60479f089d9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -55,6 +55,10 @@ if [[ -f target-host ]]; then
_target_host=true
fi
+if [[ -f no-debug ]]; then
+ _debug=false
+fi
+
if [[ -f static ]]; then
_static_build=true
_uber_minimal=true
@@ -92,7 +96,7 @@ fi
# vars
_local_qt5_repo="/opt/dev/src/qtproject/qt5"
_pkgvermajmin="5.12"
-_pkgverpatch=".1"
+_pkgverpatch=".0"
# {alpha/beta/beta2/rc}
_dev_suffix=""
pkgrel=1
@@ -299,7 +303,8 @@ _core_configure_options=" \
-reduce-exports \
"
-_tar_xz_sha256="caffbd625c7bc10ff8c5c7a27dbc7d84fa4de146975c0e1ffe904b514ccd6da4"
+#_tar_xz_sha256="caffbd625c7bc10ff8c5c7a27dbc7d84fa4de146975c0e1ffe904b514ccd6da4"
+_tar_xz_sha256="356f42d9087718f22f03d13d0c2cdfb308f91dc3cf0c6318bed33f2094cd9d6c"
source=("git://github.com/sirspudd/mkspecs.git")
sha256sums=("SKIP")