aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDonald Carr2017-05-17 23:08:13 -0700
committerDonald Carr2017-05-17 23:08:30 -0700
commit654ede1a77ad67b3efc5ce1ae266e2625916024a (patch)
tree4e63bcb6ec6a96f26535b58ae4e0b36a257b5630
parent7c3c9ae2120588416e1a0160f1c86ac65e73c501 (diff)
downloadaur-654ede1a77ad67b3efc5ce1ae266e2625916024a.tar.gz
Use the same ssl magic everywhere
-rw-r--r--PKGBUILD10
-rw-r--r--qpi.install117
2 files changed, 122 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c2b759846cd3..317994f88c66 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -172,7 +172,6 @@ _arch_specific_configure_options="\
-no-rpath"
# Seems to be creating a large amount of breakage
-# -openssl-linked \
_core_configure_options="\
-prefix ${_installprefix} \
-optimized-tools \
@@ -187,6 +186,7 @@ _core_configure_options="\
-system-freetype \
-system-harfbuzz \
-dbus-linked \
+ -openssl-linked \
-pch \
-opengl es2 \
-egl \
@@ -265,10 +265,10 @@ build() {
cd ${_srcdir}
-if $_target_host; then
- echo "INCLUDEPATH += /usr/include/openssl-1.0" >> ${_basedir}/src/network/network.pro
- export OPENSSL_LIBS='-L/usr/lib/openssl-1.0 -lssl -lcrypto'
-else
+ echo "INCLUDEPATH += ${_sysroot}/usr/include/openssl-1.0" >> ${_basedir}/src/network/network.pro
+ export OPENSSL_LIBS="-L${_sysroot}/usr/lib/openssl-1.0 -lssl -lcrypto"
+
+if ! $_target_host; then
# Get our mkspec
rm -Rf $_mkspec_dir
cp -r "${srcdir}/mkspecs/${_mkspec}" $_mkspec_dir
diff --git a/qpi.install b/qpi.install
index e69de29bb2d1..e5f8238ecfd9 100644
--- a/qpi.install
+++ b/qpi.install
@@ -0,0 +1,117 @@
+_piver=2
+_qmakepath=/opt/qt-sdk-raspberry-pi2/bin/qmake
+_sysroot=/mnt/pi2
+_sdktool="/usr/libexec/qtcreator/sdktool"
+_devicefamily="raspberrypi"
+_devicename="${_devicefamily}${_piver}"
+_familytext="Raspberry Pi"
+_devicetext="${_familytext} ${_piver}"
+
+setup_toolchain() {
+ echo "Registering toolchain with Qt Creator"
+${_sdktool} addTC \
+ --id "ProjectExplorer.ToolChain.Gcc:${_devicefamily}" \
+ --name "${_familytext} toolchain" \
+ --path /opt/arm-sirspuddarch-linux-gnueabihf/bin/arm-sirspuddarch-linux-gnueabihf-gcc \
+ --abi arm-linux-generic-elf-32bit \
+ --supportedAbis arm-linux-generic-elf-32bit
+
+ echo "Registering debugger with Qt Creator"
+${_sdktool} addDebugger \
+ --id "${_devicefamily}_gdb" \
+ --name "${_familytext} gdb" \
+ --binary /opt/arm-sirspuddarch-linux-gnueabihf/bin/arm-sirspuddarch-linux-gnueabihf-gdb \
+ --abis arm-linux-generic-elf-32bit \
+ --engine 1
+}
+
+remove_toolchain() {
+#TODO: Don't remove if the other pi package is present
+#Not used at present
+${_sdktool} rmTC \
+ --id "ProjectExplorer.ToolChain.Gcc:${_devicefamily}"
+
+${_sdktool} rmDebugger \
+ --id "${_devicefamily}_gdb"
+}
+
+remove_kit() {
+${_sdktool} rmQt \
+ --id "${_devicename}_qt"
+
+${_sdktool} rmKit \
+ --id "${_devicename}_kit"
+
+${_sdktool} rmDev \
+ --id "${_devicename}_device"
+}
+
+setup_kit() {
+ remove_kit
+ setup_toolchain
+
+ echo "Registering device with Qt Creator"
+${_sdktool} addDev \
+ --id "${_devicename}_device" \
+ --name "${_devicetext}" \
+ --host "qpi${_piver}.local" \
+ --uname "root" \
+ --password "root" \
+ --osType "GenericLinuxOsType" \
+ --type 0 \
+ --sshPort 22 \
+ --freePorts "10000-10100"
+
+ echo "Registering Qt install with Qt Creator"
+${_sdktool} addQt \
+ --id "${_devicename}_qt" \
+ --name "${_devicetext} Qt" \
+ --qmake ${_qmakepath} \
+ --type RemoteLinux.EmbeddedLinuxQt
+
+ echo "Creating Qt Creator Kit"
+${_sdktool} addKit \
+ --id "${_devicename}_kit" \
+ --name "${_devicetext} Kit" \
+ --debugger "${_devicefamily}_gdb" \
+ --devicetype GenericLinuxOsType \
+ --device "${_devicename}_device" \
+ --sysroot ${_sysroot} \
+ --toolchain "ProjectExplorer.ToolChain.Gcc:${_devicefamily}" \
+ --qt "${_devicename}_qt" \
+ --mkspec "devices/linux-rpi${_piver}-g++"
+}
+
+## arg 1: the new package version
+pre_install() {
+ echo ""
+}
+
+## arg 1: the new package version
+post_install() {
+ setup_kit
+}
+#post_install
+
+## arg 1: the new package version
+## arg 2: the old package version
+pre_upgrade() {
+ echo ""
+}
+
+## arg 1: the new package version
+## arg 2: the old package version
+post_upgrade() {
+ setup_kit
+}
+
+## arg 1: the old package version
+pre_remove() {
+ echo ""
+}
+#pre_remove
+
+## arg 1: the old package version
+post_remove() {
+ remove_kit
+}