summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDonald Carr2016-02-26 14:55:13 -0800
committerDonald Carr2016-02-26 14:55:13 -0800
commit7beba31ffd9243eb0b634237867c86cb3ec42ee4 (patch)
treead986f27f95df114d8932cbcb8893aaa2a5ceeb7
parenta985b8234f7b477217ac66da3c601228ef36dc2a (diff)
downloadaur-7beba31ffd9243eb0b634237867c86cb3ec42ee4.tar.gz
Introduce a couple static linking considerations
Change-Id: I989e37e9cce16fa003db61611f8bf5a8df2a1719
-rw-r--r--PKGBUILD19
1 files changed, 10 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 49d4abca8d12..de8bd73a4233 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -29,20 +29,19 @@ pkgrel=9
# PKGBUILD
_piver=2
-_pkgname=qt-sdk-raspberry-pi
+pkgname="qt-sdk-raspberry-pi${_piver}"
if $_static_build; then
- _pkgname="${_pkgname}-static"
+ pkgname="${pkgname}-static"
fi
if $_build_from_head; then
_pkgver=6.6.6
fi
-provides=("${_pkgname}")
-conflicts=("${_pkgname}")
-replaces=("${_pkgname}")
-pkgname="${_pkgname}${_piver}"
+provides=("${pkgname}")
+conflicts=("${pkgname}")
+replaces=("${pkgname}")
_packaginguser=$(whoami)
_libspkgname="${pkgname}-target-libs"
_mkspec="linux-rpi${_piver}-g++"
@@ -232,9 +231,11 @@ fi
sed -i "s/libspkgname/${_libspkgname}/" ${_libspkgbuild} || exit 1
sed -i "s/libspiver/${_piver}/" ${_libspkgbuild} || exit 1
- mkdir -p ${_pkgprofiled}
- cp ${startdir}/qpi.sh ${_pkgprofiled} || exit 1
- sed -i "s,localpiprefix,${_installprefix}," ${_pkgprofiled}/qpi.sh || exit 1
+ if ! ${_static_build}; then
+ mkdir -p ${_pkgprofiled}
+ cp ${startdir}/qpi.sh ${_pkgprofiled} || exit 1
+ sed -i "s,localpiprefix,${_installprefix}," ${_pkgprofiled}/qpi.sh || exit 1
+ fi
cd ${_libsdir}
runuser -l ${_packaginguser} -c 'makepkg -d -f' || exit 1