summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorViktor Drobot2021-06-09 15:00:44 +0300
committerViktor Drobot2021-06-09 15:00:44 +0300
commitb0ebc01dbf31d6866544a8787ff39147ba5d61d3 (patch)
treee0ba92efe384dbe72a52790bf70f6ff7dd556a08
parent3e403b2743d9c30a0ca5d5cd22f48f42061a0be5 (diff)
downloadaur-b0ebc01dbf31d6866544a8787ff39147ba5d61d3.tar.gz
Fix for gcc11
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD11
-rw-r--r--qt4-gcc11.patch11
3 files changed, 23 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 60b836aa8b23..36ab54b7e0c5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = qt4
pkgdesc = A cross-platform application and UI framework
pkgver = 4.8.7
- pkgrel = 33
+ pkgrel = 34
url = https://www.qt.io
arch = x86_64
license = GPL3
@@ -56,6 +56,7 @@ pkgbase = qt4
source = qt4-gcc6.patch
source = qt4-gcc8.patch
source = qt4-gcc9.patch
+ source = qt4-gcc11.patch
source = qt4-glibc-2.25.patch
source = qt4-icu59.patch
source = qt4-openssl-1.1.patch
@@ -76,9 +77,9 @@ pkgbase = qt4
sha256sums = 51da49e41edac66559d3ec8dd0a152995a51a53e5d1f63f09fa089a8af7e3112
sha256sums = 0497411e54a0461f76ffa204236f5146a2ed0d272ae66afcfabd74090459208b
sha256sums = 8d6104d7bc3b050ec87e82b9df245154cd1d80e03eb3bbe633084d6b3c079d5e
+ sha256sums = ce710612c89b47fc4a070bcce355855f899349b995e2654f342c88ec4c515ee4
sha256sums = e6555f4a681227447e94e9f14e11626d50b7e5108aad06088311e87063bc0347
sha256sums = 61d6bf45649c728dec5f8d22be5b496ed9d40f52c2c70102696d07133cd1750d
sha256sums = ff3ddb5428cd2ff243558dc0c75b35f470077e9204bbc989ddcba04c866c1b68
pkgname = qt4
-
diff --git a/PKGBUILD b/PKGBUILD
index 27b2236dcd55..146f420844c5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=qt4
pkgver=4.8.7
-pkgrel=33
+pkgrel=34
arch=('x86_64')
url='https://www.qt.io'
license=('GPL3' 'LGPL' 'FDL' 'custom')
@@ -37,7 +37,10 @@ source=("https://ftp.desolve.ru/ftp/viktor/qt4/${_pkgfqn}.tar.gz"
'disable-sslv3.patch'
'l-qclipboard_fix_recursive.patch'
'l-qclipboard_delay.patch'
- 'qt4-gcc6.patch' 'qt4-gcc8.patch' 'qt4-gcc9.patch' 'qt4-glibc-2.25.patch' 'qt4-icu59.patch' 'qt4-openssl-1.1.patch')
+ 'qt4-gcc6.patch' 'qt4-gcc8.patch' 'qt4-gcc9.patch' 'qt4-gcc11.patch'
+ 'qt4-glibc-2.25.patch'
+ 'qt4-icu59.patch'
+ 'qt4-openssl-1.1.patch')
sha256sums=('e2882295097e47fe089f8ac741a95fef47e0a73a3f3cdf21b56990638f626ea0'
'157eb47865f0b43e4717819783823c569127a2e9fc48309982ca0f2b753517a1'
'd63f22858174489068c30a12b9115d1b4e23ade00c31c117513212e9a225c1ce'
@@ -55,6 +58,7 @@ sha256sums=('e2882295097e47fe089f8ac741a95fef47e0a73a3f3cdf21b56990638f626ea0'
'51da49e41edac66559d3ec8dd0a152995a51a53e5d1f63f09fa089a8af7e3112'
'0497411e54a0461f76ffa204236f5146a2ed0d272ae66afcfabd74090459208b'
'8d6104d7bc3b050ec87e82b9df245154cd1d80e03eb3bbe633084d6b3c079d5e'
+ 'ce710612c89b47fc4a070bcce355855f899349b995e2654f342c88ec4c515ee4'
'e6555f4a681227447e94e9f14e11626d50b7e5108aad06088311e87063bc0347'
'61d6bf45649c728dec5f8d22be5b496ed9d40f52c2c70102696d07133cd1750d'
'ff3ddb5428cd2ff243558dc0c75b35f470077e9204bbc989ddcba04c866c1b68')
@@ -102,6 +106,9 @@ prepare() {
# Fix build with GCC9
patch -Np0 -i "$srcdir"/qt4-gcc9.patch
+ # Fix build with GCC11 (thx de-vries)
+ patch -Np0 -i "$srcdir"/qt4-gcc11.patch
+
# Fix build of Qt4 applications with glibc 2.25 (Fedora)
patch -p1 -i "$srcdir"/qt4-glibc-2.25.patch
diff --git a/qt4-gcc11.patch b/qt4-gcc11.patch
new file mode 100644
index 000000000000..1227854bdcf1
--- /dev/null
+++ b/qt4-gcc11.patch
@@ -0,0 +1,11 @@
+--- tools/linguist/linguist/messagemodel.cpp 2021-06-07 12:18:43.713434493 +0200
++++ tools/linguist/linguist/messagemodel.cpp 2021-06-07 12:24:24.828016548 +0200
+@@ -183,7 +183,7 @@
+ if (ContextItem *c = one->findContext(oc->context())) {
+ for (int j = 0; j < oc->messageCount(); ++j) {
+ MessageItem *m = oc->messageItem(j);
+- if (c->findMessage(m->text(), m->comment()) >= 0)
++ if (c->findMessage(m->text(), m->comment()))
+ ++inBoth;
+ }
+ }