aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBlackEagle2017-01-21 13:50:34 +0100
committerBlackEagle2017-01-21 13:50:34 +0100
commit766805ef6a20fe0596b7c57440fb63bce985fe33 (patch)
tree4ae03b2957f10bd3850ff2c67584685e8f04f50f
parent5f778cd2c73cbea8ce0410324cbe0bdfbaab11cd (diff)
downloadaur-766805ef6a20fe0596b7c57440fb63bce985fe33.tar.gz
qt4pas :: 2.5-6
Signed-off-by: BlackEagle <ike.devolder@gmail.com>
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD23
-rw-r--r--qtwebkit.patch155
3 files changed, 179 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b19d6a96cd4f..5ea1d06864ec 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,18 @@
+# Generated by mksrcinfo v8
+# Sat Jan 21 12:50:34 UTC 2017
pkgbase = qt4pas
pkgdesc = Free Pascal Qt4 Binding Library
pkgver = 2.5
- pkgrel = 5
+ pkgrel = 6
url = http://users.telenet.be/Jan.Van.hijfte/qtforfpc/fpcqt4.html
arch = i686
arch = x86_64
license = LGPL
- depends = qtwebkit
+ depends = qt4
source = http://users.telenet.be/Jan.Van.hijfte/qtforfpc/V2.5/qt4pas-V2.5_Qt4.5.3.tar.gz
- md5sums = 8249bc17e4167e077d22c7f5fb118bb2
+ source = qtwebkit.patch
+ sha256sums = 825423db80da4df5c21816c0392b3394cddfe2f3293dfd08ace84941726affea
+ sha256sums = af1721fbf6706931d0b82dd28b3540f56a65e1585b75873c4ac9eaddecf9c921
pkgname = qt4pas
diff --git a/PKGBUILD b/PKGBUILD
index 7ccee25bd2f6..2c3f050829eb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,17 +4,27 @@
pkgname=qt4pas
pkgver=2.5
-pkgrel=5
+pkgrel=6
pkgdesc="Free Pascal Qt4 Binding Library"
arch=('i686' 'x86_64')
url="http://users.telenet.be/Jan.Van.hijfte/qtforfpc/fpcqt4.html"
license=('LGPL')
-depends=('qtwebkit')
-source=("http://users.telenet.be/Jan.Van.hijfte/qtforfpc/V2.5/qt4pas-V2.5_Qt4.5.3.tar.gz")
-md5sums=('8249bc17e4167e077d22c7f5fb118bb2')
+depends=('qt4')
+source=(
+ 'http://users.telenet.be/Jan.Van.hijfte/qtforfpc/V2.5/qt4pas-V2.5_Qt4.5.3.tar.gz'
+ 'qtwebkit.patch'
+)
+sha256sums=('825423db80da4df5c21816c0392b3394cddfe2f3293dfd08ace84941726affea'
+ 'af1721fbf6706931d0b82dd28b3540f56a65e1585b75873c4ac9eaddecf9c921')
+
+prepare() {
+ cd "qt4pas-V2.5_Qt4.5.3/"
+
+ patch -p0 -i "$srcdir/qtwebkit.patch"
+}
build() {
- cd "$srcdir/qt4pas-V2.5_Qt4.5.3/"
+ cd "qt4pas-V2.5_Qt4.5.3/"
qmake-qt4 -query
qmake-qt4
@@ -22,7 +32,8 @@ build() {
}
package() {
- cd "$srcdir/qt4pas-V2.5_Qt4.5.3/"
+ cd "qt4pas-V2.5_Qt4.5.3/"
+
INSTALL_ROOT="$pkgdir" make install
pushd "$pkgdir/usr/lib"
diff --git a/qtwebkit.patch b/qtwebkit.patch
new file mode 100644
index 000000000000..94b68d4aa760
--- /dev/null
+++ b/qtwebkit.patch
@@ -0,0 +1,155 @@
+Index: Qt4Pas.pro
+===================================================================
+--- Qt4Pas.pro (revision 1)
++++ Qt4Pas.pro (working copy)
+@@ -12,7 +12,6 @@
+
+ VERSION = 5.2.5
+
+-QT += network webkit
+ TARGET = Qt4Pas
+ TEMPLATE = lib
+ DEPENDPATH += src
+@@ -155,21 +154,7 @@
+ qprintdialog_hook.h \
+ qprintpreviewdialog_hook.h \
+ qsystemtrayicon_hook.h \
+- qgraphicsscene_hook.h \
+- qabstractsocket_hook.h \
+- qudpsocket_hook.h \
+- qtcpsocket_hook.h \
+- qtcpserver_hook.h \
+- qnetworkaccessmanager_hook.h \
+- qnetworkreply_hook.h \
+- qwebframe_hook.h \
+- qwebsecurityorigin_hook.h \
+- qwebdatabase_hook.h \
+- qwebhistory_hook.h \
+- qwebhistoryinterface_hook.h \
+- qwebpage_hook.h \
+- qwebsettings_hook.h \
+- qwebview_hook.h
++ qgraphicsscene_hook.h
+
+ SOURCES += qt4pas.cpp \
+ qobject_hook_c.cpp \
+@@ -335,32 +320,6 @@
+ qstylefactory_c.cpp \
+ qgraphicsscene_c.cpp \
+ qgraphicsview_c.cpp \
+- qsslcipher_c.cpp \
+- qsslkey_c.cpp \
+- qsslerror_c.cpp \
+- qabstractsocket_c.cpp \
+- qudpsocket_c.cpp \
+- qtcpsocket_c.cpp \
+- qtcpserver_c.cpp \
+- qsslconfiguration_c.cpp \
+- qsslsocket_c.cpp \
+- qnetworkaccessmanager_c.cpp \
+- qnetworkrequest_c.cpp \
+- qnetworkreply_c.cpp \
+- qnetworkcookie_c.cpp \
+- qlclnetworkcookie_c.cpp \
+- qnetworkproxy_c.cpp \
+- qauthenticator_c.cpp \
+- qwebframe_c.cpp \
+- qwebsecurityorigin_c.cpp \
+- qwebdatabase_c.cpp \
+- qwebhistory_c.cpp \
+- qwebhistoryinterface_c.cpp \
+- qwebpage_c.cpp \
+- qlclwebpage_c.cpp \
+- qwebsettings_c.cpp \
+- qwebview_c.cpp \
+- qlclwebview_c.cpp \
+ qcoreapplication_hook_c.cpp \
+ qtimer_hook_c.cpp \
+ qabstractitemmodel_hook_c.cpp \
+@@ -434,20 +393,6 @@
+ qprintdialog_hook_c.cpp \
+ qprintpreviewdialog_hook_c.cpp \
+ qsystemtrayicon_hook_c.cpp \
+- qgraphicsscene_hook_c.cpp \
+- qabstractsocket_hook_c.cpp \
+- qudpsocket_hook_c.cpp \
+- qtcpsocket_hook_c.cpp \
+- qtcpserver_hook_c.cpp \
+- qnetworkaccessmanager_hook_c.cpp \
+- qnetworkreply_hook_c.cpp \
+- qwebframe_hook_c.cpp \
+- qwebsecurityorigin_hook_c.cpp \
+- qwebdatabase_hook_c.cpp \
+- qwebhistory_hook_c.cpp \
+- qwebhistoryinterface_hook_c.cpp \
+- qwebpage_hook_c.cpp \
+- qwebsettings_hook_c.cpp \
+- qwebview_hook_c.cpp
++ qgraphicsscene_hook_c.cpp
+
+ # end of file
+\ No newline at end of file
+Index: src/qt4pas.cpp
+===================================================================
+--- src/qt4pas.cpp (revision 1)
++++ src/qt4pas.cpp (working copy)
+@@ -15,8 +15,6 @@
+
+ #include <QtCore>
+ #include <QtGui>
+-#include <QtNetwork>
+-#include <QtWebKit>
+
+
+ #include "qobject_hook_c.cpp"
+@@ -182,32 +180,6 @@
+ #include "qstylefactory_c.cpp"
+ #include "qgraphicsscene_c.cpp"
+ #include "qgraphicsview_c.cpp"
+-#include "qsslcipher_c.cpp"
+-#include "qsslkey_c.cpp"
+-#include "qsslerror_c.cpp"
+-#include "qabstractsocket_c.cpp"
+-#include "qudpsocket_c.cpp"
+-#include "qtcpsocket_c.cpp"
+-#include "qtcpserver_c.cpp"
+-#include "qsslconfiguration_c.cpp"
+-#include "qsslsocket_c.cpp"
+-#include "qnetworkaccessmanager_c.cpp"
+-#include "qnetworkrequest_c.cpp"
+-#include "qnetworkreply_c.cpp"
+-#include "qnetworkcookie_c.cpp"
+-#include "qlclnetworkcookie_c.cpp"
+-#include "qnetworkproxy_c.cpp"
+-#include "qauthenticator_c.cpp"
+-#include "qwebframe_c.cpp"
+-#include "qwebsecurityorigin_c.cpp"
+-#include "qwebdatabase_c.cpp"
+-#include "qwebhistory_c.cpp"
+-#include "qwebhistoryinterface_c.cpp"
+-#include "qwebpage_c.cpp"
+-#include "qlclwebpage_c.cpp"
+-#include "qwebsettings_c.cpp"
+-#include "qwebview_c.cpp"
+-#include "qlclwebview_c.cpp"
+ #include "qcoreapplication_hook_c.cpp"
+ #include "qtimer_hook_c.cpp"
+ #include "qabstractitemmodel_hook_c.cpp"
+@@ -282,17 +254,3 @@
+ #include "qprintpreviewdialog_hook_c.cpp"
+ #include "qsystemtrayicon_hook_c.cpp"
+ #include "qgraphicsscene_hook_c.cpp"
+-#include "qabstractsocket_hook_c.cpp"
+-#include "qudpsocket_hook_c.cpp"
+-#include "qtcpsocket_hook_c.cpp"
+-#include "qtcpserver_hook_c.cpp"
+-#include "qnetworkaccessmanager_hook_c.cpp"
+-#include "qnetworkreply_hook_c.cpp"
+-#include "qwebframe_hook_c.cpp"
+-#include "qwebsecurityorigin_hook_c.cpp"
+-#include "qwebdatabase_hook_c.cpp"
+-#include "qwebhistory_hook_c.cpp"
+-#include "qwebhistoryinterface_hook_c.cpp"
+-#include "qwebpage_hook_c.cpp"
+-#include "qwebsettings_hook_c.cpp"
+-#include "qwebview_hook_c.cpp"