summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPier Luigi Fiorini2017-05-28 21:29:11 +0200
committerPier Luigi Fiorini2017-05-28 21:29:11 +0200
commitaf1bc1881768ef41995a6ad9c676215e24483672 (patch)
treefe7855b3c39afea793918c872a867d2f460f392e
downloadaur-af1bc1881768ef41995a6ad9c676215e24483672.tar.gz
Initial import
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD27
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9a90d7de640b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Sun May 28 19:29:08 UTC 2017
+pkgbase = qt5-accountsservice
+ pkgdesc = Qt-style wrapper for Accounts Service
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://liri.io
+ arch = i686
+ arch = x86_64
+ arch = armv6h
+ arch = armv7h
+ groups = liri
+ license = LGPL3
+ makedepends = qbs
+ depends = qt5-declarative
+ source = https://github.com/lirios/qtaccountsservice/releases/download/v1.0.0/qtaccountsservice-1.0.0.tar.xz
+ sha256sums = ccfedf6f36cecfddb053e6cdf7ab4d79ab32e0d9831ae869c21a3f20e5f86ede
+
+pkgname = qt5-accountsservice
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..155ce978f2df
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Pier Luigi Fiorini <pierluigi.fiorini@gmail.com>
+
+pkgname=qt5-accountsservice
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="Qt-style wrapper for Accounts Service"
+arch=('i686' 'x86_64' 'armv6h' 'armv7h')
+url='https://liri.io'
+license=('LGPL3')
+depends=('qt5-declarative')
+makedepends=('qbs')
+groups=('liri')
+source=("https://github.com/lirios/qtaccountsservice/releases/download/v${pkgver}/qtaccountsservice-${pkgver}.tar.xz")
+sha256sums=('ccfedf6f36cecfddb053e6cdf7ab4d79ab32e0d9831ae869c21a3f20e5f86ede')
+
+build() {
+ cd qtaccountsservice-${pkgver}
+ qbs setup-toolchains --type gcc /usr/bin/g++ gcc
+ qbs setup-qt /usr/bin/qmake-qt5 qt5
+ qbs config profiles.qt5.baseProfile gcc
+ qbs build --no-install -d build profile:qt5 qbs.installRoot:/ qbs.installPrefix:usr lirideployment.qmlDir:lib/qt/qml
+}
+
+package() {
+ cd qtaccountsservice-${pkgver}
+ qbs install -d build --no-build -v --install-root $pkgdir profile:qt5
+}