summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSkycoder422017-08-14 14:22:15 +0200
committerSkycoder422017-08-14 14:22:15 +0200
commit5dae99dd214447248bfc7a63023f869a9bfbc911 (patch)
treea62c3202b4cda0a99245b5da632457e275809399
downloadaur-5dae99dd214447248bfc7a63023f869a9bfbc911.tar.gz
created package
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD35
-rw-r--r--qt5-apng-plugin.rule1
3 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b9199f3f15f0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = qt5-apng-plugin
+ pkgdesc = apng image plugin for Qt to support animated PNGs
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/Skycoder42/qapng
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = git
+ makedepends = qt5-tools
+ depends = qt5-base
+ depends = libpng
+ optdepends = repkg: Automatically rebuild the package on dependency updates
+ source = qt5-apng-plugin-1.0.0::git+https://github.com/Skycoder42/qapng.git#tag=1.0.0
+ source = qt5-apng-plugin.rule
+ sha256sums = SKIP
+ sha256sums = 536886c68918305f12db47b6d0e6fd2ebff8b6ac41ebdab7dc2985a23e739909
+
+pkgname = qt5-apng-plugin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a7f0dffa0c7c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Felix Barz <skycoder42.de@gmx.de>
+pkgname=qt5-apng-plugin
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="apng image plugin for Qt to support animated PNGs"
+arch=('i686' 'x86_64')
+url="https://github.com/Skycoder42/qapng"
+license=('BSD')
+depends=('qt5-base' 'libpng')
+makedepends=('git' 'qt5-tools')
+optdepends=("repkg: Automatically rebuild the package on dependency updates")
+_pkgfqn=$pkgname-$pkgver
+source=("$_pkgfqn::git+https://github.com/Skycoder42/qapng.git#tag=$pkgver"
+ "$pkgname.rule")
+sha256sums=('SKIP'
+ '536886c68918305f12db47b6d0e6fd2ebff8b6ac41ebdab7dc2985a23e739909')
+
+prepare() {
+ mkdir -p build
+}
+
+build() {
+ cd build
+
+ qmake -r "../$_pkgfqn/"
+ make
+}
+
+package() {
+ cd build
+ make INSTALL_ROOT="$pkgdir" install
+
+ install -D -m644 "../$_pkgfqn/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -D -m644 "../${pkgname}.rule" "$pkgdir/etc/repkg/rules/${pkgname}.rule"
+}
diff --git a/qt5-apng-plugin.rule b/qt5-apng-plugin.rule
new file mode 100644
index 000000000000..2247db2479b7
--- /dev/null
+++ b/qt5-apng-plugin.rule
@@ -0,0 +1 @@
+qt5-base libpng