summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSkycoder422020-01-07 11:36:53 +0100
committerSkycoder422020-01-07 11:36:53 +0100
commit2ae0bd7943cf52c40fd4885cbdf9527433b7b180 (patch)
tree8d12ce23d2a13e7ae2cb11899f058dfc41993594
parent15404b6376d2bed7eac331ccbdfea0c8b3d23c86 (diff)
downloadaur-2ae0bd7943cf52c40fd4885cbdf9527433b7b180.tar.gz
update to 3.0.0-3 (fix for Qt 5.14)
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f7d35b7f9d1d..81e6983992bd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = qt5-autoupdater
pkgdesc = A Qt library to automatically check for updates and install them
pkgver = 3.0.0
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/Skycoder42/QtAutoUpdater
arch = i686
arch = x86_64
@@ -16,7 +16,7 @@ pkgbase = qt5-autoupdater
depends = qt5-base
depends = qt5-quickcontrols2
optdepends = repkg: Automatically rebuild the package on dependency updates
- source = qt5-autoupdater-3.0.0::git+https://github.com/Skycoder42/QtAutoUpdater.git#tag=3.0.0
+ source = qt5-autoupdater-3.0.0::git+https://github.com/Skycoder42/QtAutoUpdater.git#tag=3.0.0-3
source = qt5-autoupdater.rule
source = subpkg.rule
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index a24229d9c640..2447da0afb4e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ pkgbase=qt5-autoupdater
pkgname=(qt5-autoupdater qt5-autoupdater-qtifw qt5-autoupdater-packagekit qt5-autoupdater-doc)
group=qt5-autoupdater-full
pkgver=3.0.0
-pkgrel=2
+pkgrel=3
pkgdesc="A Qt library to automatically check for updates and install them"
arch=('i686' 'x86_64')
url="https://github.com/Skycoder42/QtAutoUpdater"
@@ -12,7 +12,7 @@ depends=('qt5-base' 'qt5-quickcontrols2')
makedepends=('git' 'qt5-tools' 'packagekit-qt5' 'qdep' 'python' 'doxygen' 'graphviz')
optdepends=("repkg: Automatically rebuild the package on dependency updates")
_pkgfqn=$pkgname-$pkgver
-source=("$_pkgfqn::git+https://github.com/Skycoder42/QtAutoUpdater.git#tag=$pkgver"
+source=("$_pkgfqn::git+https://github.com/Skycoder42/QtAutoUpdater.git#tag=$pkgver-3"
"$pkgname.rule"
"subpkg.rule")
sha256sums=('SKIP'
@@ -34,7 +34,7 @@ build() {
package_qt5-autoupdater() {
cd build/src/autoupdatercore
make INSTALL_ROOT="$pkgdir" install
- cd ../plugins/updater/qwebquery
+ cd ../plugins/updaters/qwebquery
make INSTALL_ROOT="$pkgdir" install
cd ../../../autoupdaterwidgets
make INSTALL_ROOT="$pkgdir" install
@@ -56,7 +56,7 @@ package_qt5-autoupdater-qtifw() {
depends=('qt5-autoupdater')
optdepends=()
- cd build/src/plugins/updater/qtifw
+ cd build/src/plugins/updaters/qtifw
make INSTALL_ROOT="$pkgdir" install
cd "../../../../../$_pkgfqn"
@@ -67,7 +67,7 @@ package_qt5-autoupdater-packagekit() {
depends=('qt5-autoupdater' 'packagekit-qt5')
optdepends=()
- cd build/src/plugins/updater/qpackagekit
+ cd build/src/plugins/updaters/qpackagekit
make INSTALL_ROOT="$pkgdir" install
cd "../../../../../$_pkgfqn"