summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSkycoder422017-11-20 11:52:35 +0100
committerSkycoder422017-11-20 11:52:35 +0100
commit0436d894e581ed4da2abd628b788b63699bd1126 (patch)
tree7ee62adc5e1be4d9a6e0bd299af028e389b2b23b
parentbd513cf9a7a1032f3520fd0442407939236e5535 (diff)
downloadaur-0436d894e581ed4da2abd628b788b63699bd1126.tar.gz
updated to 1.6.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD12
2 files changed, 9 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 175ddc5572da..8f32a233f159 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
pkgbase = qt5-backgroundprocess
pkgdesc = A Library to create background applications with simple, automated foreground control
- pkgver = 1.5.2
- pkgrel = 2
+ pkgver = 1.6.0
+ pkgrel = 1
url = https://github.com/Skycoder42/QtBackgroundProcess
arch = i686
arch = x86_64
license = BSD
makedepends = qt5-tools
makedepends = git
- makedepends = qpm
+ makedepends = qpmx-qpmsource
depends = qt5-base
optdepends = repkg: Automatically rebuild the package on dependency updates
- source = qt5-backgroundprocess-1.5.2::git+https://github.com/Skycoder42/QtBackgroundProcess.git#tag=1.5.2
+ source = qt5-backgroundprocess-1.6.0::git+https://github.com/Skycoder42/QtBackgroundProcess.git#tag=1.6.0
source = qt5-backgroundprocess.rule
sha256sums = SKIP
sha256sums = 2147916eaeebda7109b04f17e122a873388f42f2015e4b6b9fbf6f98e8e80d15
diff --git a/PKGBUILD b/PKGBUILD
index 38c407dc3d68..d96aa73ca621 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: Felix Barz <skycoder42.de@gmx.de>
pkgname=qt5-backgroundprocess
-pkgver=1.5.2
-pkgrel=2
+pkgver=1.6.0
+pkgrel=1
pkgdesc="A Library to create background applications with simple, automated foreground control"
arch=('i686' 'x86_64')
url="https://github.com/Skycoder42/QtBackgroundProcess"
license=('BSD')
depends=('qt5-base')
-makedepends=('qt5-tools' 'git' 'qpm')
+makedepends=('qt5-tools' 'git' 'qpmx-qpmsource')
optdepends=("repkg: Automatically rebuild the package on dependency updates")
_pkgfqn=$pkgname-$pkgver
source=("$_pkgfqn::git+https://github.com/Skycoder42/QtBackgroundProcess.git#tag=$pkgver"
@@ -17,15 +17,13 @@ sha256sums=('SKIP'
prepare() {
mkdir -p build
-
- cd "$_pkgfqn/src/3rdparty"
- qpm install
}
build() {
cd build
- qmake -r "../$_pkgfqn/"
+ qmake "../$_pkgfqn/"
+ make qmake_all
make
}