summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSkycoder422017-08-24 11:04:27 +0200
committerSkycoder422017-08-24 11:04:27 +0200
commit32fa833385717a8103ef7754c8f245713b959aa2 (patch)
treea57e6a97116c4a663bc04533d214d7bc332e3d9e
parent54e7faa08e349832b32ac7a064eb7af5f9a45b73 (diff)
downloadaur-32fa833385717a8103ef7754c8f245713b959aa2.tar.gz
updated to 1.5.2
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD20
-rw-r--r--qt5-backgroundprocess.rule1
3 files changed, 22 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 886e0b831be1..27053205ed64 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,20 @@
pkgbase = qt5-backgroundprocess
pkgdesc = A Library to create background applications with simple, automated foreground control
- pkgver = 1.5.1
- pkgrel = 5
+ pkgver = 1.5.2
+ pkgrel = 1
url = https://github.com/Skycoder42/QtBackgroundProcess
arch = i686
arch = x86_64
license = BSD
+ makedepends = qt5-tools
makedepends = git
+ makedepends = qpm
depends = qt5-base
- depends = qt5-tools
- source = qt5-backgroundprocess-1.5.1::git+https://github.com/Skycoder42/QtBackgroundProcess.git#tag=1.5.1
- md5sums = SKIP
+ optdepends = repkg: Automatically rebuild the package on dependency updates
+ source = qt5-backgroundprocess-1.5.2::git+https://github.com/Skycoder42/QtBackgroundProcess.git#tag=1.5.2
+ source = qt5-backgroundprocess.rule
+ sha256sums = SKIP
+ sha256sums = 42
pkgname = qt5-backgroundprocess
diff --git a/PKGBUILD b/PKGBUILD
index 1cbae4b3d5ec..d210c82b7bbe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,25 @@
# Maintainer: Felix Barz <skycoder42.de@gmx.de>
pkgname=qt5-backgroundprocess
-pkgver=1.5.1
-pkgrel=5
+pkgver=1.5.2
+pkgrel=1
pkgdesc="A Library to create background applications with simple, automated foreground control"
arch=('i686' 'x86_64')
url="https://github.com/Skycoder42/QtBackgroundProcess"
license=('BSD')
-depends=('qt5-base' 'qt5-tools')
-makedepends=('git')
+depends=('qt5-base')
+makedepends=('qt5-tools' 'git' 'qpm')
+optdepends=("repkg: Automatically rebuild the package on dependency updates")
_pkgfqn=$pkgname-$pkgver
-source=("$_pkgfqn::git+https://github.com/Skycoder42/QtBackgroundProcess.git#tag=$pkgver")
-md5sums=('SKIP')
+source=("$_pkgfqn::git+https://github.com/Skycoder42/QtBackgroundProcess.git#tag=$pkgver"
+ "${pkgname}.rule")
+sha256sums=('SKIP'
+ '42')
prepare() {
mkdir -p build
- cd "$_pkgfqn"
- git submodule update --init --recursive
+ cd "$_pkgfqn/src/3rdparty"
+ qpm install
}
build() {
@@ -35,4 +38,5 @@ package() {
-exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
install -D -m644 "../$_pkgfqn/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -D -m644 "../${pkgname}.rule" "$pkgdir/etc/repkg/rules/${pkgname}.rule"
}
diff --git a/qt5-backgroundprocess.rule b/qt5-backgroundprocess.rule
new file mode 100644
index 000000000000..5317ab13edbd
--- /dev/null
+++ b/qt5-backgroundprocess.rule
@@ -0,0 +1 @@
+qt5-base