summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCian Mc Govern2020-01-04 22:00:36 +0000
committerCian Mc Govern2020-01-04 22:00:36 +0000
commitb4aab7b40201b36fdc05eb5f64ca4e69013a700c (patch)
tree79b813525f9e428a50c51c0197c2f0a2e8a6584b
downloadaur-b4aab7b40201b36fdc05eb5f64ca4e69013a700c.tar.gz
Initial commit
-rw-r--r--.SRCINFO60
-rw-r--r--PKGBUILD118
-rw-r--r--QTBUG-62893.diff34
-rw-r--r--harmony-fix.diff76
4 files changed, 288 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6446afcc29bd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,60 @@
+pkgbase = qt5-base-595
+ pkgdesc = A cross-platform application and UI framework (v5.9.5)
+ pkgver = 5.9.5
+ pkgrel = 1
+ url = http://qt-project.org/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ license = LGPL3
+ license = FDL
+ license = custom
+ makedepends = libfbclient
+ makedepends = libmariadbclient
+ makedepends = sqlite
+ makedepends = unixodbc
+ makedepends = postgresql-libs
+ makedepends = alsa-lib
+ makedepends = gst-plugins-base-libs
+ makedepends = gtk3
+ makedepends = libpulse
+ makedepends = cups
+ makedepends = freetds
+ depends = libjpeg-turbo
+ depends = xcb-util-keysyms
+ depends = xcb-util-renderutil
+ depends = libgl
+ depends = fontconfig
+ depends = xcb-util-wm
+ depends = libxrender
+ depends = libxi
+ depends = sqlite
+ depends = xcb-util-image
+ depends = icu
+ depends = pcre2
+ depends = tslib
+ depends = libinput
+ depends = libsm
+ depends = libxkbcommon-x11
+ depends = libproxy
+ depends = libcups
+ depends = openssl-1.0
+ depends = double-conversion
+ conflicts = qtchooser
+ source = http://download.qt.io/official_releases/qt/5.9/5.9.5/submodules/qtbase-opensource-src-5.9.5.tar.xz
+ source = harmony-fix.diff
+ source = QTBUG-62893.diff
+ sha256sums = 7d3ef666d2efcf260a5a0780a1ccd49f897e839e1d9932225be4859ec26730d4
+ sha256sums = 8451c0a86e887492b706950ce533c616e687b790c54e86fb1f405dc2074737a3
+ sha256sums = b52c6fef1c1d3d7de946144631379d8391a0fbe3905021011ef29fd6f37e84a2
+
+pkgname = qt5-base-595
+ pkgdesc = A cross-platform application and UI framework (v5.9.5)
+
+pkgname = qt5-xcb-private-headers-595
+ pkgdesc = Private headers for Qt5 Xcb (v5.9.5)
+ groups =
+ depends = qt5-base-595=5.9.5
+ optdepends =
+ conflicts =
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9bd835f83dc5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,118 @@
+# Maintainer: Cian McGovern <cian@cianmcgovern.com>
+# Contributor: Felix Yan <felixonmars@archlinux.org>
+# Contributor: Andrea Scarpino <andrea@archlinux.org>
+
+pkgbase=qt5-base-595
+pkgname=(qt5-base-595 qt5-xcb-private-headers-595)
+_qtver=5.9.5
+pkgver=${_qtver/-/}
+pkgrel=1
+arch=('i686' 'x86_64')
+url='http://qt-project.org/'
+license=('GPL3' 'LGPL3' 'FDL' 'custom')
+pkgdesc='A cross-platform application and UI framework (v5.9.5)'
+depends=('libjpeg-turbo' 'xcb-util-keysyms' 'xcb-util-renderutil' 'libgl' 'fontconfig'
+ 'xcb-util-wm' 'libxrender' 'libxi' 'sqlite' 'xcb-util-image' 'icu' 'pcre2'
+ 'tslib' 'libinput' 'libsm' 'libxkbcommon-x11' 'libproxy' 'libcups' 'openssl-1.0' 'double-conversion')
+makedepends=('libfbclient' 'libmariadbclient' 'sqlite' 'unixodbc' 'postgresql-libs' 'alsa-lib' 'gst-plugins-base-libs'
+ 'gtk3' 'libpulse' 'cups' 'freetds')
+conflicts=('qtchooser')
+_pkgfqn="qtbase-opensource-src-${_qtver}"
+source=("http://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz"
+ harmony-fix.diff
+ QTBUG-62893.diff)
+sha256sums=('7d3ef666d2efcf260a5a0780a1ccd49f897e839e1d9932225be4859ec26730d4'
+ '8451c0a86e887492b706950ce533c616e687b790c54e86fb1f405dc2074737a3'
+ 'b52c6fef1c1d3d7de946144631379d8391a0fbe3905021011ef29fd6f37e84a2')
+
+prepare() {
+ cd ${_pkgfqn}
+
+ # Build qmake using Arch {C,LD}FLAGS
+ # This also sets default {C,CXX,LD}FLAGS for projects built using qmake
+ sed -i -e "s|^\(QMAKE_CFLAGS_RELEASE.*\)|\1 ${CFLAGS}|" \
+ mkspecs/common/gcc-base.conf
+ sed -i -e "s|^\(QMAKE_LFLAGS_RELEASE.*\)|\1 ${LDFLAGS}|" \
+ mkspecs/common/g++-unix.conf
+
+ # Use python2 for Python 2.x
+ find . -name '*.py' -exec sed -i \
+ 's|#![ ]*/usr/bin/python$|&2|;s|#![ ]*/usr/bin/env python$|&2|' {} +
+
+ # Fix missing private includes https://bugreports.qt.io/browse/QTBUG-37417
+ sed -e '/CMAKE_NO_PRIVATE_INCLUDES\ \=\ true/d' -i mkspecs/features/create_cmake.prf
+
+ # Freetype 2.8.1
+ patch -p1 -i ../harmony-fix.diff
+
+ # https://bugreports.qt.io/browse/QTBUG-62893
+ patch -p1 -i ../QTBUG-62893.diff
+}
+
+build() {
+ cd ${_pkgfqn}
+
+ # FS#38796
+ [[ "${CARCH}" = "i686" ]] && SSE2="-no-sse2"
+
+ echo "INCLUDEPATH += /usr/include/openssl-1.0" >> src/network/network.pro
+ export OPENSSL_LIBS='-L/usr/lib/openssl-1.0 -lssl -lcrypto'
+
+ PYTHON=/usr/bin/python2 ./configure -confirm-license -opensource -v \
+ -prefix /opt/qt595 \
+ -docdir /opt/qt595/share/doc/qt \
+ -headerdir /opt/qt595/include/qt \
+ -archdatadir /opt/qt595/lib/qt \
+ -datadir /opt/qt595/share/qt \
+ -sysconfdir /etc/xdg \
+ -examplesdir /opt/qt595/share/doc/qt/examples \
+ -plugin-sql-{psql,mysql,sqlite,odbc,ibase} \
+ -system-sqlite \
+ -openssl-linked \
+ -nomake examples \
+ -rpath \
+ -optimized-qmake \
+ -dbus-linked \
+ -system-harfbuzz \
+ -journald \
+ -no-use-gold-linker \
+ -reduce-relocations ${SSE2}
+
+ make
+}
+
+package_qt5-base-595() {
+ pkgdesc='A cross-platform application and UI framework (v5.9.5)'
+
+ cd ${_pkgfqn}
+ make INSTALL_ROOT="${pkgdir}" install
+
+ install -D -m644 LGPL_EXCEPTION.txt \
+ "${pkgdir}"/opt/qt595/share/licenses/qt5-base-595/LGPL_EXCEPTION.txt
+
+ # Drop QMAKE_PRL_BUILD_DIR because reference the build dir
+ find "${pkgdir}/opt/qt595/lib" -type f -name '*.prl' \
+ -exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
+
+ # Fix wrong qmake path in pri file
+ sed -i "s|${srcdir}/${_pkgfqn}|/opt/qt595|" \
+ "${pkgdir}"/opt/qt595/lib/qt/mkspecs/modules/qt_lib_bootstrap_private.pri
+
+ # Symlinks for backwards compatibility
+ for b in "${pkgdir}"/opt/qt595/bin/*; do
+ ln -s /opt/qt595/bin/$(basename $b) "${pkgdir}"/opt/qt595/bin/$(basename $b)-qt5
+ done
+}
+
+package_qt5-xcb-private-headers-595() {
+ pkgdesc='Private headers for Qt5 Xcb (v5.9.5)'
+
+ depends=("qt5-base-595=$pkgver")
+ optdepends=()
+ groups=()
+ conflicts=()
+
+ cd ${_pkgfqn}
+ install -d -m755 "$pkgdir"/opt/qt595/include/qtxcb-private
+ cp -r src/plugins/platforms/xcb/*.h "$pkgdir"/opt/qt595/include/qtxcb-private/
+}
diff --git a/QTBUG-62893.diff b/QTBUG-62893.diff
new file mode 100644
index 000000000000..f3e2a798e359
--- /dev/null
+++ b/QTBUG-62893.diff
@@ -0,0 +1,34 @@
+From 9a640e7bc67b0a1ff5c61c63703b669e6f24521e Mon Sep 17 00:00:00 2001
+From: Laszlo Agocs <laszlo.agocs@qt.io>
+Date: Wed, 26 Apr 2017 03:31:04 -0700
+Subject: eglfs_kms_egldevice: Fix type mess in nativeDisplay() virtual
+
+EGLNativeDisplayType is void* on NVIDIA systems but the backend may get compiled
+on others where it is something else. The function definition does not match
+the proto on these so it is time to correct this.
+
+Change-Id: I569d9f8f3fcba7b2a4672d83606dfdc7bb18a1f0
+Reviewed-by: Johan Helsing <johan.helsing@qt.io>
+---
+ .../deviceintegration/eglfs_kms_egldevice/qeglfskmsegldevice.cpp | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/plugins/platforms/eglfs/deviceintegration/eglfs_kms_egldevice/qeglfskmsegldevice.cpp b/src/plugins/platforms/eglfs/deviceintegration/eglfs_kms_egldevice/qeglfskmsegldevice.cpp
+index 0a66a897a1..cca413ff2d 100644
+--- a/src/plugins/platforms/eglfs/deviceintegration/eglfs_kms_egldevice/qeglfskmsegldevice.cpp
++++ b/src/plugins/platforms/eglfs/deviceintegration/eglfs_kms_egldevice/qeglfskmsegldevice.cpp
+@@ -77,9 +77,9 @@ void QEglFSKmsEglDevice::close()
+ setFd(-1);
+ }
+
+-EGLNativeDisplayType QEglFSKmsEglDevice::nativeDisplay() const
++void *QEglFSKmsEglDevice::nativeDisplay() const
+ {
+- return reinterpret_cast<EGLNativeDisplayType>(m_devInt->eglDevice());
++ return m_devInt->eglDevice();
+ }
+
+ QPlatformScreen *QEglFSKmsEglDevice::createScreen(const QKmsOutput &output)
+--
+cgit v1.2.1
+
diff --git a/harmony-fix.diff b/harmony-fix.diff
new file mode 100644
index 000000000000..bd3d00107ad9
--- /dev/null
+++ b/harmony-fix.diff
@@ -0,0 +1,76 @@
+diff -u -r qtbase-opensource-src-5.9.1/src/platformsupport/fontdatabases/freetype/qfontengine_ft.cpp qtbase-opensource-src-5.9.1-ftharmony/src/platformsupport/fontdatabases/freetype/qfontengine_ft.cpp
+--- qtbase-opensource-src-5.9.1/src/platformsupport/fontdatabases/freetype/qfontengine_ft.cpp 2017-06-28 11:54:29.000000000 +0200
++++ qtbase-opensource-src-5.9.1-ftharmony/src/platformsupport/fontdatabases/freetype/qfontengine_ft.cpp 2017-09-19 21:31:27.803755180 +0200
+@@ -786,6 +786,7 @@
+ m_subPixelPositionCount = 4;
+ forceAutoHint = false;
+ stemDarkeningDriver = false;
++ hasLcdRendering = false;
+ }
+
+ QFontEngineFT::~QFontEngineFT()
+@@ -909,6 +910,15 @@
+ }
+ #endif
+
++ FT_Int amajor = 0, aminor = 0, apatch = 0;
++ FT_Library_Version(qt_getFreetype(), &amajor, &aminor, &apatch);
++ if (amajor > 2 || amajor == 2 && (aminor > 8 || aminor == 8 && apatch >= 1))
++ hasLcdRendering = true;
++#if defined(QT_USE_FREETYPE_LCDFILTER)
++ else if (FT_Library_SetLcdFilter(qt_getFreetype(), FT_LCD_FILTER_NONE) == FT_Err_Ok)
++ hasLcdRendering = true;
++#endif
++
+ fontDef.styleName = QString::fromUtf8(face->style_name);
+
+ if (!freetype->hbFace) {
+@@ -1165,21 +1175,19 @@
+
+ int glyph_buffer_size = 0;
+ QScopedArrayPointer<uchar> glyph_buffer;
++ if (hasLcdRendering && slot->format == FT_GLYPH_FORMAT_OUTLINE && (hsubpixel || vfactor != 1)) {
+ #if defined(QT_USE_FREETYPE_LCDFILTER)
+- bool useFreetypeRenderGlyph = false;
+- if (slot->format == FT_GLYPH_FORMAT_OUTLINE && (hsubpixel || vfactor != 1)) {
+- err = FT_Library_SetLcdFilter(slot->library, (FT_LcdFilter)lcdFilterType);
+- if (err == FT_Err_Ok)
+- useFreetypeRenderGlyph = true;
+- }
++ FT_Library_SetLcdFilter(slot->library, (FT_LcdFilter)lcdFilterType);
++#endif
+
+- if (useFreetypeRenderGlyph) {
+ err = FT_Render_Glyph(slot, hsubpixel ? FT_RENDER_MODE_LCD : FT_RENDER_MODE_LCD_V);
+
+ if (err != FT_Err_Ok)
+ qWarning("render glyph failed err=%x face=%p, glyph=%d", err, face, glyph);
+
++#if defined(QT_USE_FREETYPE_LCDFILTER)
+ FT_Library_SetLcdFilter(slot->library, FT_LCD_FILTER_NONE);
++#endif
+
+ info.height = slot->bitmap.rows / vfactor;
+ info.width = hsubpixel ? slot->bitmap.width / 3 : slot->bitmap.width;
+@@ -1193,9 +1201,7 @@
+ convertRGBToARGB(slot->bitmap.buffer, (uint *)glyph_buffer.data(), info.width, info.height, slot->bitmap.pitch, subpixelType != Subpixel_RGB, false);
+ else if (vfactor != 1)
+ convertRGBToARGB_V(slot->bitmap.buffer, (uint *)glyph_buffer.data(), info.width, info.height, slot->bitmap.pitch, subpixelType != Subpixel_VRGB, false);
+- } else
+-#endif
+- {
++ } else {
+ int left = slot->metrics.horiBearingX;
+ int right = slot->metrics.horiBearingX + slot->metrics.width;
+ int top = slot->metrics.horiBearingY;
+diff -u -r qtbase-opensource-src-5.9.1/src/platformsupport/fontdatabases/freetype/qfontengine_ft_p.h qtbase-opensource-src-5.9.1-ftharmony/src/platformsupport/fontdatabases/freetype/qfontengine_ft_p.h
+--- qtbase-opensource-src-5.9.1/src/platformsupport/fontdatabases/freetype/qfontengine_ft_p.h 2017-06-28 11:54:29.000000000 +0200
++++ qtbase-opensource-src-5.9.1-ftharmony/src/platformsupport/fontdatabases/freetype/qfontengine_ft_p.h 2017-09-19 21:27:52.433263233 +0200
+@@ -311,6 +311,7 @@
+ bool cacheEnabled;
+ bool forceAutoHint;
+ bool stemDarkeningDriver;
++ bool hasLcdRendering;
+
+ private:
+ friend class QFontEngineFTRawFont;