summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRiley Trautman2016-02-01 15:56:33 -0600
committerRiley Trautman2016-02-01 15:56:33 -0600
commitf3a92f575f51e67de7bf991db88e2a0da17f42fd (patch)
tree20b211670f0369a2c220ec997cb46b1a9c2a6444
parent0b2ed09b70744fe5f05a24d025e94c6f38575c94 (diff)
downloadaur-f3a92f575f51e67de7bf991db88e2a0da17f42fd.tar.gz
Updated to 5.5.1.r133.ga40ea09
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD58
2 files changed, 31 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8bf24cd0616b..59f741bad4aa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sun Jan 31 01:48:32 UTC 2016
+# Mon Feb 1 21:56:33 UTC 2016
pkgbase = qt5-base-dev-git
pkgdesc = A cross-platform application and UI framework
- pkgver = 5.5.1.r129.g5ef14c5
- pkgrel = 1
+ pkgver = 5.5.1.r133.ga40ea09
+ pkgrel = 2
url = https://qt-project.org/
arch = i686
arch = x86_64
@@ -27,6 +27,7 @@ pkgbase = qt5-base-dev-git
depends = icu
depends = libxrender
depends = libinput
+ depends = qtchooser
optdepends = postgresql-libs: PostgreSQL driver
optdepends = libmariadbclient: MariaDB driver
optdepends = unixodbc: ODBC driver
diff --git a/PKGBUILD b/PKGBUILD
index ba2907db3010..38a2fb13f0dd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,8 +5,8 @@
_pkgname=qt5-base
pkgname=$_pkgname-dev-git
-pkgver=5.5.1.r129.g5ef14c5
-pkgrel=1
+pkgver=5.5.1.r133.ga40ea09
+pkgrel=2
pkgdesc="A cross-platform application and UI framework"
arch=("i686" "x86_64")
url="https://qt-project.org/"
@@ -14,7 +14,7 @@ license=("GPL3" "LGPL")
depends=(
"dbus" "xcb-util-keysyms" "xcb-util-wm" "xcb-util-image"
"libxext" "inputproto" "libgl" "libxkbcommon" "systemd"
- "libpng" "sqlite" "fontconfig" "icu" "libxrender" "libinput"
+ "libpng" "sqlite" "fontconfig" "icu" "libxrender" "libinput" "qtchooser"
)
makedepends=("git" "postgresql-libs" "gtk2")
optdepends=(
@@ -46,36 +46,32 @@ prepare() {
}
build() {
- cd "$srcdir/$_pkgname"
+ cd "$srcdir/$_pkgname"
- ./configure -confirm-license -opensource \
- -prefix /usr \
- -bindir /usr/lib/qt/bin \
- -docdir /usr/share/doc/qt \
- -headerdir /usr/include/qt \
- -archdatadir /usr/lib/qt \
- -datadir /usr/share/qt \
- -sysconfdir /etc/xdg \
- -examplesdir /usr/share/doc/qt/examples \
- -system-sqlite \
- -openssl-linked \
- -nomake examples \
- -nomake tests \
- -no-rpath \
- -optimized-qmake \
- -dbus-linked \
- -reduce-relocations \
- -egl \
- -eglfs \
- -libinput
- make
+ ./configure -confirm-license -opensource \
+ -prefix /usr \
+ -bindir /usr/lib/qt/bin \
+ -docdir /usr/share/doc/qt \
+ -headerdir /usr/include/qt \
+ -archdatadir /usr/lib/qt \
+ -datadir /usr/share/qt \
+ -sysconfdir /etc/xdg \
+ -examplesdir /usr/share/doc/qt/examples \
+ -system-sqlite \
+ -openssl-linked \
+ -nomake examples \
+ -nomake tests \
+ -no-rpath \
+ -optimized-qmake \
+ -dbus-linked \
+ -reduce-relocations \
+ -egl \
+ -eglfs \
+ -libinput
+ make
}
package() {
- cd "$srcdir/$_pkgname"
- make INSTALL_ROOT="$pkgdir" install
- for file in "${pkgdir}"/usr/lib/qt/bin/*; do
- mkdir -p "${pkgdir}"/usr/bin
- ln -s /usr/lib/qt/bin/$(basename $file) "${pkgdir}"/usr/bin/$(basename $file)
- done
+ cd "$srcdir/$_pkgname"
+ make INSTALL_ROOT="$pkgdir" install
}