summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoão Figueiredo2021-08-31 01:36:50 +0100
committerJoão Figueiredo2021-08-31 01:36:50 +0100
commit0f92ef1fdcec8ff5b712c0aba24c3b9c70678c3b (patch)
treec261a17b8dfc98ed33df900b3540d46d1d033463
parent393d266f06b56fc20f800d1ce57a464d232caba0 (diff)
downloadaur-0f92ef1fdcec8ff5b712c0aba24c3b9c70678c3b.tar.gz
Merged with official ABS qt5-base PKGBUILD
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD20
-rw-r--r--qt5-qtbase-gcc11.patch67
-rw-r--r--qtbase-QTBUG-89977.patch11
-rw-r--r--qtbase-QTBUG-90395.patch23
-rw-r--r--qtbase-QTBUG-91909.patch31
6 files changed, 24 insertions, 155 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8c44a6882dc1..d0bf5fda66fc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,18 @@
pkgbase = qt5-base-git
pkgdesc = A cross-platform application and UI framework
- pkgver = 5.15.0.beta1.r69.gfbebc93617
+ pkgver = 5.15.2+kde_r43967.gd2bd04d9fe
pkgrel = 1
- url = https://qt-project.org/
- arch = i686
+ url = https://www.qt.io
arch = x86_64
+ groups = qt-git
+ groups = qt5-git
license = GPL3
license = LGPL3
license = FDL
license = custom
+ makedepends = git
makedepends = libfbclient
makedepends = mariadb-libs
- makedepends = sqlite
makedepends = unixodbc
makedepends = postgresql-libs
makedepends = alsa-lib
@@ -21,7 +22,6 @@ pkgbase = qt5-base-git
makedepends = cups
makedepends = freetds
makedepends = vulkan-headers
- makedepends = git
depends = libjpeg-turbo
depends = xcb-util-keysyms
depends = xcb-util-renderutil
@@ -52,11 +52,22 @@ pkgbase = qt5-base-git
optdepends = freetds: MS SQL driver
optdepends = gtk3: GTK platform plugin
optdepends = perl: for fixqt4headers and syncqt
- provides = qt5-base
- conflicts = qt5-base
conflicts = qtchooser
- source = qt5-base::git://code.qt.io/qt/qtbase.git#branch=5.15
+ conflicts = qtchooser-git
+ source = git+https://invent.kde.org/qt/qt/qtbase.git
+ source = qt5-base-cflags.patch
+ source = qt5-base-nostrip.patch
sha256sums = SKIP
+ sha256sums = cf707cd970650f8b60f8897692b36708ded9ba116723ec8fcd885576783fe85c
+ sha256sums = 4b93f6a79039e676a56f9d6990a324a64a36f143916065973ded89adc621e094
pkgname = qt5-base-git
+ pkgdesc = A cross-platform application and UI framework
+ provides = qt5-base
+ conflicts = qt5-base
+pkgname = qt5-xcb-private-headers-git
+ pkgdesc = Private headers for Qt5 Xcb
+ depends = qt5-base-git=5.15.2+kde_r43967.gd2bd04d9fe
+ provides = qt5-xcb-private-headers
+ conflicts = qt5-xcb-private-headers
diff --git a/PKGBUILD b/PKGBUILD
index 05eec1cf58a0..b57de974d352 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@
pkgbase=qt5-base-git
pkgname=(qt5-base-git qt5-xcb-private-headers-git)
-pkgver=5.15.2_r43754.g40143c189b
+pkgver=5.15.2+kde_r43967.gd2bd04d9fe
pkgrel=1
arch=($CARCH)
url='https://www.qt.io'
@@ -31,32 +31,22 @@ optdepends=('qt5-svg: to use SVG icon themes'
'gtk3: GTK platform plugin'
'perl: for fixqt4headers and syncqt')
groups=(qt-git qt5-git)
-source=("git+https://github.com/qt/qtbase.git" qt5-base-cflags.patch qt5-base-nostrip.patch qt5-qtbase-gcc11.patch qtbase-QTBUG-89977.patch qtbase-QTBUG-90395.patch qtbase-QTBUG-91909.patch)
+source=("git+https://invent.kde.org/qt/qt/qtbase.git" qt5-base-cflags.patch qt5-base-nostrip.patch)
sha256sums=('SKIP'
'cf707cd970650f8b60f8897692b36708ded9ba116723ec8fcd885576783fe85c'
- '4b93f6a79039e676a56f9d6990a324a64a36f143916065973ded89adc621e094'
- 'b848bafd4eb3585cab5480196afdfdcaa251f4c56f6a93c765f7668cf48471d1'
- '435e44c35273e1f7f72e525996b0b93b08602fe9f83c751cb4270d8b67fbfec4'
- '1651229105d419937784d1b3b04955a5504142f48de3b4f96da051a76b6833f8'
- '726eccdddf6fbac3822fc6530a14d3fe3b83e671ca35563b4c2fa4f6644214a3')
+ '4b93f6a79039e676a56f9d6990a324a64a36f143916065973ded89adc621e094')
pkgver() {
cd qtbase
- echo "5.15.2_r$(git rev-list --count HEAD).g$(git rev-parse --short HEAD)"
+ echo "5.15.2+kde_r$(git rev-list --count HEAD).g$(git rev-parse --short HEAD)"
}
prepare() {
cd qtbase
- git checkout ${pkgver%%_*}
+ git checkout kde/5.15
patch -p1 < ../qt5-base-cflags.patch # Use system CFLAGS in qmake
patch -p1 < ../qt5-base-nostrip.patch # Don't strip binaries with qmake
-
- ## Fedora patches for gcc11 support
- patch -p1 < ../qt5-qtbase-gcc11.patch
- patch -p1 < ../qtbase-QTBUG-89977.patch
- patch -p1 < ../qtbase-QTBUG-90395.patch
- patch -p1 < ../qtbase-QTBUG-91909.patch
}
build() {
diff --git a/qt5-qtbase-gcc11.patch b/qt5-qtbase-gcc11.patch
deleted file mode 100644
index bef7623727b0..000000000000
--- a/qt5-qtbase-gcc11.patch
+++ /dev/null
@@ -1,67 +0,0 @@
-lude "qdatastream_p.h"
-
-+#include <limits>
-+
- #if !defined(QT_NO_DATASTREAM) || defined(QT_BOOTSTRAPPED)
- #include "qbuffer.h"
- #include "qfloat16.h"
-diff --git a/src/corelib/text/qbytearray.cpp b/src/corelib/text/qbytearray.cpp
-index 9a72df58..6651ee98 100644
---- a/src/corelib/text/qbytearray.cpp
-+++ b/src/corelib/text/qbytearray.cpp
-@@ -39,6 +39,7 @@
- **
- ****************************************************************************/
-
-+#include <limits>
- #include "qbytearray.h"
- #include "qbytearraymatcher.h"
- #include "private/qtools_p.h"
-diff --git a/src/corelib/text/qbytearraymatcher.cpp b/src/corelib/text/qbytearraymatcher.cpp
-index 72e09226..80511cb5 100644
---- a/src/corelib/text/qbytearraymatcher.cpp
-+++ b/src/corelib/text/qbytearraymatcher.cpp
-@@ -37,6 +37,7 @@
- **
- ****************************************************************************/
-
-+#include <limits>
- #include "qbytearraymatcher.h"
-
- #include <limits.h>
-diff --git a/src/corelib/tools/qbitarray.cpp b/src/corelib/tools/qbitarray.cpp
-index ab3054d5..22efb3a0 100644
---- a/src/corelib/tools/qbitarray.cpp
-+++ b/src/corelib/tools/qbitarray.cpp
-@@ -38,6 +38,7 @@
- **
- ****************************************************************************/
-
-+#include <limits>
- #include "qbitarray.h"
- #include <qalgorithms.h>
- #include <qdatastream.h>
-diff --git a/src/corelib/tools/qcryptographichash.cpp b/src/corelib/tools/qcryptographichash.cpp
-index fa8d21e0..cd85956d 100644
---- a/src/corelib/tools/qcryptographichash.cpp
-+++ b/src/corelib/tools/qcryptographichash.cpp
-@@ -38,6 +38,7 @@
- **
- ****************************************************************************/
-
-+#include <limits>
- #include <qcryptographichash.h>
- #include <qiodevice.h>
-
-diff --git a/src/gui/text/qfontengine_qpf2.cpp b/src/gui/text/qfontengine_qpf2.cpp
-index e00f9d05..917ab5f9 100644
---- a/src/gui/text/qfontengine_qpf2.cpp
-+++ b/src/gui/text/qfontengine_qpf2.cpp
-@@ -37,6 +37,7 @@
- **
- ****************************************************************************/
-
-+#include <limits>
- #include "qfontengine_qpf2_p.h"
-
- #include <QtCore/QFile>
diff --git a/qtbase-QTBUG-89977.patch b/qtbase-QTBUG-89977.patch
deleted file mode 100644
index cfaac113353e..000000000000
--- a/qtbase-QTBUG-89977.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-diff -up qtbase-everywhere-src-5.15.2/src/corelib/text/qbytearray.h.foo qtbase-everywhere-src-5.15.2/src/corelib/text/qbytearray.h
---- qtbase-everywhere-src-5.15.2/src/corelib/text/qbytearray.h.foo 2020-10-27 03:02:11.000000000 -0500
-+++ qtbase-everywhere-src-5.15.2/src/corelib/text/qbytearray.h 2021-02-06 17:05:04.879201352 -0600
-@@ -51,6 +49,7 @@
-
- #include <string>
- #include <iterator>
-+#include <limits>
-
- #ifdef truncate
- #error qbytearray.h must be included before any header file that defines truncate
diff --git a/qtbase-QTBUG-90395.patch b/qtbase-QTBUG-90395.patch
deleted file mode 100644
index cc4bb6ee994f..000000000000
--- a/qtbase-QTBUG-90395.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-diff -up qtbase-everywhere-src-5.15.2/src/corelib/global/qendian.h.QTBUG-90395 qtbase-everywhere-src-5.15.2/src/corelib/global/qendian.h
---- qtbase-everywhere-src-5.15.2/src/corelib/global/qendian.h.QTBUG-90395 2020-10-27 03:02:11.000000000 -0500
-+++ qtbase-everywhere-src-5.15.2/src/corelib/global/qendian.h 2021-02-06 16:36:27.072105717 -0600
-@@ -44,6 +44,8 @@
- #include <QtCore/qfloat16.h>
- #include <QtCore/qglobal.h>
-
-+#include <limits>
-+
- // include stdlib.h and hope that it defines __GLIBC__ for glibc-based systems
- #include <stdlib.h>
- #include <string.h>
-diff -up qtbase-everywhere-src-5.15.2/src/corelib/global/qfloat16.h.QTBUG-90395 qtbase-everywhere-src-5.15.2/src/corelib/global/qfloat16.h
---- qtbase-everywhere-src-5.15.2/src/corelib/global/qfloat16.h.QTBUG-90395 2021-02-06 16:36:27.074105730 -0600
-+++ qtbase-everywhere-src-5.15.2/src/corelib/global/qfloat16.h 2021-02-06 16:37:19.212440114 -0600
-@@ -43,6 +43,7 @@
-
- #include <QtCore/qglobal.h>
- #include <QtCore/qmetatype.h>
-+#include <limits>
- #include <string.h>
-
- #if defined(QT_COMPILER_SUPPORTS_F16C) && defined(__AVX2__) && !defined(__F16C__)
diff --git a/qtbase-QTBUG-91909.patch b/qtbase-QTBUG-91909.patch
deleted file mode 100644
index dd7e18fe41f3..000000000000
--- a/qtbase-QTBUG-91909.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-From 659f7a06e91c04b239e3f4c0bcfccbe3581af1c3 Mon Sep 17 00:00:00 2001
-From: Sona Kurazyan <sona.kurazyan@qt.io>
-Date: Wed, 17 Mar 2021 16:04:00 +0100
-Subject: [PATCH] Remove the unnecessary template parameter from the class specialization
-
-This seems to cause errors when compiling with gcc-11. Although this is
-most likely a compiler bug, specifiying the template parameter type in
-this case isn't necessary.
-
-Fixes: QTBUG-91909
-Fixes: QTBUG-90568
-Pick-to: 6.0 6.1 5.15
-Change-Id: Ib231257ccb2e16cc533f23ca5840d31e26a66d53
-Reviewed-by: MÃ¥rten Nordheim <marten.nordheim@qt.io>
----
-
-diff --git a/src/concurrent/qtconcurrentthreadengine.h b/src/concurrent/qtconcurrentthreadengine.h
-index cbd8ad04..4cd5b85 100644
---- a/src/concurrent/qtconcurrentthreadengine.h
-+++ b/src/concurrent/qtconcurrentthreadengine.h
-@@ -256,8 +256,8 @@
- class ThreadEngineStarter<void> : public ThreadEngineStarterBase<void>
- {
- public:
-- ThreadEngineStarter<void>(ThreadEngine<void> *_threadEngine)
-- :ThreadEngineStarterBase<void>(_threadEngine) {}
-+ ThreadEngineStarter(ThreadEngine<void> *_threadEngine)
-+ : ThreadEngineStarterBase<void>(_threadEngine) {}
-
- void startBlocking()
- {