summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRiley Trautman2016-02-01 15:55:13 -0600
committerRiley Trautman2016-02-01 15:55:13 -0600
commit62adde822ba1dcfc6f1aad7409ad4ed0fb3509e4 (patch)
treec098ab40faf05cf6485dcbb62c932c936face0de
parent2f383062f17adca3d69c5ba5e8b0e8fd5cef4dba (diff)
downloadaur-62adde822ba1dcfc6f1aad7409ad4ed0fb3509e4.tar.gz
Updated to git
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD78
2 files changed, 39 insertions, 42 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 45cbdc534519..9b8cc9979326 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Sun Jan 31 01:48:22 UTC 2016
+# Mon Feb 1 21:55:12 UTC 2016
pkgbase = qt5-base-git
pkgdesc = A cross-platform application and UI framework
pkgver = git
@@ -27,6 +27,7 @@ pkgbase = qt5-base-git
depends = icu
depends = libxrender
depends = libinput
+ depends = qtchooser
optdepends = qtchooser: set the default Qt toolkit
optdepends = postgresql-libs: PostgreSQL driver
optdepends = libmariadbclient: MariaDB driver
diff --git a/PKGBUILD b/PKGBUILD
index 4783daff5f41..a8cd8c49421b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,17 +12,17 @@ arch=("i686" "x86_64")
url="https://qt-project.org/"
license=("GPL3" "LGPL")
depends=(
- "dbus" "xcb-util-keysyms" "xcb-util-wm" "xcb-util-image"
- "libxext" "inputproto" "libgl" "libxkbcommon" "systemd"
- "libpng" "sqlite" "fontconfig" "icu" "libxrender" "libinput"
+"dbus" "xcb-util-keysyms" "xcb-util-wm" "xcb-util-image"
+"libxext" "inputproto" "libgl" "libxkbcommon" "systemd"
+"libpng" "sqlite" "fontconfig" "icu" "libxrender" "libinput" "qtchooser"
)
makedepends=("git" "postgresql-libs" "gtk2")
optdepends=(
- "qtchooser: set the default Qt toolkit"
- "postgresql-libs: PostgreSQL driver"
- "libmariadbclient: MariaDB driver"
- "unixodbc: ODBC driver"
- "libfbclient: Firebird/iBase driver"
+"qtchooser: set the default Qt toolkit"
+"postgresql-libs: PostgreSQL driver"
+"libmariadbclient: MariaDB driver"
+"unixodbc: ODBC driver"
+"libfbclient: Firebird/iBase driver"
)
provides=("$_pkgname")
conflicts=("$_pkgname" "qtchooser")
@@ -31,49 +31,45 @@ source=("$_pkgname::git://code.qt.io/qt/qtbase.git#branch=dev")
sha256sums=("SKIP")
pkgver() {
- cd "$srcdir/$_pkgname"
- # cutting off 'foo-' prefix that presents in the git tag
- git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ cd "$srcdir/$_pkgname"
+ # cutting off 'foo-' prefix that presents in the git tag
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
- cd "$srcdir/$_pkgname"
- sed -i "s|-O2|${CXXFLAGS}|" mkspecs/common/{g++,gcc}-base.conf
- sed -i "/^QMAKE_LFLAGS_RPATH/s| -Wl,-rpath,||g" "mkspecs/common/gcc-base-unix.conf"
- sed -i "/^QMAKE_LFLAGS\s/s|+=|+= ${LDFLAGS}|g" "mkspecs/common/gcc-base.conf"
+ cd "$srcdir/$_pkgname"
+ sed -i "s|-O2|${CXXFLAGS}|" mkspecs/common/{g++,gcc}-base.conf
+ sed -i "/^QMAKE_LFLAGS_RPATH/s| -Wl,-rpath,||g" "mkspecs/common/gcc-base-unix.conf"
+ sed -i "/^QMAKE_LFLAGS\s/s|+=|+= ${LDFLAGS}|g" "mkspecs/common/gcc-base.conf"
}
build() {
- cd "$srcdir/$_pkgname"
+ cd "$srcdir/$_pkgname"
- ./configure -confirm-license -opensource \
- -prefix /usr \
- -bindir /usr/lib/qt/bin \
- -docdir /usr/share/doc/qt \
- -headerdir /usr/include/qt \
- -archdatadir /usr/lib/qt \
- -datadir /usr/share/qt \
- -sysconfdir /etc/xdg \
- -examplesdir /usr/share/doc/qt/examples \
- -system-sqlite \
- -openssl-linked \
- -nomake examples \
- -nomake tests \
- -no-rpath \
- -optimized-qmake \
- -dbus-linked \
- -reduce-relocations \
+ ./configure -confirm-license -opensource \
+ -prefix /usr \
+ -bindir /usr/lib/qt/bin \
+ -docdir /usr/share/doc/qt \
+ -headerdir /usr/include/qt \
+ -archdatadir /usr/lib/qt \
+ -datadir /usr/share/qt \
+ -sysconfdir /etc/xdg \
+ -examplesdir /usr/share/doc/qt/examples \
+ -system-sqlite \
+ -openssl-linked \
+ -nomake examples \
+ -nomake tests \
+ -no-rpath \
+ -optimized-qmake \
+ -dbus-linked \
+ -reduce-relocations \
-egl \
-eglfs \
- -libinput
- make
+ -libinput
+ make
}
package() {
- cd "$srcdir/$_pkgname"
- make INSTALL_ROOT="$pkgdir" install
- for file in "${pkgdir}"/usr/lib/qt/bin/*; do
- mkdir -p "${pkgdir}"/usr/bin
- ln -s /usr/lib/qt/bin/$(basename $file) "${pkgdir}"/usr/bin/$(basename $file)
- done
+ cd "$srcdir/$_pkgname"
+ make INSTALL_ROOT="$pkgdir" install
}