summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Rojas2020-02-29 11:14:23 +0000
committerAntonio Rojas2020-02-29 11:14:23 +0000
commit67676a31345ddc15526bec9ef45284dff7d72368 (patch)
tree8ca5896766b0317b93af1e339338d992ed5a4ec2
parent389cc726bcd2126fd4c5fe907ac1ad2f14df8f47 (diff)
downloadaur-67676a31345ddc15526bec9ef45284dff7d72368.tar.gz
Sync with stable package
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD23
2 files changed, 25 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2c568c60506c..8c44a6882dc1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -9,9 +9,8 @@ pkgbase = qt5-base-git
license = LGPL3
license = FDL
license = custom
- makedepends = mtdev
makedepends = libfbclient
- makedepends = libmariadbclient
+ makedepends = mariadb-libs
makedepends = sqlite
makedepends = unixodbc
makedepends = postgresql-libs
@@ -21,31 +20,38 @@ pkgbase = qt5-base-git
makedepends = libpulse
makedepends = cups
makedepends = freetds
- makedepends = git
makedepends = vulkan-headers
+ makedepends = git
depends = libjpeg-turbo
depends = xcb-util-keysyms
+ depends = xcb-util-renderutil
depends = libgl
depends = fontconfig
+ depends = xdg-utils
+ depends = shared-mime-info
depends = xcb-util-wm
depends = libxrender
depends = libxi
depends = sqlite
depends = xcb-util-image
- depends = icu
+ depends = mesa
depends = tslib
depends = libinput
- depends = libsm
depends = libxkbcommon-x11
depends = libproxy
+ depends = libcups
+ depends = double-conversion
+ depends = md4c
optdepends = qt5-svg: to use SVG icon themes
+ optdepends = qt5-wayland: to run Qt applications in a Wayland session
+ optdepends = qt5-translations: for some native UI translations
optdepends = postgresql-libs: PostgreSQL driver
- optdepends = libmariadbclient: MariaDB driver
+ optdepends = mariadb-libs: MariaDB driver
optdepends = unixodbc: ODBC driver
optdepends = libfbclient: Firebird/iBase driver
optdepends = freetds: MS SQL driver
- optdepends = mtdev: evdev plugin
optdepends = gtk3: GTK platform plugin
+ optdepends = perl: for fixqt4headers and syncqt
provides = qt5-base
conflicts = qt5-base
conflicts = qtchooser
diff --git a/PKGBUILD b/PKGBUILD
index 6159edfe29bb..a478a5ddd31e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,19 +12,21 @@ arch=("i686" "x86_64")
url='https://qt-project.org/'
license=('GPL3' 'LGPL3' 'FDL' 'custom')
pkgdesc="A cross-platform application and UI framework"
-depends=('libjpeg-turbo' 'xcb-util-keysyms' 'libgl' 'fontconfig'
- 'xcb-util-wm' 'libxrender' 'libxi' 'sqlite' 'xcb-util-image' 'icu'
- 'tslib' 'libinput' 'libsm' 'libxkbcommon-x11' 'libproxy')
-makedepends=('mtdev' 'libfbclient' 'libmariadbclient' 'sqlite' 'unixodbc' 'postgresql-libs' 'alsa-lib' 'gst-plugins-base-libs'
- 'gtk3' 'libpulse' 'cups' 'freetds' 'git' 'vulkan-headers')
+depends=('libjpeg-turbo' 'xcb-util-keysyms' 'xcb-util-renderutil' 'libgl' 'fontconfig' 'xdg-utils'
+ 'shared-mime-info' 'xcb-util-wm' 'libxrender' 'libxi' 'sqlite' 'xcb-util-image' 'mesa'
+ 'tslib' 'libinput' 'libxkbcommon-x11' 'libproxy' 'libcups' 'double-conversion' 'md4c')
+makedepends=('libfbclient' 'mariadb-libs' 'sqlite' 'unixodbc' 'postgresql-libs' 'alsa-lib' 'gst-plugins-base-libs'
+ 'gtk3' 'libpulse' 'cups' 'freetds' 'vulkan-headers' 'git')
optdepends=('qt5-svg: to use SVG icon themes'
+ 'qt5-wayland: to run Qt applications in a Wayland session'
+ 'qt5-translations: for some native UI translations'
'postgresql-libs: PostgreSQL driver'
- 'libmariadbclient: MariaDB driver'
+ 'mariadb-libs: MariaDB driver'
'unixodbc: ODBC driver'
'libfbclient: Firebird/iBase driver'
'freetds: MS SQL driver'
- 'mtdev: evdev plugin'
- 'gtk3: GTK platform plugin')
+ 'gtk3: GTK platform plugin'
+ 'perl: for fixqt4headers and syncqt')
provides=("$_pkgname")
conflicts=("$_pkgname" "qtchooser")
source=("$_pkgname::git://code.qt.io/qt/qtbase.git#branch=5.15")
@@ -56,7 +58,7 @@ prepare() {
build() {
cd "$srcdir/$_pkgname"
- PYTHON=/usr/bin/python2 ./configure -I/usr/include/mysql -confirm-license -opensource -v \
+ ./configure -confirm-license -opensource -v \
-prefix /usr \
-docdir /usr/share/doc/qt \
-headerdir /usr/include/qt \
@@ -74,8 +76,7 @@ build() {
-system-harfbuzz \
-journald \
-no-use-gold-linker \
- -reduce-relocations
-
+ -reduce-relocations # -no-mimetype-database
make
}