summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStephan Springer2022-03-08 18:48:27 +0100
committerStephan Springer2022-03-08 18:48:27 +0100
commit101c97ff9b224a773390ad209f00f4dbc59a2b16 (patch)
tree4e43fbeff1df471dd225a66735ce5a634930edb0
parentbdb83d4dcd788cec62aef533a8e9c7716837a8d9 (diff)
downloadaur-101c97ff9b224a773390ad209f00f4dbc59a2b16.tar.gz
update to version 5.15.3+kde+r133
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
2 files changed, 6 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 471cba882757..a033b8c3c43d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = qt5-base-headless
pkgdesc = A cross-platform application and UI framework - headless build, no QtGui or QtWidgets
- pkgver = 5.15.2+kde+r305
+ pkgver = 5.15.3+kde+r133
pkgrel = 1
url = https://www.qt.io
arch = x86_64
@@ -29,7 +29,7 @@ pkgbase = qt5-base-headless
conflicts = qtchooser
conflicts = qt5-base
options = debug
- source = git+https://invent.kde.org/qt/qt/qtbase#commit=77c620f0a1f8a5e8e126fd00a7beba6ac8005ad0
+ source = git+https://invent.kde.org/qt/qt/qtbase#commit=e68ca8e51375d963b2391715f70b42707992dbd8
source = qmake-cflags.patch
source = qmake-config.patch
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index cad2bdcd48b4..ae1da848b63d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,9 +4,10 @@
# Contributor: Andrea Scarpino <andrea@archlinux.org>
pkgname=qt5-base-headless
-pkgver=5.15.2+kde+r305
+_basever=5.15.3
+pkgver=5.15.3+kde+r133
pkgrel=1
-_commit=77c620f0a1f8a5e8e126fd00a7beba6ac8005ad0
+_commit=e68ca8e51375d963b2391715f70b42707992dbd8
arch=('x86_64')
url='https://www.qt.io'
license=('GPL3' 'LGPL3' 'FDL' 'custom')
@@ -32,14 +33,11 @@ options=(debug)
pkgver() {
cd $_pkgfqn
- echo "5.15.2+kde+r"`git rev-list --count origin/5.15.2..$_commit`
+ echo "$_basever+kde+r"`git rev-list --count v$_basever-lts-lgpl..$_commit`
}
prepare() {
cd ${_pkgfqn}
-
- git revert -n 6344955d17e17e2398720fe60c34cfc2a4a95208 # Revert version bump
-
patch -p1 < ../qmake-cflags.patch # Use system CFLAGS in qmake
patch -p1 < ../qmake-config.patch # Don't strip binaries with qmake and use -ltcg, cf. QTBUG-73834
}