summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorK9002020-01-27 13:47:28 +0300
committerK9002020-01-27 13:47:28 +0300
commit2f64c7a40109367dfd52ad466ea04169737020ac (patch)
treea530f201bf9272f7ba4b006e43feaa1d6815a6b1
parentbe9c4c11c85d0f8e0985f77e4b61c5aa263be297 (diff)
downloadaur-2f64c7a40109367dfd52ad466ea04169737020ac.tar.gz
5.14.1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD12
2 files changed, 8 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 49a6d161776f..d44786034b2f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = qt5-base-headless
pkgdesc = A cross-platform application and UI framework - headless build (no QtGui or QtWidgets)
- pkgver = 5.14.0
- pkgrel = 2
+ pkgver = 5.14.1
+ pkgrel = 1
url = https://www.qt.io/
arch = x86_64
license = GPL3
@@ -29,10 +29,8 @@ pkgbase = qt5-base-headless
provides = qt5-base
conflicts = qtchooser
conflicts = qt5-base
- source = https://download.qt.io/official_releases/qt/5.14/5.14.0/submodules/qtbase-everywhere-src-5.14.0.tar.xz
- source = qtbug-81272.patch::https://code.qt.io/cgit/qt/qtbase.git/patch/?id=e6f1fde2
- sha256sums = 4ef921c0f208a1624439801da8b3f4344a3793b660ce1095f2b7f5c4246b9463
- sha256sums = e93ca83adbf0becc0c78b7db8fed32eed123a62907fe0274e4d352aa169daad1
+ source = https://download.qt.io/official_releases/qt/5.14/5.14.1/submodules/qtbase-everywhere-src-5.14.1.tar.xz
+ sha256sums = d9d423a6e7bcf1055c0372fc029f14a6fe67dd62c67b83095cde68b60b762cf7
pkgname = qt5-base-headless
diff --git a/PKGBUILD b/PKGBUILD
index f3185a7dd0c0..38e27f1ef38f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,9 +3,9 @@
# Headless by: K900 <me@0upti.me>
pkgname=qt5-base-headless
-_qtver=5.14.0
+_qtver=5.14.1
pkgver=${_qtver/-/}
-pkgrel=2
+pkgrel=1
arch=('x86_64')
url='https://www.qt.io/'
license=('GPL3' 'LGPL3' 'FDL' 'custom')
@@ -21,10 +21,8 @@ optdepends=('postgresql-libs: PostgreSQL driver'
conflicts=('qtchooser' 'qt5-base')
provides=('qt5-base')
_pkgfqn="qtbase-everywhere-src-${_qtver}"
-source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz"
- qtbug-81272.patch::"https://code.qt.io/cgit/qt/qtbase.git/patch/?id=e6f1fde2")
-sha256sums=('4ef921c0f208a1624439801da8b3f4344a3793b660ce1095f2b7f5c4246b9463'
- 'e93ca83adbf0becc0c78b7db8fed32eed123a62907fe0274e4d352aa169daad1')
+source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz")
+sha256sums=('d9d423a6e7bcf1055c0372fc029f14a6fe67dd62c67b83095cde68b60b762cf7')
prepare() {
cd ${_pkgfqn}
@@ -35,8 +33,6 @@ prepare() {
mkspecs/common/gcc-base.conf
sed -i -e "s|^\(QMAKE_LFLAGS_RELEASE.*\)|\1 ${LDFLAGS}|" \
mkspecs/common/g++-unix.conf
-
- patch -p1 -i ../qtbug-81272.patch # https://bugreports.qt.io/browse/QTBUG-81272
}
build() {