summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorK9002018-12-20 13:17:56 +0300
committerK9002018-12-20 13:17:56 +0300
commit4c0de92b40560117c225010eac77ce26f9c1975c (patch)
tree94a840b6bcefb18540699e37915957c71ab7b14d
parentc87d2de028854931b5099fc6dd7d0c43f8ac22f0 (diff)
downloadaur-4c0de92b40560117c225010eac77ce26f9c1975c.tar.gz
5.12.0
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD24
3 files changed, 23 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 61d13e459d2c..62c7efa06580 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = qt5-base-headless
pkgdesc = A cross-platform application and UI framework - headless build (no QtGui or QtWidgets)
- pkgver = 5.11.2
+ pkgver = 5.12.0
pkgrel = 1
url = http://qt-project.org/
arch = x86_64
@@ -12,20 +12,24 @@ pkgbase = qt5-base-headless
makedepends = sqlite
makedepends = unixodbc
makedepends = postgresql-libs
+ makedepends = dbus
depends = sqlite
depends = libproxy
depends = double-conversion
+ depends = pcre2
+ depends = glib2
+ depends = icu
optdepends = postgresql-libs: PostgreSQL driver
optdepends = libmariadbclient: MariaDB driver
optdepends = unixodbc: ODBC driver
- optdepends = libfbclient: Firebird/iBase driver
optdepends = freetds: MS SQL driver
- optdepends = gtk3: GTK platform plugin
+ optdepends = python: build scripts for Apple platforms
+ optdepends = dbus: DBus module
provides = qt5-base
conflicts = qtchooser
conflicts = qt5-base
- source = http://download.qt.io/official_releases/qt/5.11/5.11.2/submodules/qtbase-everywhere-src-5.11.2.tar.xz
- sha256sums = 6381e7c3468d5a1dcfe3683b29eeced192faa0f8a32434fec071a59b8bcd0107
+ source = http://download.qt.io/official_releases/qt/5.12/5.12.0/submodules/qtbase-everywhere-src-5.12.0.tar.xz
+ sha256sums = 5e03221d780e121aabd734896aab8f331e5d8c9d9b54f1eb04907d0818eaeecb
pkgname = qt5-base-headless
diff --git a/.gitignore b/.gitignore
index e40ee8dab148..73526e93a120 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,3 +2,4 @@ pkg/
src/
*.tar.xz
*.pkg.tar*
+*.log
diff --git a/PKGBUILD b/PKGBUILD
index 26ae850bf5b9..dd46286214cd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,26 +3,26 @@
# Headless by: K900 <me@0upti.me>
pkgname=qt5-base-headless
-_qtver=5.11.2
+_qtver=5.12.0
pkgver=${_qtver/-/}
pkgrel=1
arch=('x86_64')
url='http://qt-project.org/'
license=('GPL3' 'LGPL3' 'FDL' 'custom')
pkgdesc='A cross-platform application and UI framework - headless build (no QtGui or QtWidgets)'
-depends=('sqlite' 'libproxy' 'double-conversion')
-makedepends=('libmariadbclient' 'sqlite' 'unixodbc' 'postgresql-libs')
+depends=('sqlite' 'libproxy' 'double-conversion' 'pcre2' 'glib2' 'icu')
+makedepends=('libmariadbclient' 'sqlite' 'unixodbc' 'postgresql-libs' 'dbus')
optdepends=('postgresql-libs: PostgreSQL driver'
'libmariadbclient: MariaDB driver'
'unixodbc: ODBC driver'
- 'libfbclient: Firebird/iBase driver'
'freetds: MS SQL driver'
- 'gtk3: GTK platform plugin')
+ 'python: build scripts for Apple platforms'
+ 'dbus: DBus module')
conflicts=('qtchooser' 'qt5-base')
provides=('qt5-base')
_pkgfqn="qtbase-everywhere-src-${_qtver}"
source=("http://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz")
-sha256sums=('6381e7c3468d5a1dcfe3683b29eeced192faa0f8a32434fec071a59b8bcd0107')
+sha256sums=('5e03221d780e121aabd734896aab8f331e5d8c9d9b54f1eb04907d0818eaeecb')
prepare() {
cd ${_pkgfqn}
@@ -45,7 +45,7 @@ build() {
-datadir /usr/share/qt \
-sysconfdir /etc/xdg \
-examplesdir /usr/share/doc/qt/examples \
- -plugin-sql-{psql,mysql,sqlite,odbc,ibase} \
+ -plugin-sql-{psql,mysql,sqlite,odbc} \
-system-sqlite \
-openssl-linked \
-nomake examples \
@@ -63,7 +63,10 @@ build() {
-no-xcb \
-no-eglfs \
-no-directfb \
- -no-cups
+ -no-cups \
+ -no-accessibility \
+ -no-freetype \
+ -no-harfbuzz
make
}
@@ -72,8 +75,7 @@ package() {
cd ${_pkgfqn}
make INSTALL_ROOT="${pkgdir}" install
- install -D -m644 LGPL_EXCEPTION.txt \
- "${pkgdir}"/usr/share/licenses/${pkgname}/LGPL_EXCEPTION.txt
+ install -Dm644 LICENSE* -t "$pkgdir"/usr/share/licenses/$pkgbase
# Drop QMAKE_PRL_BUILD_DIR because reference the build dir
find "${pkgdir}/usr/lib" -type f -name '*.prl' \
@@ -85,6 +87,6 @@ package() {
# Symlinks for backwards compatibility
for b in "${pkgdir}"/usr/bin/*; do
- ln -s /usr/bin/$(basename $b) "${pkgdir}"/usr/bin/$(basename $b)-qt5
+ ln -s $(basename $b) "${pkgdir}"/usr/bin/$(basename $b)-qt5
done
}