summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorK9002019-06-22 16:35:29 +0300
committerK9002019-06-22 16:35:29 +0300
commit9578411c0b5f8482d2038ae37009ec1d864e07d2 (patch)
treea5e45c82993caec1058c4973753e142f8c2e478d
parent1d9b1dbd4424a05e48f0a92c24c1d2f57a51cc0a (diff)
downloadaur-9578411c0b5f8482d2038ae37009ec1d864e07d2.tar.gz
5.13.0
-rw-r--r--.SRCINFO9
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD13
3 files changed, 16 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e10d5b666c35..28977b122502 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = qt5-base-headless
pkgdesc = A cross-platform application and UI framework - headless build (no QtGui or QtWidgets)
- pkgver = 5.12.4
+ pkgver = 5.13.0
pkgrel = 1
url = https://www.qt.io/
arch = x86_64
@@ -19,6 +19,7 @@ pkgbase = qt5-base-headless
depends = pcre2
depends = glib2
depends = icu
+ depends = zstd
optdepends = postgresql-libs: PostgreSQL driver
optdepends = mariadb-libs: MariaDB driver
optdepends = unixodbc: ODBC driver
@@ -28,8 +29,10 @@ pkgbase = qt5-base-headless
provides = qt5-base
conflicts = qtchooser
conflicts = qt5-base
- source = https://download.qt.io/official_releases/qt/5.12/5.12.4/submodules/qtbase-everywhere-src-5.12.4.tar.xz
- sha256sums = 20fbc7efa54ff7db9552a7a2cdf9047b80253c1933c834f35b0bc5c1ae021195
+ source = https://download.qt.io/official_releases/qt/5.13/5.13.0/submodules/qtbase-everywhere-src-5.13.0.tar.xz
+ source = qtbase-zlib-compression.patch::https://code.qt.io/cgit/qt/qtbase.git/patch/?id=cbdc9a77
+ sha256sums = ff6964b3b528cd3b1d21bcf3470006e8e5cbe69591923f982871d886ea0488fe
+ sha256sums = 9300d8ab7abe4145e92eea75178a26ad3d5a71b0646665c3776ca2c375dd1233
pkgname = qt5-base-headless
diff --git a/.gitignore b/.gitignore
index 73526e93a120..ede125c35cca 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,5 +1,6 @@
pkg/
src/
*.tar.xz
+*.patch
*.pkg.tar*
*.log
diff --git a/PKGBUILD b/PKGBUILD
index fd507be140bf..ae2ca4aa384d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,14 @@
# Headless by: K900 <me@0upti.me>
pkgname=qt5-base-headless
-_qtver=5.12.4
+_qtver=5.13.0
pkgver=${_qtver/-/}
pkgrel=1
arch=('x86_64')
url='https://www.qt.io/'
license=('GPL3' 'LGPL3' 'FDL' 'custom')
pkgdesc='A cross-platform application and UI framework - headless build (no QtGui or QtWidgets)'
-depends=('sqlite' 'libproxy' 'double-conversion' 'pcre2' 'glib2' 'icu')
+depends=('sqlite' 'libproxy' 'double-conversion' 'pcre2' 'glib2' 'icu' 'zstd')
makedepends=('mariadb-libs' 'sqlite' 'unixodbc' 'postgresql-libs' 'dbus')
optdepends=('postgresql-libs: PostgreSQL driver'
'mariadb-libs: MariaDB driver'
@@ -21,8 +21,10 @@ optdepends=('postgresql-libs: PostgreSQL driver'
conflicts=('qtchooser' 'qt5-base')
provides=('qt5-base')
_pkgfqn="qtbase-everywhere-src-${_qtver}"
-source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz")
-sha256sums=('20fbc7efa54ff7db9552a7a2cdf9047b80253c1933c834f35b0bc5c1ae021195')
+source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz"
+ qtbase-zlib-compression.patch::"https://code.qt.io/cgit/qt/qtbase.git/patch/?id=cbdc9a77")
+sha256sums=('ff6964b3b528cd3b1d21bcf3470006e8e5cbe69591923f982871d886ea0488fe'
+ '9300d8ab7abe4145e92eea75178a26ad3d5a71b0646665c3776ca2c375dd1233')
prepare() {
cd ${_pkgfqn}
@@ -33,6 +35,8 @@ prepare() {
mkspecs/common/gcc-base.conf
sed -i -e "s|^\(QMAKE_LFLAGS_RELEASE.*\)|\1 ${LDFLAGS}|" \
mkspecs/common/g++-unix.conf
+
+ patch -p1 -i ../qtbase-zlib-compression.patch # Change the default compression back to zlib for backwards compatibility
}
build() {
@@ -54,6 +58,7 @@ build() {
-dbus-linked \
-system-harfbuzz \
-journald \
+ -no-mimetype-database \
-no-use-gold-linker \
-reduce-relocations \
\