summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStephan Springer2022-02-15 18:50:26 +0100
committerStephan Springer2022-02-15 18:50:26 +0100
commitb242a2cec391e5284bf9183f3dc41fccff0a5a80 (patch)
treed0f4c3e455d3f98974a30964f0ef9d0a014d5fa9
parent67c9b9254415464c646d22ed00d9e5394cf7133a (diff)
downloadaur-b242a2cec391e5284bf9183f3dc41fccff0a5a80.tar.gz
update to version 5.15.2+kde+r298
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD14
-rw-r--r--qmake-cflags.patch (renamed from qt5-base-cflags.patch)0
-rw-r--r--qmake-config.patch (renamed from qt5-base-nostrip.patch)2
4 files changed, 13 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a0e4a8c59484..f74ca55a4484 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = qt5-base-headless
pkgdesc = A cross-platform application and UI framework - headless build, no QtGui or QtWidgets
- pkgver = 5.15.2+kde+r297
+ pkgver = 5.15.2+kde+r298
pkgrel = 1
url = https://www.qt.io
arch = x86_64
@@ -29,11 +29,11 @@ pkgbase = qt5-base-headless
conflicts = qtchooser
conflicts = qt5-base
options = debug
- source = git+https://invent.kde.org/qt/qt/qtbase#commit=d16bf02a11953dcac01dca73e6f3778f293adefe
- source = qt5-base-cflags.patch
- source = qt5-base-nostrip.patch
+ source = git+https://invent.kde.org/qt/qt/qtbase#commit=17ded49c32dfb855ba996e0fdab957130c9b2620
+ source = qmake-cflags.patch
+ source = qmake-config.patch
sha256sums = SKIP
sha256sums = 5411edbe215c24b30448fac69bd0ba7c882f545e8cf05027b2b6e2227abc5e78
- sha256sums = 4b93f6a79039e676a56f9d6990a324a64a36f143916065973ded89adc621e094
+ sha256sums = 4abc22150fa3e06b2fdcec32146abc9be4e316692aa4d5bd5aa53b4b726783fa
pkgname = qt5-base-headless
diff --git a/PKGBUILD b/PKGBUILD
index cfe315128ff7..bf8840cb6811 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,9 +4,9 @@
# Contributor: Andrea Scarpino <andrea@archlinux.org>
pkgname=qt5-base-headless
-pkgver=5.15.2+kde+r297
+pkgver=5.15.2+kde+r298
pkgrel=1
-_commit=d16bf02a11953dcac01dca73e6f3778f293adefe
+_commit=17ded49c32dfb855ba996e0fdab957130c9b2620
arch=('x86_64')
url='https://www.qt.io'
license=('GPL3' 'LGPL3' 'FDL' 'custom')
@@ -23,11 +23,11 @@ provides=('qt5-base')
groups=('qt' 'qt5')
_pkgfqn=qtbase
source=(git+https://invent.kde.org/qt/qt/$_pkgfqn#commit=$_commit
- qt5-base-cflags.patch
- qt5-base-nostrip.patch)
+ qmake-cflags.patch
+ qmake-config.patch)
sha256sums=('SKIP'
'5411edbe215c24b30448fac69bd0ba7c882f545e8cf05027b2b6e2227abc5e78'
- '4b93f6a79039e676a56f9d6990a324a64a36f143916065973ded89adc621e094')
+ '4abc22150fa3e06b2fdcec32146abc9be4e316692aa4d5bd5aa53b4b726783fa')
options=(debug)
pkgver() {
@@ -40,8 +40,8 @@ prepare() {
git revert -n 6344955d17e17e2398720fe60c34cfc2a4a95208 # Revert version bump
- patch -p1 < ../qt5-base-cflags.patch # Use system CFLAGS in qmake
- patch -p1 < ../qt5-base-nostrip.patch # Don't strip binaries with qmake
+ patch -p1 < ../qmake-cflags.patch # Use system CFLAGS in qmake
+ patch -p1 < ../qmake-config.patch # Don't strip binaries with qmake and use -ltcg, cf. QTBUG-73834
}
build() {
diff --git a/qt5-base-cflags.patch b/qmake-cflags.patch
index 3325016108f0..3325016108f0 100644
--- a/qt5-base-cflags.patch
+++ b/qmake-cflags.patch
diff --git a/qt5-base-nostrip.patch b/qmake-config.patch
index 17d24b4b6551..77d9694b37a0 100644
--- a/qt5-base-nostrip.patch
+++ b/qmake-config.patch
@@ -6,7 +6,7 @@ index 99d77156fd..fc840fe9f6 100644
# you can use the manual test in tests/manual/mkspecs.
#
-+CONFIG += nostrip
++CONFIG += nostrip ltcg
+
QMAKE_CFLAGS_OPTIMIZE = -O2
QMAKE_CFLAGS_OPTIMIZE_FULL = -O3