summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorK9002018-11-02 13:58:37 +0300
committerK9002018-11-02 14:02:43 +0300
commitc87d2de028854931b5099fc6dd7d0c43f8ac22f0 (patch)
tree5ee1e8565d3b920a7e946b96965555a9e5eae166
downloadaur-c87d2de028854931b5099fc6dd7d0c43f8ac22f0.tar.gz
first commit
-rw-r--r--.SRCINFO31
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD90
3 files changed, 125 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..61d13e459d2c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+pkgbase = qt5-base-headless
+ pkgdesc = A cross-platform application and UI framework - headless build (no QtGui or QtWidgets)
+ pkgver = 5.11.2
+ pkgrel = 1
+ url = http://qt-project.org/
+ arch = x86_64
+ license = GPL3
+ license = LGPL3
+ license = FDL
+ license = custom
+ makedepends = libmariadbclient
+ makedepends = sqlite
+ makedepends = unixodbc
+ makedepends = postgresql-libs
+ depends = sqlite
+ depends = libproxy
+ depends = double-conversion
+ optdepends = postgresql-libs: PostgreSQL driver
+ optdepends = libmariadbclient: MariaDB driver
+ optdepends = unixodbc: ODBC driver
+ optdepends = libfbclient: Firebird/iBase driver
+ optdepends = freetds: MS SQL driver
+ optdepends = gtk3: GTK platform plugin
+ provides = qt5-base
+ conflicts = qtchooser
+ conflicts = qt5-base
+ source = http://download.qt.io/official_releases/qt/5.11/5.11.2/submodules/qtbase-everywhere-src-5.11.2.tar.xz
+ sha256sums = 6381e7c3468d5a1dcfe3683b29eeced192faa0f8a32434fec071a59b8bcd0107
+
+pkgname = qt5-base-headless
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e40ee8dab148
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+src/
+*.tar.xz
+*.pkg.tar*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..26ae850bf5b9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,90 @@
+# Maintainer: Felix Yan <felixonmars@archlinux.org>
+# Contributor: Andrea Scarpino <andrea@archlinux.org>
+# Headless by: K900 <me@0upti.me>
+
+pkgname=qt5-base-headless
+_qtver=5.11.2
+pkgver=${_qtver/-/}
+pkgrel=1
+arch=('x86_64')
+url='http://qt-project.org/'
+license=('GPL3' 'LGPL3' 'FDL' 'custom')
+pkgdesc='A cross-platform application and UI framework - headless build (no QtGui or QtWidgets)'
+depends=('sqlite' 'libproxy' 'double-conversion')
+makedepends=('libmariadbclient' 'sqlite' 'unixodbc' 'postgresql-libs')
+optdepends=('postgresql-libs: PostgreSQL driver'
+ 'libmariadbclient: MariaDB driver'
+ 'unixodbc: ODBC driver'
+ 'libfbclient: Firebird/iBase driver'
+ 'freetds: MS SQL driver'
+ 'gtk3: GTK platform plugin')
+conflicts=('qtchooser' 'qt5-base')
+provides=('qt5-base')
+_pkgfqn="qtbase-everywhere-src-${_qtver}"
+source=("http://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz")
+sha256sums=('6381e7c3468d5a1dcfe3683b29eeced192faa0f8a32434fec071a59b8bcd0107')
+
+prepare() {
+ cd ${_pkgfqn}
+
+ # Build qmake using Arch {C,LD}FLAGS
+ # This also sets default {C,CXX,LD}FLAGS for projects built using qmake
+ sed -i -e "s|^\(QMAKE_CFLAGS_RELEASE.*\)|\1 ${CFLAGS}|" \
+ mkspecs/common/gcc-base.conf
+ sed -i -e "s|^\(QMAKE_LFLAGS_RELEASE.*\)|\1 ${LDFLAGS}|" \
+ mkspecs/common/g++-unix.conf
+}
+
+build() {
+ cd ${_pkgfqn}
+
+ ./configure -confirm-license -opensource -v \
+ -prefix /usr \
+ -headerdir /usr/include/qt \
+ -archdatadir /usr/lib/qt \
+ -datadir /usr/share/qt \
+ -sysconfdir /etc/xdg \
+ -examplesdir /usr/share/doc/qt/examples \
+ -plugin-sql-{psql,mysql,sqlite,odbc,ibase} \
+ -system-sqlite \
+ -openssl-linked \
+ -nomake examples \
+ -no-rpath \
+ -optimized-qmake \
+ -dbus-linked \
+ -system-harfbuzz \
+ -journald \
+ -no-use-gold-linker \
+ -reduce-relocations \
+ \
+ \
+ -no-gui \
+ -no-widgets \
+ -no-xcb \
+ -no-eglfs \
+ -no-directfb \
+ -no-cups
+
+ make
+}
+
+package() {
+ cd ${_pkgfqn}
+ make INSTALL_ROOT="${pkgdir}" install
+
+ install -D -m644 LGPL_EXCEPTION.txt \
+ "${pkgdir}"/usr/share/licenses/${pkgname}/LGPL_EXCEPTION.txt
+
+ # Drop QMAKE_PRL_BUILD_DIR because reference the build dir
+ find "${pkgdir}/usr/lib" -type f -name '*.prl' \
+ -exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
+
+ # Fix wrong qmake path in pri file
+ sed -i "s|${srcdir}/${_pkgfqn}|/usr|" \
+ "${pkgdir}"/usr/lib/qt/mkspecs/modules/qt_lib_bootstrap_private.pri
+
+ # Symlinks for backwards compatibility
+ for b in "${pkgdir}"/usr/bin/*; do
+ ln -s /usr/bin/$(basename $b) "${pkgdir}"/usr/bin/$(basename $b)-qt5
+ done
+}