summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorK9002020-01-19 12:25:21 +0300
committerK9002020-01-19 12:25:21 +0300
commitf80dcbda836a0ad68b89930ffe1f89ce12b3a1ee (patch)
treed0faf3d45f2a8823e78f1bb96e08decff7baea08
parenta7972329024c9a2c60da25544d11619184ee89f9 (diff)
downloadaur-f80dcbda836a0ad68b89930ffe1f89ce12b3a1ee.tar.gz
import security fix from extra/5.14.0-3
-rw-r--r--PKGBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a822c702dc2c..f3185a7dd0c0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=qt5-base-headless
_qtver=5.14.0
pkgver=${_qtver/-/}
-pkgrel=1
+pkgrel=2
arch=('x86_64')
url='https://www.qt.io/'
license=('GPL3' 'LGPL3' 'FDL' 'custom')
@@ -21,8 +21,10 @@ optdepends=('postgresql-libs: PostgreSQL driver'
conflicts=('qtchooser' 'qt5-base')
provides=('qt5-base')
_pkgfqn="qtbase-everywhere-src-${_qtver}"
-source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz")
-sha256sums=('4ef921c0f208a1624439801da8b3f4344a3793b660ce1095f2b7f5c4246b9463')
+source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz"
+ qtbug-81272.patch::"https://code.qt.io/cgit/qt/qtbase.git/patch/?id=e6f1fde2")
+sha256sums=('4ef921c0f208a1624439801da8b3f4344a3793b660ce1095f2b7f5c4246b9463'
+ 'e93ca83adbf0becc0c78b7db8fed32eed123a62907fe0274e4d352aa169daad1')
prepare() {
cd ${_pkgfqn}
@@ -33,6 +35,8 @@ prepare() {
mkspecs/common/gcc-base.conf
sed -i -e "s|^\(QMAKE_LFLAGS_RELEASE.*\)|\1 ${LDFLAGS}|" \
mkspecs/common/g++-unix.conf
+
+ patch -p1 -i ../qtbug-81272.patch # https://bugreports.qt.io/browse/QTBUG-81272
}
build() {