summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJames Bunton2019-01-16 13:01:19 +1100
committerJames Bunton2019-01-16 13:01:19 +1100
commit582c0323167f64b2f0dbf6d78266b6c5b5df42df (patch)
tree995a79bf139d623e85f58917fe162234dcbf5301
parentcf8067b0c4872137b0c4890df00b7eb2d4806c90 (diff)
downloadaur-582c0323167f64b2f0dbf6d78266b6c5b5df42df.tar.gz
Sync from upstream package
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
2 files changed, 10 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0f884e65e7a2..903b11295cb1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = qt5-base-nostatx
pkgdesc = A cross-platform application and UI framework
pkgver = 5.12.0
- pkgrel = 1
+ pkgrel = 2
url = http://qt-project.org/
arch = x86_64
groups = qt
@@ -50,7 +50,9 @@ pkgbase = qt5-base-nostatx
optdepends = gtk3: GTK platform plugin
conflicts = qtchooser
source = http://download.qt.io/official_releases/qt/5.12/5.12.0/submodules/qtbase-everywhere-src-5.12.0.tar.xz
+ source = qtbug-72844.patch::https://code.qt.io/cgit/qt/qtbase.git/patch/?id=52e0d9e2
sha256sums = 5e03221d780e121aabd734896aab8f331e5d8c9d9b54f1eb04907d0818eaeecb
+ sha256sums = afdea0787e1d8d4c2e7139770761aba4fe8268f50b7f5d715bdd850cc7017996
pkgname = qt5-base-nostatx
pkgdesc = A cross-platform application and UI framework
diff --git a/PKGBUILD b/PKGBUILD
index a11ae714263c..a6affb09e56d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,7 +16,7 @@ _pkgbase=qt5-base
pkgname=(qt5-base-nostatx qt5-xcb-private-headers-nostatx)
_qtver=5.12.0
pkgver=${_qtver/-/}
-pkgrel=1
+pkgrel=2
arch=('x86_64')
url='http://qt-project.org/'
license=('GPL3' 'LGPL3' 'FDL' 'custom')
@@ -36,8 +36,10 @@ optdepends=('qt5-svg: to use SVG icon themes'
conflicts=('qtchooser')
groups=('qt' 'qt5')
_pkgfqn="${_pkgbase/5-/}-everywhere-src-${_qtver}"
-source=("http://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz")
-sha256sums=('5e03221d780e121aabd734896aab8f331e5d8c9d9b54f1eb04907d0818eaeecb')
+source=("http://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz"
+ qtbug-72844.patch::"https://code.qt.io/cgit/qt/qtbase.git/patch/?id=52e0d9e2")
+sha256sums=('5e03221d780e121aabd734896aab8f331e5d8c9d9b54f1eb04907d0818eaeecb'
+ 'afdea0787e1d8d4c2e7139770761aba4fe8268f50b7f5d715bdd850cc7017996')
prepare() {
cd ${_pkgfqn}
@@ -48,6 +50,8 @@ prepare() {
mkspecs/common/gcc-base.conf
sed -i -e "s|^\(QMAKE_LFLAGS_RELEASE.*\)|\1 ${LDFLAGS}|" \
mkspecs/common/g++-unix.conf
+
+ patch -p1 -i ../qtbug-72844.patch # Fix drag and drop regression
}
build() {