summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJames Bunton2018-12-20 01:38:22 +1100
committerJames Bunton2018-12-20 02:05:59 +1100
commitcf8067b0c4872137b0c4890df00b7eb2d4806c90 (patch)
treeabdd107fe4e9b840ebeeb480a8ad0d6c6c1508fb
downloadaur-cf8067b0c4872137b0c4890df00b7eb2d4806c90.tar.gz
Initial commit
-rw-r--r--.SRCINFO67
-rw-r--r--PKGBUILD115
2 files changed, 182 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 00000000000..0f884e65e7a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,67 @@
+pkgbase = qt5-base-nostatx
+ pkgdesc = A cross-platform application and UI framework
+ pkgver = 5.12.0
+ pkgrel = 1
+ url = http://qt-project.org/
+ arch = x86_64
+ groups = qt
+ groups = qt5
+ license = GPL3
+ license = LGPL3
+ license = FDL
+ license = custom
+ makedepends = libfbclient
+ makedepends = libmariadbclient
+ makedepends = sqlite
+ makedepends = unixodbc
+ makedepends = postgresql-libs
+ makedepends = alsa-lib
+ makedepends = gst-plugins-base-libs
+ makedepends = gtk3
+ makedepends = libpulse
+ makedepends = cups
+ makedepends = freetds
+ makedepends = vulkan-headers
+ depends = libjpeg-turbo
+ depends = xcb-util-keysyms
+ depends = xcb-util-renderutil
+ depends = libgl
+ depends = fontconfig
+ depends = xdg-utils
+ depends = shared-mime-info
+ depends = xcb-util-wm
+ depends = libxrender
+ depends = libxi
+ depends = sqlite
+ depends = xcb-util-image
+ depends = mesa
+ depends = tslib
+ depends = libinput
+ depends = libxkbcommon-x11
+ depends = libproxy
+ depends = libcups
+ depends = double-conversion
+ optdepends = qt5-svg: to use SVG icon themes
+ optdepends = postgresql-libs: PostgreSQL driver
+ optdepends = libmariadbclient: MariaDB driver
+ optdepends = unixodbc: ODBC driver
+ optdepends = libfbclient: Firebird/iBase driver
+ optdepends = freetds: MS SQL driver
+ optdepends = gtk3: GTK platform plugin
+ conflicts = qtchooser
+ source = http://download.qt.io/official_releases/qt/5.12/5.12.0/submodules/qtbase-everywhere-src-5.12.0.tar.xz
+ sha256sums = 5e03221d780e121aabd734896aab8f331e5d8c9d9b54f1eb04907d0818eaeecb
+
+pkgname = qt5-base-nostatx
+ pkgdesc = A cross-platform application and UI framework
+ provides = qt5-base
+ conflicts = qt5-base
+
+pkgname = qt5-xcb-private-headers-nostatx
+ pkgdesc = Private headers for Qt5 Xcb
+ groups =
+ depends = qt5-base-nostatx=5.12.0
+ optdepends =
+ provides = qt5-xcb-private-headers
+ conflicts = qt5-xcb-private-headers
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 00000000000..a11ae714263
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,115 @@
+# Maintainer: James Bunton <jamesbunton@delx.net.au>
+# Contributor: Felix Yan <felixonmars@archlinux.org>
+# Contributor: Andrea Scarpino <andrea@archlinux.org>
+
+# This is intended to track qt5-base, but without the dependency on Linux 4.11's statx.
+#
+# In Qt 5.12.0 the statx syscall changed to a hard dependency if it is detected
+# at compile time. Previously if the running kernel returned ENOSYS Qt would
+# use a runtime fall back.
+#
+# See https://bugreports.qt.io/browse/QTBUG-72484
+# and https://bugs.archlinux.org/task/61130
+
+pkgbase=qt5-base-nostatx
+_pkgbase=qt5-base
+pkgname=(qt5-base-nostatx qt5-xcb-private-headers-nostatx)
+_qtver=5.12.0
+pkgver=${_qtver/-/}
+pkgrel=1
+arch=('x86_64')
+url='http://qt-project.org/'
+license=('GPL3' 'LGPL3' 'FDL' 'custom')
+pkgdesc='A cross-platform application and UI framework'
+depends=('libjpeg-turbo' 'xcb-util-keysyms' 'xcb-util-renderutil' 'libgl' 'fontconfig' 'xdg-utils'
+ 'shared-mime-info' 'xcb-util-wm' 'libxrender' 'libxi' 'sqlite' 'xcb-util-image' 'mesa'
+ 'tslib' 'libinput' 'libxkbcommon-x11' 'libproxy' 'libcups' 'double-conversion')
+makedepends=('libfbclient' 'libmariadbclient' 'sqlite' 'unixodbc' 'postgresql-libs' 'alsa-lib' 'gst-plugins-base-libs'
+ 'gtk3' 'libpulse' 'cups' 'freetds' 'vulkan-headers')
+optdepends=('qt5-svg: to use SVG icon themes'
+ 'postgresql-libs: PostgreSQL driver'
+ 'libmariadbclient: MariaDB driver'
+ 'unixodbc: ODBC driver'
+ 'libfbclient: Firebird/iBase driver'
+ 'freetds: MS SQL driver'
+ 'gtk3: GTK platform plugin')
+conflicts=('qtchooser')
+groups=('qt' 'qt5')
+_pkgfqn="${_pkgbase/5-/}-everywhere-src-${_qtver}"
+source=("http://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz")
+sha256sums=('5e03221d780e121aabd734896aab8f331e5d8c9d9b54f1eb04907d0818eaeecb')
+
+prepare() {
+ cd ${_pkgfqn}
+
+ # Build qmake using Arch {C,LD}FLAGS
+ # This also sets default {C,CXX,LD}FLAGS for projects built using qmake
+ sed -i -e "s|^\(QMAKE_CFLAGS_RELEASE.*\)|\1 ${CFLAGS}|" \
+ mkspecs/common/gcc-base.conf
+ sed -i -e "s|^\(QMAKE_LFLAGS_RELEASE.*\)|\1 ${LDFLAGS}|" \
+ mkspecs/common/g++-unix.conf
+}
+
+build() {
+ cd ${_pkgfqn}
+
+ ./configure -confirm-license -opensource -v \
+ -prefix /usr \
+ -docdir /usr/share/doc/qt \
+ -headerdir /usr/include/qt \
+ -archdatadir /usr/lib/qt \
+ -datadir /usr/share/qt \
+ -sysconfdir /etc/xdg \
+ -examplesdir /usr/share/doc/qt/examples \
+ -plugin-sql-{psql,mysql,sqlite,odbc,ibase} \
+ -system-sqlite \
+ -openssl-linked \
+ -nomake examples \
+ -no-rpath \
+ -optimized-qmake \
+ -dbus-linked \
+ -system-harfbuzz \
+ -journald \
+ -no-use-gold-linker \
+ -reduce-relocations \
+ -no-feature-statx
+ make
+}
+
+package_qt5-base-nostatx() {
+ pkgdesc='A cross-platform application and UI framework'
+ provides=(qt5-base)
+ conflicts=(qt5-base)
+
+ cd ${_pkgfqn}
+ make INSTALL_ROOT="${pkgdir}" install
+
+ install -Dm644 LICENSE* -t "$pkgdir"/usr/share/licenses/$_pkgbase
+
+ # Drop QMAKE_PRL_BUILD_DIR because reference the build dir
+ find "${pkgdir}/usr/lib" -type f -name '*.prl' \
+ -exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
+
+ # Fix wrong qmake path in pri file
+ sed -i "s|${srcdir}/${_pkgfqn}|/usr|" \
+ "${pkgdir}"/usr/lib/qt/mkspecs/modules/qt_lib_bootstrap_private.pri
+
+ # Symlinks for backwards compatibility
+ for b in "${pkgdir}"/usr/bin/*; do
+ ln -s $(basename $b) "${pkgdir}"/usr/bin/$(basename $b)-qt5
+ done
+}
+
+package_qt5-xcb-private-headers-nostatx() {
+ pkgdesc='Private headers for Qt5 Xcb'
+
+ depends=("qt5-base-nostatx=$pkgver")
+ optdepends=()
+ groups=()
+ provides=(qt5-xcb-private-headers)
+ conflicts=(qt5-xcb-private-headers)
+
+ cd ${_pkgfqn}
+ install -d -m755 "$pkgdir"/usr/include/qtxcb-private
+ cp -r src/plugins/platforms/xcb/*.h "$pkgdir"/usr/include/qtxcb-private/
+}