summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortaotieren2021-04-03 17:50:23 +0800
committertaotieren2021-04-03 17:50:23 +0800
commit3b94a382ef6adcc623ba5d72c5629f495cebc871 (patch)
tree77ff6425da72382500e68e18dc76964ae3a7bc2e
downloadaur-3b94a382ef6adcc623ba5d72c5629f495cebc871.tar.gz
update qt5-base-util
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore11
-rw-r--r--PKGBUILD24
3 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f88a3aa4c5c5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = qt5-base-util
+ pkgdesc = A cross-platform application and UI framework
+ pkgver = 5.15.2
+ pkgrel = 1
+ url = https://www.qt.io
+ arch = x86_64
+ groups = qt
+ groups = qt5
+ license = GPL3
+ license = LGPL3
+ license = FDL
+ license = custom
+ depends = qt5-base
+ source = https://download.qt.io/official_releases/qt/5.15/5.15.2/submodules/qtbase-everywhere-src-5.15.2.tar.xz
+ sha256sums = 909fad2591ee367993a75d7e2ea50ad4db332f05e1c38dd7a5a274e156a4e0f8
+
+pkgname = qt5-base-util
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..0e9b545dadba
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,11 @@
+src
+pkg
+*.deb
+*.rpm
+*.zip
+*.gz
+*.pkg.tar.xz
+*.xz
+*.pkg.tar.zst
+*.log
+*.png
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..38710a3659fa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: taotieren <admin@taotieren.com>
+
+pkgname=qt5-base-util
+_pkgname=qt5-base
+_qtver=5.15.2
+pkgver=${_qtver/-/}
+pkgrel=1
+arch=(x86_64)
+url='https://www.qt.io'
+license=('GPL3' 'LGPL3' 'FDL' 'custom')
+pkgdesc='A cross-platform application and UI framework'
+depends=('qt5-base')
+makedepends=()
+optdepends=()
+groups=('qt' 'qt5')
+_pkgfn="${_pkgname/5-/}-everywhere-src-${_qtver}"
+source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/$_qtver/submodules/$_pkgfn.tar.xz")
+sha256sums=('909fad2591ee367993a75d7e2ea50ad4db332f05e1c38dd7a5a274e156a4e0f8')
+
+package()
+{
+ install -dm755 "${pkgdir}/opt/qt/qt5/${_pkgname}/"
+ cp -r "${srcdir}/${_pkgfn}/util" "${pkgdir}/opt/qt/qt5/${_pkgname}/"
+}