summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAchmad Fathoni2021-12-17 14:20:13 +0700
committerAchmad Fathoni2021-12-17 14:20:13 +0700
commitf7e1b116c259a769b8284f771e51a920f9f8a14e (patch)
tree40b5c7ca75a927469cb31c4db427426da1625af3
downloadaur-f7e1b116c259a769b8284f771e51a920f9f8a14e.tar.gz
init
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD41
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..934862589ab9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = qt5-charts-ubuntu-ver
+ pkgdesc = qt5-charts with same version as current Ubuntu(focal)
+ pkgver = 5.12.8
+ pkgrel = 1
+ url = https://www.qt.io
+ arch = x86_64
+ groups = qt
+ groups = qt5
+ license = GPL3
+ makedepends = qt5-declarative
+ depends = qt5-base
+ optdepends = qt5-declarative: QML bindings
+ provides = qt5-charts
+ conflicts = qt5-charts
+ source = https://download.qt.io/official_releases/qt/5.12/5.12.8/submodules/qtcharts-everywhere-src-5.12.8.tar.xz
+ sha256sums = ded463b3f99bf5cc5fe39ed2d70183948c6e955430ce0b21eb235b5c13bc9d16
+
+pkgname = qt5-charts-ubuntu-ver
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3524dba4da3a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Achmad Fathoni <fathoni DOT id AT gmail DOT com>
+
+pkgname=qt5-charts-ubuntu-ver
+_pkgname=qt5-charts
+_qtver=5.12.8
+pkgver=${_qtver/-/}
+pkgrel=1
+arch=('x86_64')
+url='https://www.qt.io'
+license=('GPL3')
+pkgdesc='qt5-charts with same version as current Ubuntu(focal)'
+depends=('qt5-base')
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+makedepends=('qt5-declarative')
+optdepends=('qt5-declarative: QML bindings')
+groups=('qt' 'qt5')
+_pkgfqn="${_pkgname/5-/}-everywhere-src-${_qtver}"
+source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz")
+sha256sums=('ded463b3f99bf5cc5fe39ed2d70183948c6e955430ce0b21eb235b5c13bc9d16')
+
+prepare() {
+ mkdir -p build
+}
+
+build() {
+ cd build
+
+ qmake ../${_pkgfqn}
+ make
+}
+
+package() {
+ cd build
+ make INSTALL_ROOT="$pkgdir" install
+
+ # Drop QMAKE_PRL_BUILD_DIR because reference the build dir
+ find "$pkgdir/usr/lib" -type f -name '*.prl' \
+ -exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
+}
+