summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTheCynicalTeam2020-08-09 22:43:29 +0100
committerTheCynicalTeam2020-08-09 22:43:29 +0100
commit07597f6e0532ab61216b7e29ecebd66566e61203 (patch)
tree947bfd81ea22412eb64915285003f9404a30592d
parent441c14030efc2411a129fb7fc75561ac5488e16d (diff)
downloadaur-07597f6e0532ab61216b7e29ecebd66566e61203.tar.gz
Update Build
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD23
2 files changed, 13 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b4b0dcadd807..f6810247b413 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = qt5-color-widgets
pkgdesc = A user-friendly color dialog and several color-related widgets for Qt
- pkgver = 0.r305.634f90e
+ pkgver = 2020.8.9
pkgrel = 1
- url = https://gitlab.com/mattia.basaglia/Qt-Color-Widgets
+ url = https://github.com/TheCynicalTeam/Qt-Color-Widgets
arch = i686
arch = x86_64
license = LGPL3
@@ -14,8 +14,8 @@ pkgbase = qt5-color-widgets
provides = qt-color-widgets-common
conflicts = qt-color-widgets-common
replaces = qt5-color-picker
- source = git+https://gitlab.com/mattia.basaglia/Qt-Color-Widgets.git
- sha256sums = SKIP
+ source = https://github.com/TheCynicalTeam/qt5-color-widgets/archive/2020.8.9-1.tar.gz
+ sha256sums = 5325e843189cace2c5fa5cde6e193841a54c625daf817ffec22fe5d8e7a1be06
pkgname = qt5-color-widgets
diff --git a/PKGBUILD b/PKGBUILD
index 5a440e8ce0de..8c272a66fc32 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,12 +2,11 @@
# Contributor: Mattia Basaglia <mattia.basaglia@gmail.com>
pkgname=qt5-color-widgets
-_pkgname=Qt-Color-Widgets
-pkgver=0.r305.634f90e
+pkgver=2020.8.9
pkgrel=1
pkgdesc='A user-friendly color dialog and several color-related widgets for Qt'
arch=('i686' 'x86_64')
-url='https://gitlab.com/mattia.basaglia/Qt-Color-Widgets'
+url='https://github.com/TheCynicalTeam/Qt-Color-Widgets'
license=('LGPL3')
depends=('qt5-base')
optdepends=('qt5-tools: for QtDesigner integration'
@@ -16,16 +15,12 @@ makedepends=('git' 'cmake')
provides=('qt-color-widgets-common')
conflicts=('qt-color-widgets-common')
replaces=('qt5-color-picker')
-source=("git+https://gitlab.com/mattia.basaglia/Qt-Color-Widgets.git")
-sha256sums=('SKIP')
+source=("https://github.com/TheCynicalTeam/$pkgname/archive/$pkgver-$pkgrel.tar.gz")
+sha256sums=('5325e843189cace2c5fa5cde6e193841a54c625daf817ffec22fe5d8e7a1be06')
-pkgver() {
- cd $_pkgname
- printf '0.r%s.%s' "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
-}
build() {
- cd $_pkgname
+ cd "$srcdir/$pkgname-$pkgver-$pkgrel"
mkdir build
cd build
cmake ..
@@ -33,10 +28,10 @@ build() {
}
package() {
- cd $_pkgname
- install -d "${pkgdir}/usr/include/${_pkgname}"
+ cd "$srcdir/$pkgname-$pkgver-$pkgrel"
+ install -d "${pkgdir}/usr/include/${pkgname}"
mkdir -p "$pkgdir/usr/lib/qt/plugins/designer"
install -Dvm644 "build/color_widgets_designer_plugin/libQtColorWidgetsPlugin-Qt52.so" "${pkgdir}/usr/lib/qt/plugins/designer/"
- find 'src' -type f -iname '*.hpp' -exec install -Dvm644 {} "${pkgdir}/usr/include/${_pkgname}/" \;
- find 'include' -maxdepth 1 -type f -exec install -Dvm644 {} "${pkgdir}/usr/include/${_pkgname}/" \;
+ find 'src' -type f -iname '*.hpp' -exec install -Dvm644 {} "${pkgdir}/usr/include/${pkgname}/" \;
+ find 'include' -maxdepth 1 -type f -exec install -Dvm644 {} "${pkgdir}/usr/include/${pkgname}/" \;
}