summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorManuel Hüsers2017-12-11 15:40:57 +0100
committerManuel Hüsers2017-12-11 15:43:02 +0100
commit317d526d7b895d36d1b1ee20b75670134350d0c6 (patch)
tree755173a791af41a76f12a92aa6d0393fd5753779
parentb799bdf10a10aa15af8955a296514c1bac7f2824 (diff)
downloadaur-317d526d7b895d36d1b1ee20b75670134350d0c6.tar.gz
Update to revision 236.94e478e-2
* New package release number due to PKGBUILD changes to make it work with latest version (thanks goes to AbysmalBiscuit at this point) * Use of CMake for compilation
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD21
2 files changed, 22 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5cb06e6a6bbb..bffe3cf6e7b1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,17 @@
# Generated by mksrcinfo v8
-# Sun Aug 13 00:30:07 UTC 2017
+# Mon Dec 11 14:40:57 UTC 2017
pkgbase = qt5-color-widgets
pkgdesc = A user-friendly color dialog and several color-related widgets for Qt
- pkgver = 0.r222.d426a33
- pkgrel = 1
+ pkgver = 0.r236.94e478e
+ pkgrel = 2
url = https://github.com/mbasaglia/Qt-Color-Widgets
arch = i686
arch = x86_64
license = LGPL3
- makedepends = git
+ makedepends = git cmake
depends = qt5-base
+ optdepends = qt5-tools: for QtDesigner integration
+ optdepends = qtcreator: for QtCreator integration
provides = qt-color-widgets-common
conflicts = qt-color-widgets-common
replaces = qt5-color-picker
diff --git a/PKGBUILD b/PKGBUILD
index 0421a70951e1..96b505e4c984 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,16 @@
pkgname=qt5-color-widgets
_pkgname=QtColorWidgets
-pkgver=0.r222.d426a33
-pkgrel=1
+pkgver=0.r236.94e478e
+pkgrel=2
pkgdesc='A user-friendly color dialog and several color-related widgets for Qt'
arch=('i686' 'x86_64')
url='https://github.com/mbasaglia/Qt-Color-Widgets'
license=('LGPL3')
depends=('qt5-base')
-makedepends=('git')
+optdepends=('qt5-tools: for QtDesigner integration'
+ 'qtcreator: for QtCreator integration')
+makedepends=('git cmake')
provides=('qt-color-widgets-common')
conflicts=('qt-color-widgets-common')
replaces=('qt5-color-picker')
@@ -25,13 +27,22 @@ pkgver() {
build() {
cd $pkgname
eval "qmake-${pkgname::3} PREFIX=${pkgdir}/usr"
- make
+
+ # Ensure build is an empty directory
+ rm -rf 'build'
+ mkdir -p 'build'
+ cd 'build'
+
+ cmake ..
+ make ColorWidgetsPlugin
}
package() {
cd $pkgname
make DESTDIR="$pkgdir" install_target
+ install -d "${pkgdir}/usr/lib/qt/plugins/designer"
+ install -Dvm644 'build/color_widgets_designer_plugin/libColorWidgetsPlugin.so' "${pkgdir}/usr/lib/qt/plugins/designer/"
install -d "${pkgdir}/usr/include/${_pkgname}"
find 'src' -type f -iname '*.hpp' -exec install -Dvm644 {} "${pkgdir}/usr/include/${_pkgname}/" \;
find 'include' -maxdepth 1 -type f -exec install -Dvm644 {} "${pkgdir}/usr/include/${_pkgname}/" \;
-}
+} \ No newline at end of file