summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorManuel Hüsers2016-12-26 21:22:38 +0100
committerManuel Hüsers2016-12-26 21:22:38 +0100
commit74dae4bd6d720febc82b0f5d97cbd88f95624df0 (patch)
treead1ee263ae8f7c7c9fff7eed03912fcb1c7776c9
parent4bf56dd4007c491c273a105e90eccc2276d8bbd8 (diff)
downloadaur-74dae4bd6d720febc82b0f5d97cbd88f95624df0.tar.gz
Merge of qt-color-widgets-common
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD8
2 files changed, 10 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7e118c23c04e..e5e6410d0036 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Sat Dec 24 16:53:46 UTC 2016
+# Mon Dec 26 20:22:38 UTC 2016
pkgbase = qt5-color-widgets
pkgdesc = A user-friendly color dialog and several color-related widgets for Qt
pkgver = 0.r194.5b24c61
@@ -10,7 +10,8 @@ pkgbase = qt5-color-widgets
license = LGPL3
makedepends = git
depends = qt5-base
- depends = qt-color-widgets-common
+ provides = qt-color-widgets-common
+ conflicts = qt-color-widgets-common
replaces = qt5-color-picker
source = qt5-color-widgets::git+git://github.com/mbasaglia/Qt-Color-Widgets.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 1fbab90486bd..ee98e8892bed 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,17 @@
# Contributor: Mattia Basaglia <mattia.basaglia@gmail.com>
pkgname=qt5-color-widgets
+_pkgname=QtColorWidgets
pkgver=0.r194.5b24c61
pkgrel=1
pkgdesc='A user-friendly color dialog and several color-related widgets for Qt'
arch=('i686' 'x86_64')
url='https://github.com/mbasaglia/Qt-Color-Widgets'
license=('LGPL3')
-depends=('qt5-base' 'qt-color-widgets-common')
+depends=('qt5-base')
makedepends=('git')
+provides=('qt-color-widgets-common')
+conflicts=('qt-color-widgets-common')
replaces=('qt5-color-picker')
source=("${pkgname}::git+git://github.com/mbasaglia/Qt-Color-Widgets.git")
sha256sums=('SKIP')
@@ -28,4 +31,7 @@ build() {
package() {
cd $pkgname
make DESTDIR="$pkgdir" install_target
+ install -d "${pkgdir}/usr/include/${_pkgname}"
+ find 'src' -type f -iname '*.hpp' -exec install -Dvm644 {} "${pkgdir}/usr/include/${_pkgname}/" \;
+ find 'include' -maxdepth 1 -type f -exec install -Dvm644 {} "${pkgdir}/usr/include/${_pkgname}/" \;
}