summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSkycoder422017-04-15 15:15:03 +0200
committerSkycoder422017-04-15 15:15:03 +0200
commit3671a777bba2c8169a433407dc5ffb138d9feb8c (patch)
tree540f9c2f009348377cfeb35ad1b23293f5c49dd2
parentc562bc273b9bc64a5026eddddefd80d6bcc381ab (diff)
downloadaur-3671a777bba2c8169a433407dc5ffb138d9feb8c.tar.gz
fixed missing build deps for qpm
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD8
2 files changed, 8 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4a018a6726a3..0aeb02c9db6d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
pkgbase = qt5-datasync
pkgdesc = A simple offline-first synchronisation framework, to synchronize data of Qt applications between devices
pkgver = 2.0.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/Skycoder42/QtDataSync
arch = i686
arch = x86_64
license = BSD
makedepends = git
+ makedepends = qpm
depends = qt5-base
depends = qt5-tools
depends = qt5-jsonserializer>=2.0.0
diff --git a/PKGBUILD b/PKGBUILD
index d6d49f1b9a49..cb85d8765e72 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,22 @@
# Maintainer: Felix Barz <skycoder42.de@gmx.de>
pkgname=qt5-datasync
pkgver=2.0.0
-pkgrel=1
+pkgrel=2
pkgdesc="A simple offline-first synchronisation framework, to synchronize data of Qt applications between devices"
arch=('i686' 'x86_64')
url="https://github.com/Skycoder42/QtDataSync"
license=('BSD')
depends=('qt5-base' 'qt5-tools' 'qt5-jsonserializer>=2.0.0' 'qt5-backgroundprocess>=1.5.0' 'qt5-websockets')
-makedepends=('git')
+makedepends=('git' 'qpm')
source=("$pkgname-$pkgver::git+https://github.com/Skycoder42/QtDataSync.git#tag=$pkgver")
md5sums=('SKIP')
build() {
cd "$pkgname-$pkgver"
+
+ cd src/3rdparty
+ qpm install
+ cd ../..
qmake
make qmake_all