summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSkycoder422017-08-06 11:05:05 +0200
committerSkycoder422017-08-06 11:05:05 +0200
commitcdce953e373f680c0584b60088aa936a244f1c31 (patch)
treeb454d8fa6b1a87b149fcf3da68a2682d63d58c12
parent4f1359c47f89be511c3792c072df24c632b0218b (diff)
downloadaur-cdce953e373f680c0584b60088aa936a244f1c31.tar.gz
update to 3.0.2
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD16
-rw-r--r--qt5-datasync.rule1
3 files changed, 19 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6649836ce1b8..b2286e8b7852 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,23 @@
pkgbase = qt5-datasync
pkgdesc = A simple offline-first synchronisation framework, to synchronize data of Qt applications between devices
- pkgver = 3.0.1
- pkgrel = 3
+ pkgver = 3.0.2
+ pkgrel = 1
url = https://github.com/Skycoder42/QtDataSync
arch = i686
arch = x86_64
license = BSD
+ makedepends = qt5-tools
makedepends = git
makedepends = qpm
depends = qt5-base
- depends = qt5-tools
depends = qt5-jsonserializer>=2.1.0
depends = qt5-backgroundprocess>=1.5.0
depends = qt5-websockets
- source = qt5-datasync-3.0.1::git+https://github.com/Skycoder42/QtDataSync.git#tag=3.0.1
- md5sums = SKIP
+ optdepends = repkg: Automatically rebuild the package on dependency updates
+ source = qt5-datasync-3.0.2::git+https://github.com/Skycoder42/QtDataSync.git#tag=3.0.2
+ source = qt5-datasync.rule
+ sha256sums = SKIP
+ sha256sums = 9bfb38bb6338775f16514f5958c4aef3f55a4132253b0ae1a6ac1ace398a99c4
pkgname = qt5-datasync
diff --git a/PKGBUILD b/PKGBUILD
index b886f85a074b..a0b591750758 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,19 @@
# Maintainer: Felix Barz <skycoder42.de@gmx.de>
pkgname=qt5-datasync
-pkgver=3.0.1
-pkgrel=3
+pkgver=3.0.2
+pkgrel=1
pkgdesc="A simple offline-first synchronisation framework, to synchronize data of Qt applications between devices"
arch=('i686' 'x86_64')
url="https://github.com/Skycoder42/QtDataSync"
license=('BSD')
-depends=('qt5-base' 'qt5-tools' 'qt5-jsonserializer>=2.1.0' 'qt5-backgroundprocess>=1.5.0' 'qt5-websockets')
-makedepends=('git' 'qpm')
+depends=('qt5-base' 'qt5-jsonserializer>=2.1.0' 'qt5-backgroundprocess>=1.5.0' 'qt5-websockets')
+makedepends=('qt5-tools' 'git' 'qpm')
+optdepends=("repkg: Automatically rebuild the package on dependency updates")
_pkgfqn=$pkgname-$pkgver
-source=("$_pkgfqn::git+https://github.com/Skycoder42/QtDataSync.git#tag=$pkgver")
-md5sums=('SKIP')
+source=("$_pkgfqn::git+https://github.com/Skycoder42/QtDataSync.git#tag=$pkgver"
+ 'qt5-datasync.rule')
+sha256sums=('SKIP'
+ '9bfb38bb6338775f16514f5958c4aef3f55a4132253b0ae1a6ac1ace398a99c4')
prepare() {
mkdir -p build
@@ -35,4 +38,5 @@ package() {
-exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
install -D -m644 "../$_pkgfqn/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -D -m644 "../${pkgname}.rule" "$pkgdir/etc/repkg/rules/${pkgname}.rule"
}
diff --git a/qt5-datasync.rule b/qt5-datasync.rule
new file mode 100644
index 000000000000..5cc0cb833247
--- /dev/null
+++ b/qt5-datasync.rule
@@ -0,0 +1 @@
+qt5-base qt5-jsonserializer qt5-backgroundprocess qt5-websockets