summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRiley Trautman2015-06-20 13:39:14 -0500
committerRiley Trautman2015-06-20 13:39:14 -0500
commit84225f43dd8ecf690897f0a7c28e788635225e36 (patch)
tree9b377a3310f4f7a2fc184ef30b0561971cd2d986
downloadaur-84225f43dd8ecf690897f0a7c28e788635225e36.tar.gz
Initial Import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD37
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ce9ca3aabeb6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = qt5-graphicaleffects-git
+ pkgdesc = A cross-platform application and UI framework (QtGraphicalEffects)
+ pkgver = v5.5.0.beta1
+ pkgrel = 1
+ url = https://qt-project.org/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ license = LGPL
+ makedepends = git
+ depends = qt5-declarative-git
+ provides = qt5-graphicaleffects
+ conflicts = qt5-graphicaleffects
+ source = qt5-graphicaleffects::git://code.qt.io/qt/qtgraphicaleffects.git#branch=5.5
+ sha256sums = SKIP
+
+pkgname = qt5-graphicaleffects-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..656b7d65cedb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Jerome Leclanche <jerome@leclan.ch>
+# Contributor: Andrea Scarpino <andrea@archlinux.org>
+# Contributor: Pier Luigi Fiorini <pierluigi.fiorini@gmail.com>
+
+_pkgname=qt5-graphicaleffects
+pkgname=$_pkgname-git
+pkgver=v5.5.0.beta1
+pkgrel=1
+pkgdesc="A cross-platform application and UI framework (QtGraphicalEffects)"
+arch=("i686" "x86_64")
+url="https://qt-project.org/"
+license=("GPL3" "LGPL")
+depends=("qt5-declarative-git")
+makedepends=("git")
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("$_pkgname::git://code.qt.io/qt/qtgraphicaleffects.git#branch=5.5")
+sha256sums=("SKIP")
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ git describe --always | sed "s/-/./g"
+}
+
+prepare() {
+ cd "$srcdir/$_pkgname"
+ mkdir -p build
+ cd build
+ qmake ..
+ make
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ cd build
+ make INSTALL_ROOT="$pkgdir" install
+}