summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12019-02-05 02:55:13 +0800
committerChocobo12019-02-05 02:56:10 +0800
commit9b9152721547906a71da809840e24cacf91781a7 (patch)
treec61d30409103b063b8a3ca48f1b50afed41bad5c
parenteb266d8923a76fc9d3a335a72cd12ab64ba08cc9 (diff)
downloadaur-9b9152721547906a71da809840e24cacf91781a7.tar.gz
upgpkg: qt5-graphicaleffects-git 5.12.1.r6.g8a6aecd-1
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD67
2 files changed, 50 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bcabc692f36a..f4cd3b97872b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,19 @@
pkgbase = qt5-graphicaleffects-git
- pkgdesc = A cross-platform application and UI framework (QtGraphicalEffects)
- pkgver = v5.5.0.1.gb4ef5a9
+ pkgdesc = Qt5 graphical effects module
+ pkgver = 5.12.1.r6.g8a6aecd
pkgrel = 1
- url = https://qt-project.org/
+ url = https://www.qt.io/
arch = i686
arch = x86_64
- license = GPL3
+ license = FDL
+ license = GPL
license = LGPL
+ license = custom
makedepends = git
- depends = qt5-declarative-git
+ depends = qt5-declarative
provides = qt5-graphicaleffects
conflicts = qt5-graphicaleffects
- source = qt5-graphicaleffects::git://code.qt.io/qt/qtgraphicaleffects.git#branch=5.5
+ source = git+https://code.qt.io/qt/qtgraphicaleffects.git#branch=dev
sha256sums = SKIP
pkgname = qt5-graphicaleffects-git
diff --git a/PKGBUILD b/PKGBUILD
index 702584e4c892..161152b4972f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,55 @@
-# Maintainer: Riley Trautman <asonix.dev@gmail.com>
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+# Previous maintainer: Riley Trautman <asonix.dev@gmail.com>
# Contributor: Jerome Leclanche <jerome@leclan.ch>
# Contributor: Andrea Scarpino <andrea@archlinux.org>
# Contributor: Pier Luigi Fiorini <pierluigi.fiorini@gmail.com>
-_pkgname=qt5-graphicaleffects
-pkgname=$_pkgname-git
-pkgver=git
+pkgname=qt5-graphicaleffects-git
+pkgver=5.12.1.r6.g8a6aecd
pkgrel=1
-pkgdesc="A cross-platform application and UI framework (QtGraphicalEffects)"
-arch=("i686" "x86_64")
-url="https://qt-project.org/"
-license=("GPL3" "LGPL")
-depends=("qt5-declarative-git")
-makedepends=("git")
-provides=("$_pkgname")
-conflicts=("$_pkgname")
-source=("$_pkgname::git://code.qt.io/qt/qtgraphicaleffects.git#branch=dev")
-sha256sums=("SKIP")
+pkgdesc="Qt5 graphical effects module"
+arch=('i686' 'x86_64')
+url="https://www.qt.io/"
+license=('FDL' 'GPL' 'LGPL' 'custom')
+depends=('qt5-declarative')
+makedepends=('git')
+provides=('qt5-graphicaleffects')
+conflicts=('qt5-graphicaleffects')
+source=("git+https://code.qt.io/qt/qtgraphicaleffects.git#branch=dev")
+sha256sums=('SKIP')
+
+
+prepare() {
+ cd "$srcdir"
+
+ mkdir -p "_build"
+}
pkgver() {
- cd "$srcdir/$_pkgname"
- git describe --always | sed "s/-/./g"
+ cd "qtgraphicaleffects"
+
+ _tag=$(git tag -l --sort -v:refname | sed -n '1,1{s/v//p}')
+ _rev=$(git rev-list --count v$_tag..HEAD)
+ _hash=$(git rev-parse --short HEAD)
+ printf "%s.r%s.g%s" "$_tag" "$_rev" "$_hash"
}
-prepare() {
- cd "$srcdir/$_pkgname"
- mkdir -p build
- cd build
- qmake ..
- make
+build() {
+ cd "_build"
+
+ qmake ../qtgraphicaleffects
+ make
}
package() {
- cd "$srcdir/$_pkgname"
- cd build
- make INSTALL_ROOT="$pkgdir" install
+ cd "_build"
+
+ make INSTALL_ROOT="$pkgdir" install
+
+ # Drop QMAKE_PRL_BUILD_DIR because reference the build dir
+ find "$pkgdir/usr/lib" -type f -name '*.prl' \
+ -exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
+
+ cd "$srcdir/qtgraphicaleffects"
+ install -Dm644 "LICENSE.GPL3-EXCEPT" "$pkgdir/usr/share/licenses/qt5-graphicaleffects/LICENSE.GPL3-EXCEPT"
}