summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcouney2021-10-17 15:36:14 +0100
committerMarcouney2021-10-17 15:36:14 +0100
commit58a804f3f8b07a9d8b3b204f6c9ab6f058daba37 (patch)
treecf41d39be1f6ae6818b27cf8ba840e8aee42a8e8
parent59535a3c90f113d20b54f6345c3a23f2ceb7d5d3 (diff)
downloadaur-58a804f3f8b07a9d8b3b204f6c9ab6f058daba37.tar.gz
Add kservices thumbnailer, remove patch, update to version 0.3.1
-rw-r--r--.SRCINFO7
-rw-r--r--010-qt-jpegxl-image-plugin-allow-qt6-coinstall.patch39
-rw-r--r--PKGBUILD13
-rw-r--r--jpegxlthumbnail.desktop10
4 files changed, 17 insertions, 52 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 565f7520c7ae..ed6a52e395d7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = qt5-jpegxl-image-plugin-git
pkgdesc = Qt5 plug-in to allow Qt5 and KDE based applications to read/write JXL images (git version)
- pkgver = 0.2.0.r0.geb424dd
+ pkgver = 0.3.1.r0.gc33ed32
pkgrel = 1
url = https://github.com/novomesk/qt-jpegxl-image-plugin
arch = x86_64
@@ -14,10 +14,9 @@ pkgbase = qt5-jpegxl-image-plugin-git
depends = qt5-base
provides = qt5-jpegxl-image-plugin
conflicts = qt5-jpegxl-image-plugin
- options = !emptydirs
source = git+https://github.com/novomesk/qt-jpegxl-image-plugin.git
- source = 010-qt-jpegxl-image-plugin-allow-qt6-coinstall.patch
+ source = jpegxlthumbnail.desktop
sha256sums = SKIP
- sha256sums = 05d7106ddc07a91ae3dccaa8815cf74fa9aef87c12e2961dfadc1240c5f07790
+ sha256sums = d57870099934ebd6fddfc38ca8c6420e891f072e7a3c1779496cc1ad75039315
pkgname = qt5-jpegxl-image-plugin-git
diff --git a/010-qt-jpegxl-image-plugin-allow-qt6-coinstall.patch b/010-qt-jpegxl-image-plugin-allow-qt6-coinstall.patch
deleted file mode 100644
index 2289df0af91a..000000000000
--- a/010-qt-jpegxl-image-plugin-allow-qt6-coinstall.patch
+++ /dev/null
@@ -1,39 +0,0 @@
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -20,7 +20,15 @@ include(KDECMakeSettings)
- include(CheckIncludeFiles)
-
- set(REQUIRED_QT_VERSION 5.14.0)
--find_package(Qt5Gui ${REQUIRED_QT_VERSION} REQUIRED NO_MODULE)
-+string(REGEX MATCH "^[0-9]" REQUIRED_QT_MAJOR "${REQUIRED_QT_VERSION}")
-+set(QT_MAJOR ${REQUIRED_QT_MAJOR} CACHE STRING "Qt major version to use")
-+
-+if(QT_MAJOR GREATER_EQUAL ${REQUIRED_QT_MAJOR})
-+ message(STATUS "Info: building with Qt${QT_MAJOR}")
-+ find_package(Qt${QT_MAJOR}Gui ${REQUIRED_QT_VERSION} REQUIRED NO_MODULE)
-+else()
-+ message(FATAL_ERROR "Qt major version must be at least ${REQUIRED_QT_MAJOR}")
-+endif()
-
- include(FindPkgConfig)
- pkg_check_modules(LibJXL REQUIRED IMPORTED_TARGET libjxl>=0.5.0)
---- a/src/CMakeLists.txt
-+++ b/src/CMakeLists.txt
-@@ -18,7 +18,7 @@ function(kimageformats_add_plugin plugin)
- add_library(${plugin} MODULE ${KIF_ADD_PLUGIN_SOURCES})
- set_property(TARGET ${plugin} APPEND PROPERTY AUTOGEN_TARGET_DEPENDS ${json})
- set_target_properties(${plugin} PROPERTIES LIBRARY_OUTPUT_DIRECTORY "${CMAKE_LIBRARY_OUTPUT_DIRECTORY}/imageformats")
-- target_link_libraries(${plugin} Qt5::Gui)
-+ target_link_libraries(${plugin} Qt${QT_MAJOR}::Gui)
- install(TARGETS ${plugin} DESTINATION ${KDE_INSTALL_QTPLUGINDIR}/imageformats)
- endfunction()
-
-@@ -27,7 +27,7 @@ endfunction()
- if (LibJXL_FOUND)
- kimageformats_add_plugin(libqjpegxl JSON "jpegxl.json" SOURCES "main.cpp" "qjpegxlhandler.cpp")
- target_link_libraries(libqjpegxl PkgConfig::LibJXL PkgConfig::LibJXLThreads)
-- install(FILES jxl.desktop DESTINATION ${KDE_INSTALL_KSERVICES5DIR}/qimageioplugins/)
-+ install(FILES jxl.desktop DESTINATION ${KDE_INSTALL_KSERVICES5DIR}/qimageioplugins/ RENAME jxl_qt${QT_MAJOR}.desktop)
- endif()
-
- ##################################
diff --git a/PKGBUILD b/PKGBUILD
index e085d427d832..13f61fb95f05 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=qt5-jpegxl-image-plugin-git
_pkgname=qt-jpegxl-image-plugin
-pkgver=0.2.0.r0.geb424dd
+pkgver=0.3.1.r0.gc33ed32
pkgrel=1
pkgdesc='Qt5 plug-in to allow Qt5 and KDE based applications to read/write JXL images (git version)'
arch=('x86_64')
@@ -13,25 +13,19 @@ makedepends=('git' 'cmake' 'extra-cmake-modules' 'highway')
checkdepends=('appstream')
provides=('qt5-jpegxl-image-plugin')
conflicts=('qt5-jpegxl-image-plugin')
-options=('!emptydirs')
source=("git+$url.git"
- "010-$_pkgname-allow-qt6-coinstall.patch")
+ 'jpegxlthumbnail.desktop')
sha256sums=('SKIP'
- '05d7106ddc07a91ae3dccaa8815cf74fa9aef87c12e2961dfadc1240c5f07790')
+ 'd57870099934ebd6fddfc38ca8c6420e891f072e7a3c1779496cc1ad75039315')
pkgver() {
git -C $_pkgname describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//'
}
-prepare() {
- patch -d $_pkgname -Np1 -i "$srcdir/010-$_pkgname-allow-qt6-coinstall.patch"
-}
-
build() {
cmake -B build -S $_pkgname \
-DCMAKE_BUILD_TYPE:STRING='None' \
-DCMAKE_INSTALL_PREFIX:PATH='/usr' \
- -DQT_MAJOR:STRING='5' \
-Wno-dev
make -C build
}
@@ -42,4 +36,5 @@ check() {
package() {
make -C build DESTDIR="$pkgdir" install
+ install -D -m644 jpegxlthumbnail.desktop -t "$pkgdir/usr/share/kservices5"
}
diff --git a/jpegxlthumbnail.desktop b/jpegxlthumbnail.desktop
new file mode 100644
index 000000000000..db6255ee7b36
--- /dev/null
+++ b/jpegxlthumbnail.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Type=Service
+Name=JPEG-XL Images
+Name[en_GB]=JPEG-XL Images
+Name[pt]=Imagens JPEG-XL
+Name[pt_BR]=Imagens JPEG-XL
+X-KDE-ServiceTypes=ThumbCreator
+MimeType=image/jxl;
+X-KDE-Library=imagethumbnail
+CacheThumbnail=true