summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSkycoder422019-03-16 17:32:44 +0100
committerSkycoder422019-03-16 17:32:44 +0100
commit427f53c8b94323ef77faf38904cd260f0ae8de22 (patch)
tree53abc60aa0653fdb19a17c39fd96d6de5a7c6146
parentce5ddf32a9c44f1d500fe374d7e50f76f89937ed (diff)
downloadaur-427f53c8b94323ef77faf38904cd260f0ae8de22.tar.gz
updated to 3.3.1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD10
-rw-r--r--missing-headers.patch13
3 files changed, 5 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9301924e3058..88329384be37 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = qt5-jsonserializer
pkgdesc = A library to perform generic seralization and deserialization of QObjects
- pkgver = 3.3.0
- pkgrel = 3
+ pkgver = 3.3.1
+ pkgrel = 1
url = https://github.com/Skycoder42/QtJsonSerializer
arch = i686
arch = x86_64
@@ -13,11 +13,9 @@ pkgbase = qt5-jsonserializer
makedepends = graphviz
depends = qt5-base
optdepends = repkg: Automatically rebuild the package on dependency updates
- source = qt5-jsonserializer-3.3.0::git+https://github.com/Skycoder42/QtJsonSerializer.git#tag=3.3.0
- source = missing-headers.patch
+ source = qt5-jsonserializer-3.3.1::git+https://github.com/Skycoder42/QtJsonSerializer.git#tag=3.3.1
source = qt5-jsonserializer.rule
sha256sums = SKIP
- sha256sums = 37e13775a69ead1e6f4a9ce34bccff519c39e929499e5f7728252e0fc115a3e8
sha256sums = 1b52eef5216017cfb4b399df1775950db544550a68a542053efe00eb8ef34911
pkgname = qt5-jsonserializer
diff --git a/PKGBUILD b/PKGBUILD
index 709dd9a1ddd8..4af51effd331 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
pkgbase=qt5-jsonserializer
pkgname=(qt5-jsonserializer qt5-jsonserializer-doc)
group=qt5-jsonserializer-full
-pkgver=3.3.0
-pkgrel=3
+pkgver=3.3.1
+pkgrel=1
pkgdesc="A library to perform generic seralization and deserialization of QObjects"
arch=('i686' 'x86_64')
url="https://github.com/Skycoder42/QtJsonSerializer"
@@ -13,10 +13,8 @@ makedepends=('git' 'qt5-tools' 'python' 'doxygen' 'graphviz')
optdepends=("repkg: Automatically rebuild the package on dependency updates")
_pkgfqn=$pkgname-$pkgver
source=("$_pkgfqn::git+https://github.com/Skycoder42/QtJsonSerializer.git#tag=$pkgver"
- "missing-headers.patch"
"$pkgname.rule")
sha256sums=('SKIP'
- '37e13775a69ead1e6f4a9ce34bccff519c39e929499e5f7728252e0fc115a3e8'
'1b52eef5216017cfb4b399df1775950db544550a68a542053efe00eb8ef34911')
prepare() {
@@ -24,10 +22,6 @@ prepare() {
}
build() {
- cd "$_pkgfqn"
- git apply ../missing-headers.patch
- cd ..
-
cd build
qmake "../$_pkgfqn/"
diff --git a/missing-headers.patch b/missing-headers.patch
deleted file mode 100644
index d04d2879af6e..000000000000
--- a/missing-headers.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/src/jsonserializer/qjsonserializer.h b/src/jsonserializer/qjsonserializer.h
-index 4e2f54f..3fff0e4 100644
---- a/src/jsonserializer/qjsonserializer.h
-+++ b/src/jsonserializer/qjsonserializer.h
-@@ -21,6 +21,8 @@
- #include <QtCore/qlinkedlist.h>
- #include <QtCore/qvector.h>
- #include <QtCore/qset.h>
-+#include <QtCore/qqueue.h>
-+#include <QtCore/qstack.h>
- #include <QtCore/qhash.h>
- #include <QtCore/qmap.h>
-